mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 17.01.2018 12:16 Benutzername: Passwort: Auto-Login

Thema: Startseite in WordPress vom 15.12.2017


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Web-Software -> Startseite in WordPress
Seite: 1, 2  Weiter
Autor Nachricht
Schmitty
Threadersteller

Dabei seit: 24.06.2013
Ort: -
Alter: 43
Geschlecht: Männlich
Verfasst Fr 15.12.2017 11:09
Titel

Startseite in WordPress

Antworten mit Zitat Zum Seitenanfang

Hallo zusammen,
für ein befreundetes Pärchen habe ich mit WordPress eine Homepage erstellt. Als Startseite habe ich die statische Seite HOME eingestellt. Dieses funktioniert soweit auch. In der Navigationsleiste allerdings wird mir nun nicht mehr "Home" angezeigt, sondern das Wort "Startseite", wo sich dann die Seite HOME hinter verbirgt. Die Formatierung des Wortes "Startseite" ist auch anders als der Rest der Navigation.
Muss ich irgendwas beachten oder ein-/umstellen, damit die Seite HOME zwar weiterhin meine Startseite ist, diese aber in der Navigation auch als "Home" angezeigt wird?
  View user's profile Private Nachricht senden
xBe

Dabei seit: 03.06.2006
Ort: Mönchengladbach
Alter: 28
Geschlecht: Männlich
Verfasst Fr 15.12.2017 12:27
Titel

Antworten mit Zitat Zum Seitenanfang

gib uns doch mal einen Link oder einen Screenshot, dann ist da sganze einfacher Lächel

grs
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Schmitty
Threadersteller

Dabei seit: 24.06.2013
Ort: -
Alter: 43
Geschlecht: Männlich
Verfasst So 17.12.2017 13:54
Titel

Antworten mit Zitat Zum Seitenanfang




Ich hoffe, das hilft Euch weiter und somit auch mir Lächel

Falls es noch wichtig sein sollte, ich nutze das Theme "BizGrowth".
  View user's profile Private Nachricht senden
xBe

Dabei seit: 03.06.2006
Ort: Mönchengladbach
Alter: 28
Geschlecht: Männlich
Verfasst Mo 18.12.2017 09:39
Titel

Antworten mit Zitat Zum Seitenanfang

sieht aus als wäre eine "active"-Klasse falsch formatiert.
Schau mal in die CSS
  View user's profile Private Nachricht senden
Schmitty
Threadersteller

Dabei seit: 24.06.2013
Ort: -
Alter: 43
Geschlecht: Männlich
Verfasst Mo 18.12.2017 12:10
Titel

Antworten mit Zitat Zum Seitenanfang

Also, die Formatierung des Links habe ich nun korrigiert.
Was aber kann ich machen, dass statt dem Begriff "Startseite" wieder "Home" erscheint. Liegt das am Theme? Kann ich das einstellen? Muss ich irgendwas beachten? Auf anderen Homepage lässt sich auch eine Seite als Startseite festlegen, diese wird dann aber nicht in "Startseite" umbenannt.
  View user's profile Private Nachricht senden
xBe

Dabei seit: 03.06.2006
Ort: Mönchengladbach
Alter: 28
Geschlecht: Männlich
Verfasst Mo 18.12.2017 12:26
Titel

Antworten mit Zitat Zum Seitenanfang

ich bin mir nicht ganz sicher, aber ich glaube das es für die themes auch sprachdateien gibt, hört sich für mich so an als würde die berzeichnung überschrieben.
  View user's profile Private Nachricht senden
l8rdude

Dabei seit: 30.07.2009
Ort: Nordhorn
Alter: -
Geschlecht: Männlich
Verfasst Mo 18.12.2017 13:56
Titel

Antworten mit Zitat Zum Seitenanfang

Moin Schmitty,

meine Vermutung ist folgende:

In der header.php deines Themes lässt du ein automatisch generiertes Seitenmenü ausgeben mittels wp_page_menu(). Entweder wurde dort als Argument "show_home" mit true übergeben oder aber ein Filter ändert diese Parameter (siehe: wp_page_menu_args Filter; in der Regel werden diese in der functions.php hinzugefügt).
Wenn show_home auf "true" gesetzt ist, fügt WordPress automatisch den Menüpunkt "Home" an erster Stelle hinzu. Die Standard-WordPress Übersetzung von "Home" ist "Startseite". Du kannst das prüfen, in dem du im Backend die Sprache temporär auf Englisch umstellst. Du solltest im Menü dann "Home" statt "Startseite" sehen.


Falls das soweit passt, kannst du folgende Alternative wählen:


1. Registriere in deiner functions.php eine Menüposition, z.B. "header": https://developer.wordpress.org/reference/functions/register_nav_menu/

Code:
add_action( 'after_setup_theme', 'register_my_menu' );
 
function register_my_menu() {
    register_nav_menu( 'header', 'Headermenü' );
}


2. In deiner header.php verwendet du zur Ausgabe nicht mehr wp_page_menu() sondern stattdessen wp_nav_menu(). Als Parameter für 'theme_location' übergibst du den Wert aus der register_nav_menu() Funktion, also 'header':

Code:
wp_nav_menu( array( 'theme_location' => 'header' ) );


3. Im Backend erstellst du unter "Design - Menüs" ein neues Menü und weist es deiner registrierten Menüposition zu. Im Menüeditor kannst du das Menü jetzt nach Belieben erstellen, sortieren und anpassen. Tipp: Im Menüeditor unter "Ansicht anpassen" verstecken sich weitere Anpassungsmöglichkeiten wie beispielsweise "CSS-Klassen".


Grüße,


Zuletzt bearbeitet von l8rdude am Mo 18.12.2017 13:56, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Schmitty
Threadersteller

Dabei seit: 24.06.2013
Ort: -
Alter: 43
Geschlecht: Männlich
Verfasst Mo 18.12.2017 15:26
Titel

Antworten mit Zitat Zum Seitenanfang

Ich glaub, ich hab es geschafft Lächel

In der Datei "bizgrowth-extras.php" habe ich den Eintrag

Code:
function bizgrowth_page_menu_args( $args ) {
   $args['show_home'] = true;
   return $args;
}


auf

Code:
function bizgrowth_page_menu_args( $args ) {
   $args['show_home'] = false;
   return $args;
}


geändert. Nun wird mir die Startseite auch wieder als "Home" angezeigt und nicht mehr durch "Startseite" überschrieben.
  View user's profile Private Nachricht senden
 
Ähnliche Themen xtcommerce - Angebot von Startseite entfernen
Plesk: Startseite des Servers ändern
Wordpress MU vs. Wordpress 3.0
Wordpress Navigation
Wordpress Template
Wordpress ... Hilfe...
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Web-Software


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.