mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 10.12.2016 13:52 Benutzername: Passwort: Auto-Login

Thema: loadMovie - unloadMovie Problem vom 26.08.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> loadMovie - unloadMovie Problem
Autor Nachricht
Flextone
Threadersteller

Dabei seit: 29.06.2005
Ort: -
Alter: 35
Geschlecht: Männlich
Verfasst Fr 26.08.2005 11:01
Titel

loadMovie - unloadMovie Problem

Antworten mit Zitat Zum Seitenanfang

hallo,

ich habe eine frage. ich habe eine grundebene mit einem button names "movie".
und ich habe einen movieclip namens "clip". der "clip" enthält einfach nur einen kasten der von alpha 0% auf alpha 100% fadet. bei den 100% stopt er. er würde dann gleich wieder auf 0% auslaufen, um den ablauf gleich zu behalten.

ich habe über dem button "movie" eine maske mit dem befehl:

on(release){
_root.loader.loadMovie("clip.swf",1);
}

um den "clip" einzuladen mit preloader und Co.

Nur wenn ich nun wieder "movie" drück würde er aprupt aufhören da ich durch:

on(release){
_root.loader.unloadMovie("clip.swf");
}

den "clip" wieder rausnehme.

meine frage:

wie kann ich dem "clip" über "movie" sagen, dass er nicht aprupt raus soll sondern zu der stelle wo er wieder auf 0% fadet ?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Fr 26.08.2005 13:53
Titel

Antworten mit Zitat Zum Seitenanfang

Soll der Clip auf 0% zurückfaden? Dann bau dir Steuervariablen ein, die du auf true/false stellst. Dann rufst du bei Buttonklick eine Funktion auf, die den Film zurücklaufen lässt und rufst dabei die Steuervariablen ab. Ist sie true tritt unloadMovie in Kraft, ist sie falsch, wird die Animation fertiggespielt. Alternativ zum Zürücklaufen des Filmes könntest du auch die Animation in soweit erweitern, so dass sie von 100% auf 0% zurückläuft.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
 
Ähnliche Themen LoadMovie Problem ... einfach zu langsam !
[Flash MX] Problem mit Preloader für LoadMovie
[Flash AS2] loadmovie problem
[Flash] Problem mit loadmovie /Bilder reinladen
[Flash] Helft mal bitte schnell weiter - unloadMovie()
[FlashMX]loadMovie in einem MC
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.