mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 10.12.2016 23:23 Benutzername: Passwort: Auto-Login

Thema: Fehlerhafte Links in Kommentaren von Wordpress vom 16.11.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Software - Nonprint -> Fehlerhafte Links in Kommentaren von Wordpress
Seite: 1, 2, 3  Weiter
Autor Nachricht
marta hansen
Threadersteller

Dabei seit: 12.08.2005
Ort: Berlin
Alter: 33
Geschlecht: Weiblich
Verfasst Do 16.11.2006 12:28
Titel

Fehlerhafte Links in Kommentaren von Wordpress

Antworten mit Zitat Zum Seitenanfang

hallo ihr,

ich hab n problem in wordpress.
und zwar werden bei kommentaren, dann wahrscheinlich auch text, die links nicht richtig dargestellt.

im wordpress forum stand alle links mit http:// zu beginnen, hat aber leider nicht geholfen. kurze links mit http:// werden problemlos übernommen. längere links, auch mit http:// vorneweg, werden aber willkürlich gekürzt, wordpress setzt die blogdomain davor und klammert die linkadresse in \ also z.b. <a href="http://blog.domain.de%20%5Chttp://link%20%5C" ...>.
es wurde auch weiterhin vorgeschlagen den rte abzuschalten. auch das hat kein ergebniss gebracht. der fehler muss also irgendwo im speicherprozess liegen.

hat jemand ne lösung wie auch längere links oder text, welcher nicht den link als text entält, problemlos dargestellt werden können?

vielen dank für eure mühen Lächel
  View user's profile Private Nachricht senden
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Do 16.11.2006 13:37
Titel

Antworten mit Zitat Zum Seitenanfang

Wordpress-Version?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
marta hansen
Threadersteller

Dabei seit: 12.08.2005
Ort: Berlin
Alter: 33
Geschlecht: Weiblich
Verfasst Do 16.11.2006 13:59
Titel

Antworten mit Zitat Zum Seitenanfang

version 2.0.3
  View user's profile Private Nachricht senden
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Do 16.11.2006 14:07
Titel

Antworten mit Zitat Zum Seitenanfang

Beispiel?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
marta hansen
Threadersteller

Dabei seit: 12.08.2005
Ort: Berlin
Alter: 33
Geschlecht: Weiblich
Verfasst Do 16.11.2006 15:49
Titel

Antworten mit Zitat Zum Seitenanfang

so sieht ein langer link aus:
die auskommentierungen werden durch wordpress automatisch hinzugefügt, daher funktioniert der link auch nicht.

Code:
<a href=\"http://www.web-analytics.org/index.php/webanalyse-artikel/weiter/jupiterresearch_studie_nutzer_loeschen_cookies/\" rel="nofollow">löschen Nutzer ihre Cookies häufiger als erwartet</a>


verlinkt werden sollte:
http://www.web-analytics.org/index.php/webanalyse-artikel/weiter/jupiterresearch_studie_nutzer_loeschen_cookies
mit dem Text: löschen Nutzer ihre Cookies häufiger als erwartet


weiteres problem:
beim versuch den oben genannten link als text (also der link wird direkt im kommentar als text aufgeführt) zu verlinken ensteht folgender quelltext
Code:

(<a href=\"http://www.web-analytics.org/index.php/webanalyse-artikel/weiter/jupiterresearch_studie_nutzer_loeschen_cookies/\" rel="nofollow"><a href='http://www.web-analytics.org/index.php/webanalyse-artikel/' rel='nofollow'>http://www.web-analytics.org/index.php/webanalyse-artikel/</a> weiter/jupiterresearch_studie_nutzer_loeschen_cookies/</a>)


wie man sieht wird hier nur bis zum ersten leerzeichen verlinkt (was ich im rte aber nicht gemacht habe) und auch der link wird nur bis zu dieser stelle gesetzt und ist damit falsch


und einen haben wir noch:
Code:
<a target=\"_blank\" href=\"http://openpr.de/news/102910/\" rel="nofollow"><a href='http://openpr.de/news/102910/' rel='nofollow'>http://openpr.de/news/102910/</a></a>


diese links funktionieren zwar, werden aber "doppelt" gesetzt (ineinander verschachtelt). nach weiteren speichervorgängen sieht der link dann so aus:

Code:
<a rel=\"\\\"\\\\\\\"nofollow\\\\\\\"\\\"\" href=\"http://blog.domain.de/%5C%22http://blog.domain.de/%5C%22http://blog.domain.de/%5C%22http://openpr.de/news/102910/%5C%22%5C%22%5C%22\" rel="nofollow">


bitte habt verständnis dafür, dass ich euch den original code nicht zur verfügung stellen kann, da es sonst auf der seite ständig fehlerhafter code ausgegeben werden würde.
  View user's profile Private Nachricht senden
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Do 16.11.2006 15:57
Titel

Antworten mit Zitat Zum Seitenanfang

Nimm auf jeden Fall mal die ganzen Backslashes raus.

Bei mir funktioniert der Link problemlos. Es gibt auch keine Längenbeschränkung
in WP.

Auf jeden Fall solltest Du mal auf die Version 2.0.5 aktualisieren, evtl. gibt es
in der 2.0.3 einen Bug.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
marta hansen
Threadersteller

Dabei seit: 12.08.2005
Ort: Berlin
Alter: 33
Geschlecht: Weiblich
Verfasst Do 16.11.2006 16:03
Titel

Antworten mit Zitat Zum Seitenanfang

tacker hat geschrieben:
Nimm auf jeden Fall mal die ganzen Backslashes raus.


ich habe erwähnt, dass wordpress diese automatisch einfügt. ich kann nicht bei jedem neuen link, erstmal alle automatisch hinzugefügten backslashes entfernen.

der link ist ja auch nicht das problem, sondern das was wordpress daraus macht. es wäre auch ziemlich unsinnig auf eine nicht vorhandene seite zu verlinken *balla balla*


Zuletzt bearbeitet von marta hansen am Do 16.11.2006 16:05, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Do 16.11.2006 17:15
Titel

Antworten mit Zitat Zum Seitenanfang

Ok, hat das Update geholfen?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Wordpress : "Hefter - Links" und Bildverlinkungen
Toggledisplay unter Kommentaren will nicht funktionieren ?
Fehlerhafte E-Mail Signatur
fehlerhafte Schriftdarstellung in Photoshop
Fehlerhafte Darstellung von Site mit Iframes im IE
Word --> PDF (fehlerhafte Konvertierung)
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2, 3  Weiter
MGi Foren-Übersicht -> Software - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.