mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 18:54 Benutzername: Passwort: Auto-Login

Thema: [Flash MX] schleifenprogramminerung funktionier nicht vom 24.03.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [Flash MX] schleifenprogramminerung funktionier nicht
Autor Nachricht
ZeroFlash
Threadersteller

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Fr 24.03.2006 08:17
Titel

[Flash MX] schleifenprogramminerung funktionier nicht

Antworten mit Zitat Zum Seitenanfang

hab folgendes problem

hab mir ne testdatei aufgebaut, die wie meine richtige datei ist.
hab auf das erste schlüsselbild ne action gelegt:
counter=0;

so dann nach 30 schlüsselbildern wieder ne action:
counter=counter+1;
if(counter=3) {
stop();
this._parent._parent._parent.play();
};

so in der datei geht das auch alles bestens. ich brauche so viele parent, da in meiner richtigen datei die animation
so verzewigt aufgebaut ist.

mein problem ist, wenn ich das in meiner richtigen animation einbaue, alles nach dem gleichen schema, spielt er mit die schleife einmal ab und springt dann gleich die drei "ebenen" zurück.

ich versteh das nicht * Keine Ahnung... * woran kann das liegen?
  View user's profile Private Nachricht senden
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Fr 24.03.2006 08:40
Titel

Re: [Flash MX] schleifenprogramminerung funktionier nicht

Antworten mit Zitat Zum Seitenanfang

wenn
Code:
if(counter==3)


nicht
Code:
if(counter=3)


*zwinker*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
ZeroFlash
Threadersteller

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Fr 24.03.2006 09:05
Titel

Antworten mit Zitat Zum Seitenanfang

merci Lächel

jetzt gehts bestens

btw: wieso ging es in der testdatei mit einem = ?
  View user's profile Private Nachricht senden
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Fr 24.03.2006 09:13
Titel

Antworten mit Zitat Zum Seitenanfang

ZeroFlash hat geschrieben:
merci Lächel

jetzt gehts bestens

btw: wieso ging es in der testdatei mit einem = ?


Nen Player, der die alte Syntax liest? * Keine Ahnung... *

Seit Flash 5 wird zwischen "=" (einfacher Zuweisungsoperator) "==" (Gleichheit) und ab Flash 6 zusätzlich noch "===" strikte Gleichheit unterschieden.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
ZeroFlash
Threadersteller

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Fr 24.03.2006 09:46
Titel

Antworten mit Zitat Zum Seitenanfang

hmm ja das kann sein, dass ich noch den flash 5 player drauf hab. aber habs ja in mx gemacht und dann dort über film testen probiert. und das er dann nen älteren player nimmt ist ja unwahrscheinlich, vorallem, da es ja mit ner älteren version gemacht ist... sehr merkwürdig

na egal jetzt gehts Lächel
  View user's profile Private Nachricht senden
 
Ähnliche Themen Ajaxanfänge wollen nach mehrmaligem prüfen nicht funktionier
Login-System funktionier nur HALB
div "bottom" ausrichten funktionier im IE nicht
[Flash,Swish] von Flash aus eine bestimmte Scene,Frame Laden
reine Flash-Seite oder lieber nur mit Flash-Elementen
Flash-Animationen OHNE Macromedia Flash-Player abspielen
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.