mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 13.11.2019 01:16 Benutzername: Passwort: Auto-Login

Thema: SVG- Probleme bei Animation vom 23.01.2011


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> SVG- Probleme bei Animation
Autor Nachricht
marlen184
Threadersteller

Dabei seit: 23.01.2011
Ort: Dresden
Alter: 28
Geschlecht: Weiblich
Verfasst So 23.01.2011 18:15
Titel

SVG- Probleme bei Animation

Antworten mit Zitat Zum Seitenanfang

Hallo Leute, und zwar versuche ich meine SVG Grafik zu animieren. Ich habe zwar herausgefunden wie das alles funktioniert und auch alles im Quelltext eingegeben wie es da steh (also war bei selfsvg) aber es zeigt mir keine Animation an.

Ich kann euch ja mal den Quelltext bzw den Abschnitt zeigen um den es sich handelt. Weiß ja nicht ob ich ein zeichen oder irgendwas übersehen habe aber jedenfalls funktioniert es bei mir einfach nicht.
Ziel ist es ein Auge zu Animieren welches groß und wieder klein wird.


<circle cx="200" cy="200" r="130"
fill="blue" stroke="black"
stroke-width="10" >
<animate attributeName="r" from="130" to="70" begin="0s" dur="2s" fill="freeze" />
</circle>

bzw der komplette Quelltext vlt is da irgendwas falsch:


<?xml version="1.0" standalone="no" ?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 20010904//EN"
"http://www.w3.org/TR/2001/REC-SVG-20010904/DTD/svg10.dtd">
<svg width="1000" height="1000" xmlns="http://www.w3.org/2000/svg"
xmlns:xlink="http://www.w3.org/1999/xlink">

<title>Die Animation</title>

<rect x="50" y="100" width="700" height="600"
rx="500" ry="480"
fill="#FFD39B" stroke="#EEC591"
stroke-width="15" />


<circle cx="200" cy="200" r="130"
fill="blue" stroke="black"
stroke-width="10" >
<animate attributeName="r" from="130" to="70" begin="0s" dur="2s" fill="freeze" />
</circle>
<circle cx="250" cy="250" r="50"
fill="black" stroke="#68228B"
stroke-width="10" />
<circle cx="600" cy="200" r="70"
fill="white" stroke="black"
stroke-width="10" />
<circle cx="600" cy="200" r="20"
fill="black" stroke="green"
stroke-width="10" />

<line x1="330" y1="30" x2="370" y2="150"
style="stroke:black; stroke-width:10px;" />
<line x1="450" y1="50" x2="420" y2="130"
style="stroke:black; stroke-width:5px;" />
<line x1="600" y1="20" x2="480" y2="150"
style="stroke:black; stroke-width:10px;" />


<ellipse cx="400" cy="630"
rx="150" ry="50"
fill="red" />

<ellipse cx="400" cy="630"
rx="100" ry="10"
fill="#8B0000" />

<rect fill="#CDAA7D" stroke="#8B7355" stroke-width="10"
rx="150" ry="300"
x="350" y="300" width="100" height="200" />
</svg>


danke schon mal im voraus.
  View user's profile Private Nachricht senden
zweitaccount

Dabei seit: 25.01.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst So 23.01.2011 23:10
Titel

Antworten mit Zitat Zum Seitenanfang

Hi,
speichere die Datei mal als *.svg und öffne die dann mal
im Brower, dann dürfte auch die Animation funzen.

Grüße
zweitaccount
  View user's profile Private Nachricht senden
Anzeige
Anzeige
marlen184
Threadersteller

Dabei seit: 23.01.2011
Ort: Dresden
Alter: 28
Geschlecht: Weiblich
Verfasst Mo 24.01.2011 11:43
Titel

Antworten mit Zitat Zum Seitenanfang

hab ich ja auch schon alles versucht aber finde komplett keine lösung. hatte auch shcon eine andere art von animation versucht aber da ist das selbe problem, es zeigt zwar keinen fehler an aber animation spielt es nicht ab.

kann man das ni noch auf eine andere art und weiße abspielen lassen?

ich öffne das ja immer mit firefox
  View user's profile Private Nachricht senden
zweitaccount

Dabei seit: 25.01.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst Mo 24.01.2011 12:01
Titel

Antworten mit Zitat Zum Seitenanfang

Achso, mein Firefox hier, will das auch nicht animieren.
Nimm doch mal einen Webkit (Chrome oder so) oder
auch den IE8, dort funktioniert das mit dem <animate>

Grüße
  View user's profile Private Nachricht senden
 
Ähnliche Themen svg animation verzögerung wiederholung
ai --> svg ?
SVG druckproblem
Nachteile von SVG
SVG skalieren
Illustrator kann svg nicht lesen
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.