mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 02.12.2022 01:05 Benutzername: Passwort: Auto-Login

Thema: youtube API verweigert zugriff vom 08.04.2011


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Programmierung -> youtube API verweigert zugriff
Seite: 1, 2  Weiter
Autor Nachricht
Psilo
Threadersteller

Dabei seit: 20.02.2007
Ort: -
Alter: 34
Geschlecht: Männlich
Verfasst Fr 08.04.2011 12:39
Titel

youtube API verweigert zugriff

Antworten mit Zitat Zum Seitenanfang

hi,

ich habe eine seite, welche auf der youtube api aufgebaut ist..
soweit funktioniert alles..

jedoch kann ich seit circa drei tagen keine kommentare und keine user infos mehr abfragen.
diese daten erhalte ich normalerweiße in form einer xml datei..

lokal funktioniert das alles.
sobald ich das ganze jedoch über meine domain teste erhalte ich keine xml daten mehr..

als ob youtube meine domain gesperrt hätte..
jedoch kann ich noch immer die video infos abrufen.. lediglich die kommentare und user infos nicht

weiß jemand woran das liegen könnte?

danke
  View user's profile Private Nachricht senden
Zeithase

Dabei seit: 09.05.2005
Ort: Erfurt
Alter: 38
Geschlecht: Männlich
Verfasst Fr 08.04.2011 12:49
Titel

Antworten mit Zitat Zum Seitenanfang

An Deinem Duschbad.










Eindeutig.






Glaskugel

Welchen Fehler gibt's denn?
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Psilo
Threadersteller

Dabei seit: 20.02.2007
Ort: -
Alter: 34
Geschlecht: Männlich
Verfasst Fr 08.04.2011 12:54
Titel

Antworten mit Zitat Zum Seitenanfang

naja...
ich erwarte keine fehlerbehebung sondern eher ne antwort ob es möglich ist, dass youtube domains für gewisse inhalte blockt...

der fehler:
Fatal error: Call to a member function children() on a non-object in......

die function children() funktioniert nicht, da sie auf einen leeren inhalt angewendet wird.
lokal funktioniert alles, da ich dort eine xml datei auslesen kann...
online ist die xml datei dann leer wenn ich sie abfrage..

vor ein paar tagen ging noch alles...
  View user's profile Private Nachricht senden
Psilo
Threadersteller

Dabei seit: 20.02.2007
Ort: -
Alter: 34
Geschlecht: Männlich
Verfasst Mi 20.04.2011 13:25
Titel

Antworten mit Zitat Zum Seitenanfang

youtube api blockt mich.. wie kann das sein?
hat denn hier keiner ahnung von der api?
wäre sehr dankbar für hilfe


Warning: simplexml_load_file(http://gdata.youtube.com/feeds/api/standardfeeds/most_viewed?time=this_week&start-index=1&max-results=20) [function.simplexml-load-file]: failed to open stream: HTTP request failed! HTTP/1.0 403 Forbidden in /hp/br/ac/wj/www/anschauenoderauchnet/functions/trends.php on line 8

Warning: simplexml_load_file() [function.simplexml-load-file]: I/O warning : failed to load external entity "http://gdata.youtube.com/feeds/api/standardfeeds/most_viewed?time=this_week&start-index=1&max-results=20" in /hp/br/ac/wj/www/anschauenoderauchnet/functions/trends.php on line 8

Warning: Invalid argument supplied for foreach() in /hp/br/ac/wj/www/anschauenoderauchnet/functions/trends.php on line 9
Es wurden keine Videos zu der Suchanfrage nach gefunden


www.anschauenoderauch.net
  View user's profile Private Nachricht senden
bacon

Dabei seit: 24.10.2007
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 20.04.2011 13:41
Titel

Antworten mit Zitat Zum Seitenanfang

Du sitzt da jetzt 10 Tage dran und bist nicht in der Lage, mal durch die Doku zu steigen? Wie sollen wir denn wissen, wie Deine Netzinfrastruktur, Firewall oder whatwever aussieht?? Und hast Du den ersten Kommentar auf der php.net eigenen Dokuseite zu simplexml_load_file() gelesen?? Woher sollen wir wissen, ob Du das schon berücksichtigt hast - wo Du doch gar keinen Sourcecode gepostet hast?

Zitat:
If you find that you are receiving 500 errors with simplexml_load_file() but you can access the xml/rss feed manually through a browser, your script is probably being blocked by a user agent sniffer.

Add this code before your xml call to remedy this issue

<?php

ini_set("user_agent","Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)");
ini_set("max_execution_time", 0);
ini_set("memory_limit", "10000M");

$rss = simplexml_load_file($feed_url);

?>
  View user's profile Private Nachricht senden
Psilo
Threadersteller

Dabei seit: 20.02.2007
Ort: -
Alter: 34
Geschlecht: Männlich
Verfasst Mi 20.04.2011 13:51
Titel

Antworten mit Zitat Zum Seitenanfang

ich will keine LÖSUNG...
ich will lediglich wissen ob youtube Domains blockt und wo ich das prüfen kann...

außerdem ging doch bis jetzt alles... also am code liegt es höchstwahrscheinlich nicht...

und das problem besteht erst seit heute...

das problem vor zehn tagen war, das ich nicht auf den kommentar feed zugreifen konnte..

Und wer lesen kann ist klar im vorteil, denn das script läuft fehlerfrei auf dem localhost.. soviel zum code
  View user's profile Private Nachricht senden
bacon

Dabei seit: 24.10.2007
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 20.04.2011 13:58
Titel

Antworten mit Zitat Zum Seitenanfang

Ich habe auch keine Lösung gepostet - soviel zum "Wer lesen kann ...".

Man ich bin´s so leid euch Dumpfbacken das Hirn zu ersetzen... tut mir schon leid, dass ich gepostet hab.
  View user's profile Private Nachricht senden
DerM

Dabei seit: 18.01.2009
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Mi 20.04.2011 15:57
Titel

Antworten mit Zitat Zum Seitenanfang

Psilo hat geschrieben:

Und wer lesen kann ist klar im vorteil, denn das script läuft fehlerfrei auf dem localhost.. soviel zum code


Hmm keine Ahnung, aber vllt hast du ne Datei mit falschem API Key hochgeladen, oder so ??
Sind die Keys nicht Domain gebunden?

Localhost != Online where ever ....

Schinken hat geschrieben:

Man ich bin´s so leid euch Dumpfbacken das Hirn zu ersetzen... tut mir schon leid, dass ich gepostet hab.


Tja.. Wat willste machen.. Außer immer wieder an das gute im TE zu denken * Keine Ahnung... *
  View user's profile Private Nachricht senden
 
Ähnliche Themen XAMPP > zugriff bzw. schreiben verweigert ?
[Hilfe] Navi über JS ergibt Fehler "Zugriff verweigert&
DIV verweigert 100% Höhe
Dreamweaver verweigert die seriennummer
Photoshop CC verweigert Umlaute
pflege verweigert und nachträglich cms angeboten
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Programmierung


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.