mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 20:59 Benutzername: Passwort: Auto-Login

Thema: [flash]kontaktformular sendet leere Felder vom 24.06.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [flash]kontaktformular sendet leere Felder
Seite: 1, 2  Weiter
Autor Nachricht
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 13:05
Titel

[flash]kontaktformular sendet leere Felder

Antworten mit Zitat Zum Seitenanfang

Hallo Leute!


Ich geh ein! In meinem Büro herrschen Sauna-ähnliche Zustände
und mein Job bringt mich zur Verzweiflung...

Ich bastel grad an nem Kontaktformular aus Flash MX 2004. Ein
Kollege hat mir zum "Nachbauen" ein funktionierendes Fla von
ihm gegeben. Aber hier werden nur leere Felder gesendet.
Das Ergebnis:
>Von:
>Strasse:
>PLZ/Ort:
>Telefon:
>E-mail:
>Nachricht:

Warum nur?

Hab die Felder so angelegt:
Eingabefeld, Instanz bezeichnet (z.B. Name1), Variable angegeben
(z.B. Name), das gesamte Formular in einem Movieclip

Im AS in der Fla steht auf dem 1. Bild:
stop();
absender = "www........";
empfaenger = ".....@.......";
betreff = "Anfrage";

Die beigehörige kontakt.php lautet folgendermaßen:
<?php

$sender = "From: $absender";

$mailbody = "Von: $name $vorname\n";
$mailbody = $mailbody."Strasse: $strasse_nr\n";
$mailbody = $mailbody."PLZ/Ort: $plz_ort\n";
$mailbody = $mailbody."Telefon: $telefon\n";
$mailbody = $mailbody."E-Mail: $email\n";
$mailbody = $mailbody."Nachricht: $nachricht\n\n";

mail($empfaenger,$betreff,$mailbody,$sender);

?>

Gibt's hier jemanden, für den das nicht nur wie Chinesisch ist
und der ne Idee hat, wo der Fehler begraben ist?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Fr 24.06.2005 13:14
Titel

Antworten mit Zitat Zum Seitenanfang

zumglück hat dein provider register_globals ausgeschaltet. schick ihm ne mail dass du ihm dankbar dafür bist. danach lies die php-dokue zu den suberglobals $_GET, $_POST und $_REQUEST.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 13:23
Titel

Antworten mit Zitat Zum Seitenanfang

Ok, hab kein Wort verstanden! Au weia!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
theflu

Dabei seit: 07.08.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Fr 24.06.2005 13:47
Titel

Antworten mit Zitat Zum Seitenanfang

bk1 hat geschrieben:
Ok, hab kein Wort verstanden! Au weia!


nicht deine schuld, gtz provilierungswahn... * Nee, nee, nee *

kann dir da leider auch nicht weiterhelfen...
  View user's profile Private Nachricht senden
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 13:51
Titel

Antworten mit Zitat Zum Seitenanfang

Danke für die aufbauenden Worte....

Tja, vieleicht kann mir ja noch jemand anders helfen. *hu hu huu*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Fr 24.06.2005 14:10
Titel

Antworten mit Zitat Zum Seitenanfang

du greifst auf die übergebenen werte direkt zu via $schiessmichtot. auf einem anständigen server wird eine formularvariabele schiessmichtot aber nich zu $schiessmichtot, sondern zu $_REQUEST['schiessmichtot'].
ein blick ins php-manual an der von mir angegebenen stelle hätte dir das in 3 sekunden verraten.


Zuletzt bearbeitet von gtz am Fr 24.06.2005 14:10, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 14:27
Titel

Antworten mit Zitat Zum Seitenanfang

gtz hat geschrieben:
du greifst auf die übergebenen werte direkt zu via $schiessmichtot. auf einem anständigen server wird eine formularvariabele schiessmichtot aber nich zu $schiessmichtot, sondern zu $_REQUEST['schiessmichtot'].
ein blick ins php-manual an der von mir angegebenen stelle hätte dir das in 3 sekunden verraten.


Ich hab von PHP echt mal so 0 Ahnung...wie gesagt, die PHP-Datei kommt von nem Kollegen und ich
hab sie einfach so übernommen und gehofft, dass alles klappt. Und bei ihm klappt es ja auch so.

Was muss ich denn jetzt an dem PHP-Text umtippen, damit es deiner Meinung nach funzt?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Fr 24.06.2005 14:59
Titel

Antworten mit Zitat Zum Seitenanfang

gtz hat geschrieben:
nich zu $schiessmichtot, sondern zu $_REQUEST['schiessmichtot'].
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Kontaktformular sendet leere Inhalte
[php] Kontaktformular sendet nicht
Php Kontaktformular sendet nicht
Kontaktformular für / in Flash
Kontaktformular in Flash MX
Kontaktformular in Flash?
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.