mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 20:31 Benutzername: Passwort: Auto-Login

Thema: [flash]kontaktformular sendet leere Felder vom 24.06.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [flash]kontaktformular sendet leere Felder
Seite: Zurück  1, 2
Autor Nachricht
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 15:09
Titel

Antworten mit Zitat Zum Seitenanfang

gtz hat geschrieben:
gtz hat geschrieben:
nich zu $schiessmichtot, sondern zu $_REQUEST['schiessmichtot'].


Also lautet meine php-Datei dann:

<?php

$sender = "From: $_REQUEST['absender'];

$mailbody = "Von: $_REQUEST['name'] $_REQUEST['vorname\n']";
$mailbody = $mailbody."Strasse: $_REQUEST['strasse_nr\n']";
$mailbody = $mailbody."PLZ/Ort: $_REQUEST['plz_ort\n']";
$mailbody = $mailbody."Telefon: $_REQUEST['telefon\n']";
$mailbody = $mailbody."E-Mail: $_REQUEST['email\n']";
$mailbody = $mailbody."Nachricht: $_REQUEST['nachricht\n\n']";

mail($empfaenger,$betreff,$mailbody,$sender);

?>


Richtig oder nicht?! Menno!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Fr 24.06.2005 15:12
Titel

Antworten mit Zitat Zum Seitenanfang

bk1 hat geschrieben:

Richtig oder nicht?! Menno!


wenns so nich geht, liegts an was andrem.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 24.06.2005 15:16
Titel

Antworten mit Zitat Zum Seitenanfang

gtz hat geschrieben:
bk1 hat geschrieben:

Richtig oder nicht?! Menno!


wenns so nich geht, liegts an was andrem.


Dann schon mal danke, ich probier's heute Abend aus.

Wenn's nicht klappt, nerv ich euch alle am Montag weiter...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Mo 27.06.2005 15:48
Titel

Antworten mit Zitat Zum Seitenanfang

bk1 hat geschrieben:
gtz hat geschrieben:
gtz hat geschrieben:
nich zu $schiessmichtot, sondern zu $_REQUEST['schiessmichtot'].


Also lautet meine php-Datei dann:

<?php

$sender = "From: $_REQUEST['absender'];

$mailbody = "Von: $_REQUEST['name'] $_REQUEST['vorname\n']";
$mailbody = $mailbody."Strasse: $_REQUEST['strasse_nr\n']";
$mailbody = $mailbody."PLZ/Ort: $_REQUEST['plz_ort\n']";
$mailbody = $mailbody."Telefon: $_REQUEST['telefon\n']";
$mailbody = $mailbody."E-Mail: $_REQUEST['email\n']";
$mailbody = $mailbody."Nachricht: $_REQUEST['nachricht\n\n']";

mail($empfaenger,$betreff,$mailbody,$sender);

?>


Richtig oder nicht?! Menno!


Hab's probiert, jetzt geht gar nichts mehr...d.h. es werden noch nicht mal
mehr leere Felder übermittelt, sondern es wird gar keine eMail generiert.

Ich bin mir aber eigentlich sicher, dass das Problem in der PHP-Datei
liegen muss. Gibt's hier vielleicht jemanden, der mir eine PHP-Datei mit den
benutzen Variablen (siehe 1. Post) schreiben kann? Sind doch im Grunde
genommen nur 12 Zeilen oder so - für einen, der's kann ungefähr 5 min...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
burnout

Dabei seit: 31.01.2002
Ort: Osnabrücker Land
Alter: 36
Geschlecht: Männlich
Verfasst Mo 27.06.2005 15:52
Titel

Antworten mit Zitat Zum Seitenanfang

bk1 hat geschrieben:

Hab's probiert, jetzt geht gar nichts mehr...d.h. es werden noch nicht mal
mehr leere Felder übermittelt, sondern es wird gar keine eMail generiert.

Ich bin mir aber eigentlich sicher, dass das Problem in der PHP-Datei
liegen muss. Gibt's hier vielleicht jemanden, der mir eine PHP-Datei mit den
benutzen Variablen (siehe 1. Post) schreiben kann? Sind doch im Grunde
genommen nur 12 Zeilen oder so - für einen, der's kann ungefähr 5 min...


in PHP bin ich auch nicht sooo firm, aber ich bin mir ziemlich sicher, dass das \n nicht in die variable gehört Lächel
so:
Code:
$_REQUEST['deine_var'] \n;
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Mo 27.06.2005 16:00
Titel

Antworten mit Zitat Zum Seitenanfang

burnout hat geschrieben:
bk1 hat geschrieben:

Hab's probiert, jetzt geht gar nichts mehr...d.h. es werden noch nicht mal
mehr leere Felder übermittelt, sondern es wird gar keine eMail generiert.

Ich bin mir aber eigentlich sicher, dass das Problem in der PHP-Datei
liegen muss. Gibt's hier vielleicht jemanden, der mir eine PHP-Datei mit den
benutzen Variablen (siehe 1. Post) schreiben kann? Sind doch im Grunde
genommen nur 12 Zeilen oder so - für einen, der's kann ungefähr 5 min...


in PHP bin ich auch nicht sooo firm, aber ich bin mir ziemlich sicher, dass das \n nicht in die variable gehört Lächel
so:
Code:
$_REQUEST['deine_var'] \n;


\n ist der Zeilenumbruch, richtig?!

Dann wär's natürlich logisch, dass das nicht in die Variable gehört. Danke, probier ich aus!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
bk1
Threadersteller

Dabei seit: 14.04.2004
Ort: Düsseldorf
Alter: 34
Geschlecht: Männlich
Verfasst Fr 01.07.2005 08:53
Titel

Antworten mit Zitat Zum Seitenanfang

Es hilft alles nichts, ich nerv euch weiter mit meinen Formularfragen! Ooops

Auch der Tipp von gtz brachte mich nicht weiter, es kommt keine Email an,
am 'REQUEST' lag's also nicht und ich hab's wieder rausgenommen. Mittlerweile
ist es auch nicht mehr so, dass eine LEERE Email ankommt, es kommt GAR KEINE
Email mehr an... *hu hu huu* Flashforum hat mir auch nicht weitergeholfen. Da gab's
zwar ne Menge Tuts, aber die hatten am Ende eigentlich viel zu viel Funktionen
und waren dementsprechend unverständlich für mich.

Also nochmal, vielleicht hat ja noch irgendjemand nen Tipp für mich. Es wär ja
schon schön zu wiisen, wo der Fehler zu suchen ist, ob im AS oder im PHP.

AS auf 1. Bild:
Code:

stop();
absender = "www.seite.com";
empfaenger = "ich@seite.com";
betreff = "Amfrage";


AS auf Senden-Button:
Code:

on (release) {
loadVariables("www.seite.com/kontakt.php", 0, "POST");
gotoAndStop (2);
}


Der Code der kontakt.php:
Code:

<?php

$sender = "From: $absender"\n;

$mailbody = "Von: $txt_firma $txt_name $txt_vorname"\n;
$mailbody = $mailbody. "Strasse: $txt_strasse"\n;
$mailbody = $mailbody. "PLZ/Ort: $txt_plz $txt_ort"\n;
$mailbody = $mailbody. "Telefon: $txt_tel"\n;
$mailbody = $mailbody. "Fax: $txt_fax"\n;
$mailbody = $mailbody. "Email: $txt_email"\n;
$mailbody = $mailbody. "Nachricht: $txt_nachricht"\n\n;

mail ($empfaenger,$betreff,$mailbody,$sender);

?>


Zuletzt bearbeitet von bk1 am Fr 01.07.2005 08:55, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Kontaktformular sendet leere Inhalte
[php] Kontaktformular sendet nicht
Php Kontaktformular sendet nicht
Kontaktformular für / in Flash
Kontaktformular in Flash MX
Kontaktformular in Flash?
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.