mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 10.12.2016 14:12 Benutzername: Passwort: Auto-Login

Thema: [Dringend!] Flash Problem bei Tweens !!! vom 08.07.2004


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [Dringend!] Flash Problem bei Tweens !!!
Seite: Zurück  1, 2, 3  Weiter
Autor Nachricht
seven

Dabei seit: 31.07.2003
Ort: munich
Alter: -
Geschlecht: Weiblich
Verfasst Do 08.07.2004 17:15
Titel

Antworten mit Zitat Zum Seitenanfang

aUDIOfREAK hat geschrieben:
dieses "rucken" bei tweens - bei pixelbilder - ist ein flash-bug den ich auch schon öfters hatte. ich hab bis heute keine passable lösung für dieses problem gefunden!


wenns trotz dem tipp von mir (siehe oben) nicht klappt, und das eine ganz simple fade-in-fade-out geschichte z.b. auf schwarzem hintergrund ist, kann man sich mit nem workaround behelfen. man kann statt dem bild, eine schwarze fläche die über dem bild liegt ein- und ausblenden.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
aUDIOfREAK

Dabei seit: 04.04.2002
Ort: Ansbach
Alter: 36
Geschlecht: Männlich
Verfasst Do 08.07.2004 17:16
Titel

Antworten mit Zitat Zum Seitenanfang

impact hat geschrieben:
@audiofreak

aber warum macht er das dann nur bei manchen bildern und bei manchen nicht? bzw. bei manchen stärker und bei manchen schwächer?


hinter dieses geheimnis bin ich auch noch nicht gekommen... versuch mal die bilder evtl. als png zu importieren - damit hatte ich bei manchen sachen schon öfters erfolg - aber frag mich net warum das so ist....
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
impact
Threadersteller

Dabei seit: 14.02.2004
Ort: vienna
Alter: -
Geschlecht: Männlich
Verfasst Do 08.07.2004 17:18
Titel

Antworten mit Zitat Zum Seitenanfang

in meinem fall ist der hintergrund gelb.
das problem ist nur, dass die bilder ineinander faden. somit funkt das mit der eben drüberlegen leider nicht.

es sei denn ich arbeite mit 2 fade ebenen? hmmm... das könnt gehen...
aber das is ja dann echt mehr als ein workaround...

aber ich versuchs mal, thanks
  View user's profile Private Nachricht senden
impact
Threadersteller

Dabei seit: 14.02.2004
Ort: vienna
Alter: -
Geschlecht: Männlich
Verfasst Do 08.07.2004 17:21
Titel

Antworten mit Zitat Zum Seitenanfang

ups... fast nicht zu ende gedacht.... zwei fadelayer würde ja bedeuten, dass ich das eine bild auf jeden fall mit 100% überdecken mus... und das wär nicht so gut....

das mit den pngs hab ich extra so gemacht... aber das half leider auch nichts...
strange...
  View user's profile Private Nachricht senden
seven

Dabei seit: 31.07.2003
Ort: munich
Alter: -
Geschlecht: Weiblich
Verfasst Do 08.07.2004 17:33
Titel

Antworten mit Zitat Zum Seitenanfang

wie oft sind die bilder denn verschachtelt? spricht wieviele mcs? vielleicht liegts an den unterschiedlichen koordinaten der verschachtelungen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
impact
Threadersteller

Dabei seit: 14.02.2004
Ort: vienna
Alter: -
Geschlecht: Männlich
Verfasst Do 08.07.2004 17:36
Titel

Antworten mit Zitat Zum Seitenanfang

es ist so dass immer nur ein bild ausgefaded wird und 5 frames vor dem endgültigen fadeout das andere bild eingefaded wird. also ganz simpel zwei layer mit sich überlappenden fades...
  View user's profile Private Nachricht senden
seven

Dabei seit: 31.07.2003
Ort: munich
Alter: -
Geschlecht: Weiblich
Verfasst Do 08.07.2004 17:54
Titel

Antworten mit Zitat Zum Seitenanfang

tja, weiss auch nicht. bei mir half immer alpha auf 99% stellen, bild nen tick kleiner skalieren und in den keyframes (schon vor der erstellung des tweens) deaktivieren. (und natürlich auf korrekte koordinaten achten)

vielleicht hilfe dir das hier weiter...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
impact
Threadersteller

Dabei seit: 14.02.2004
Ort: vienna
Alter: -
Geschlecht: Männlich
Verfasst Fr 09.07.2004 09:59
Titel

Antworten mit Zitat Zum Seitenanfang

@seven:

Vielen dank für den Link! War wirklich genau die Info die ich benötigt hatte Lächel

@audiofreak:

Es ist also wirklich so. Flash hat Probleme bei der Berechnung von Images. Das Flackern kommt daher, dass beim Tween selbst ein von Flash berechnetes Bild verwendet wird, und sobald der Tween fertig ist, das "Originalbild" angezeigt wird. Aufgrund von Rundungsfehlern beim Fade ensteht dann dieses Flackern.

-> Abhilfe: Die Bilder in Symbole wandeln. Im Symbol das Frame in dem das Bild ist mit nem Tween versehen und dabei alpha auf 99% stellen. Dann arbeitet Flash nur mit berechneten Bildern und das Flackern ist Vergangenheit. Das Ursprungsbildformat ist dabei vollkommen egal, und auch die Einstellungen die beim Bild gemacht werden können (jpeg / compression / png / gif / lossless)

is zwar ein wenig viel geklicke, aber fürs auge viel schöner wenns nicht mehr zuckt und ruckt
  View user's profile Private Nachricht senden
 
Ähnliche Themen [AS2] - Problem mit Tweens
FLASH Bildlaufleiste mit dynamischen Tweens
Flash - Bilder aus tweens tauschen möglich?
Flash & Alpha Tweens - Performance
DRINGEND! Flash-Scrolbar Problem
tweens verzögern
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2, 3  Weiter
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.