mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 05.12.2016 05:53 Benutzername: Passwort: Auto-Login

Thema: [Excel] Tabellen vergleichen vom 13.05.2004


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Hard- und Software -> [Excel] Tabellen vergleichen
Seite: 1, 2  Weiter
Autor Nachricht
TinCup
Threadersteller

Dabei seit: 07.10.2003
Ort: Freiburg
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.05.2004 15:01
Titel

[Excel] Tabellen vergleichen

Antworten mit Zitat Zum Seitenanfang

Hi,

ich darf/muß/soll zwei Tabellen (Adressliste) auf "Nicht Duplikate" prüfen, also auf ne Art umgekehrte Schnittmenge (mir fehlen irgendwie die Begriffe *Schnief*)
Vorgehensweise ist bisher die, daß ich in einer Hilfstabelle die beiden Listen hintereinanderschreibe und dann zunächst sortiere. Folglich hab ich Duplikate und Unikate (Ha! Begriff!) untereinander in, say, A stehen.
Weiterer Hilfsschritt ist, die Duplikate zu erkennen und entsprechend zu markieren. Hierzu verwende ich in einer gesonderten Spalte folgende Formel: =WENN(ODER(A1=A2;A2=A3);"doppelt";"----")

Das funktioniert auch bis auf einen doofen Haken zuverlässig, da die Markierung "----" für Unikate verrutscht. Das Ergebnis sieht nämlich so aus:

Code:

A    B

a    doppelt
a    doppelt
b    doppelt
b    ----
c    doppelt
d    doppelt
d    doppelt


Jetzt kann ich natürlich ne zweite Hilfsspalte anlegen und die Markierung richtig plazieren lassen, indem ich in C2 =WENN(C1="----";"Unikat";"") mache und runterkopiere. Das funktioniert dann.

Könnt Ihr mir vielleicht vom Schlauch runterhelfen, wie ich das in einem Zug machen kann - oder gibts vielleicht ne andere und bessere Möglichkeit?
Klar, mein Problem hab ich so gelöst bekommen, aber 'eleganter' wär schöner (wenn ähnliches nochmal vorkommt).

Danke!
  View user's profile Private Nachricht senden
Account gelöscht


Ort: -
Alter: -
Verfasst Do 13.05.2004 15:26
Titel

Antworten mit Zitat Zum Seitenanfang

Beitrag gelöscht.

Zuletzt bearbeitet von am Do 13.05.2004 15:34, insgesamt 2-mal bearbeitet
 
Anzeige
Anzeige
TinCup
Threadersteller

Dabei seit: 07.10.2003
Ort: Freiburg
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.05.2004 15:29
Titel

Antworten mit Zitat Zum Seitenanfang

no comment
  View user's profile Private Nachricht senden
saucer

Dabei seit: 19.05.2002
Ort: München
Alter: 36
Geschlecht: Männlich
Verfasst Do 13.05.2004 15:46
Titel

Antworten mit Zitat Zum Seitenanfang

als csv exportieren und dann in mysql importieren.
dort dann vergleichen -> siehe Forum:"Programmierung"



@chatcress
du hattest im canon-thread auch schon so einen dummfug geschrieben.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
TinCup
Threadersteller

Dabei seit: 07.10.2003
Ort: Freiburg
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.05.2004 16:02
Titel

Antworten mit Zitat Zum Seitenanfang

Mal kräftig mit dem Kopf auf die Tischplatte...

Saucer, ya made my day!

Wie betriebsblind kann ein einzelner Mensch sein...
Danke Dir!
  View user's profile Private Nachricht senden
saucer

Dabei seit: 19.05.2002
Ort: München
Alter: 36
Geschlecht: Männlich
Verfasst Do 13.05.2004 16:17
Titel

Antworten mit Zitat Zum Seitenanfang

fuck, es ist spät. ich bin durstig. draussen hält beckstein gerade einen vortrag im bierzelt. ich bin fertig.
konnte ich dir helfen? Au weia!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
cyanamide
Moderator

Dabei seit: 09.12.2002
Ort: Altkaiserreich Koblenz WW
Alter: 40
Geschlecht: Weiblich
Verfasst Do 13.05.2004 16:56
Titel

Antworten mit Zitat Zum Seitenanfang

chatcress hat geschrieben:
sorry, kann zwar net helfen, aber ich wollte mal meine gefühle bezüglich dieser bestimmt sinnvollen software zum ausdruck bringen.

Du wirst keine bessere Tabellenkalkulation finden. Das war ein Spruch vom Profi, hmm?
  View user's profile Private Nachricht senden
TinCup
Threadersteller

Dabei seit: 07.10.2003
Ort: Freiburg
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.05.2004 17:08
Titel

Antworten mit Zitat Zum Seitenanfang

cyanamide hat geschrieben:
Das war ein Spruch vom Profi, hmm?


Repro?


SCNR
  View user's profile Private Nachricht senden
 
Ähnliche Themen Excel-Tabellen
Tabellen-/Diagrammformatierung in Excel
Excel Tabellen zusammenfügen
PDF Tabellen in Excel portieren
[excel] WTF?
Maßangaben in Excel
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Hard- und Software


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.