mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 12:52 Benutzername: Passwort: Auto-Login

Thema: sessionaufruf geht nicht! vom 13.01.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Programmierung -> sessionaufruf geht nicht!
Seite: 1, 2  Weiter
Autor Nachricht
Smooth-Graphics
Threadersteller

Dabei seit: 22.05.2006
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Sa 13.01.2007 22:54
Titel

sessionaufruf geht nicht!

Antworten mit Zitat Zum Seitenanfang

Hallo!

Ich hoffe Ihr könnt mir hier weiterhelfen. Und zwar möchte ich auf meiner Seite ein Kontaktformular einbiden, welches Sessions aufruft (=Spamschutz über Sessions). Nur bekomme ich nun die Fehlermeldung, dass das script keinen session cookie schicken kann, da bereits einer aus meiner index.php datei gesendet wurde. Dort hab ich nur einen kleinen Link includer drinen. Siehe Link.

Wie kann ich dies verhindern oder umgehen?

Liebe Grüße
Smooth-Graphics
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.01.2007 11:24
Titel

Antworten mit Zitat Zum Seitenanfang

bevor du session_start() ausführst, darfst du nichts an den browser
ausgeben .. kein " <?php foo();" (leerzeichen vor den php-tags)
oder echo 'irgendwas';
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Smooth-Graphics
Threadersteller

Dabei seit: 22.05.2006
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.01.2007 11:33
Titel

Antworten mit Zitat Zum Seitenanfang

also auch keine id per $_GET senden oder? *Schnief*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.01.2007 13:22
Titel

Antworten mit Zitat Zum Seitenanfang

lesen kannste? da steht nur was von ausgeben an den browser,
nichts anderes.
  View user's profile Private Nachricht senden
Smooth-Graphics
Threadersteller

Dabei seit: 22.05.2006
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.01.2007 20:50
Titel

Antworten mit Zitat Zum Seitenanfang

Ja ich kann lesen *ha ha* * huduwudu! *
Aber es geht trotzdem net? und ich geb kein echo oder ähnliches aus. Nur ne einzelne variable über GET...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
pRiMUS

Dabei seit: 09.09.2003
Ort: Vienna
Alter: 41
Geschlecht: Männlich
Verfasst So 14.01.2007 21:55
Titel

Antworten mit Zitat Zum Seitenanfang

so ganz mit ohne quelltext wird die hilfe holprig
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
schachbrett

Dabei seit: 11.10.2006
Ort: Köln
Alter: -
Geschlecht: Männlich
Verfasst Mo 15.01.2007 08:26
Titel

Antworten mit Zitat Zum Seitenanfang

Smooth-Graphics hat geschrieben:
Nur ne einzelne variable über GET...

Also gibts du doch was aus?! * Keine Ahnung... *
  View user's profile Private Nachricht senden
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Mo 15.01.2007 11:34
Titel

Antworten mit Zitat Zum Seitenanfang

Evtl. hast Du ja ne Leerzeile am Dateiende, die dir nicht auffällt.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Programmierung


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.