mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 02.12.2016 19:32 Benutzername: Passwort: Auto-Login

Thema: Validator Problem mit & vom 17.08.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Validator Problem mit &
Autor Nachricht
s1ck
Threadersteller

Dabei seit: 28.06.2004
Ort: Sondershausen
Alter: 31
Geschlecht: Männlich
Verfasst Mi 17.08.2005 22:17
Titel

Validator Problem mit &

Antworten mit Zitat Zum Seitenanfang

Hallo,

kurze Frage die ihr bestimmt recht flott beantworten könnt.

Auf meiner Seite sind verschiedene Links gesetzt welche folgendes Format haben:
<a class="button_aktu" href="dokument.php?count=2&sz=1"></a>

Nun hab ich diese Seite Validieren lassen nach HTML 4.01 mittels validator.w3.org und er gibt mir folgende Fehlermeldung zurück:

Zitat:

Warning Line 30 column 51: cannot generate system identifier for general entity "sz".


Wieso Systemidentifier? Soll doch nur ne mitgegebene Variable sein ^^


Wäre über Hilfe sehr dankbar.

Lg s1ck
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Mi 17.08.2005 22:21
Titel

Antworten mit Zitat Zum Seitenanfang

im html-quelltext hat n & nix zu suchen. und blos weil da anführungszeichen drum herum sind, ändert das nix daran.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
reside

Dabei seit: 23.01.2005
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mi 17.08.2005 22:26
Titel

Antworten mit Zitat Zum Seitenanfang

gtz hat geschrieben:
im html-quelltext hat n & nix zu suchen. und blos weil da anführungszeichen drum herum sind, ändert das nix daran.



genau! du musst anstatt & einfach &amp; schreiben!


gruß reside
  View user's profile Private Nachricht senden
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 39
Geschlecht: Männlich
Verfasst Mi 17.08.2005 23:44
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
Wieso Systemidentifier? Soll doch nur ne mitgegebene Variable sein


Weil man mit dem Ampersandzeichen & nunmal Entities einleitet.
Und die beginnen halt mit einem & und enden mit einem Semikolon.
&entity;

Jetzt wird versucht, ein Entity zu erstellen. Das funktioniert aber nicht, weil das anschließende
Semikolon fehlt.
&sz; wäre syntaktisch korrekt (auch wenn es das in HTML nicht gibt). Mit &sz kann der Validator
aber nichts anfangen und bemeckert es deswegen.

Naja, und wie es jetzt korrekt kodiert wird, wurde ja bereits geschrieben...
  View user's profile Private Nachricht senden
s1ck
Threadersteller

Dabei seit: 28.06.2004
Ort: Sondershausen
Alter: 31
Geschlecht: Männlich
Verfasst Do 18.08.2005 16:45
Titel

Antworten mit Zitat Zum Seitenanfang

Vielen Dank. Lächel
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen validator problem
JavaScript Problem mit Validator [erledigt]
validator in
W3 Validator
verwirrender validator
validator.w3.org: ..Was sind das für Fehler?
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.