mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 13.12.2017 12:21 Benutzername: Passwort: Auto-Login

Thema: Problem Vista IE7 vom 13.05.2008


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Software - Nonprint -> Problem Vista IE7
Autor Nachricht
LadyJay
Threadersteller

Dabei seit: 27.03.2006
Ort: -
Alter: 30
Geschlecht: Weiblich
Verfasst Di 13.05.2008 08:09
Titel

Problem Vista IE7

Antworten mit Zitat Zum Seitenanfang

Hallöchen,
wie oben schon geschrieben habe ich ein Problem mit Vista.
Die Navigation der Seite http://www.moegglingen.de funktioniert überall, nur unter Vista IE7 nicht.
Das ganze sind normale Rollover-Buttons mit JS programmiert.

Weiss irgend jemand eine Lösung wie ich diesen Rollover-Effekt bekomme mit möglichst niedrigem Aufwand?

LG Jay
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
l3mon

Dabei seit: 26.07.2005
Ort: -5m
Alter: 52
Geschlecht: Männlich
Verfasst Di 13.05.2008 08:56
Titel

Antworten mit Zitat Zum Seitenanfang

* Keine Ahnung... * ich seh keinen unterschied (egal ob ff ode ie)
  View user's profile Private Nachricht senden
Anzeige
Anzeige
zweitaccount

Dabei seit: 25.01.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst Di 13.05.2008 09:21
Titel

Antworten mit Zitat Zum Seitenanfang

Dein Browsercheck gibt false zurück im IE7:

if (navigator.appVersion.indexOf("2.") != -1){
check = false;
}
if ((navigator.appVersion.indexOf("3.") != -1) && (navigator.appName.indexOf("Explorer") != -1)){
check = false;
}
else {
check = true;
}
  View user's profile Private Nachricht senden
LadyJay
Threadersteller

Dabei seit: 27.03.2006
Ort: -
Alter: 30
Geschlecht: Weiblich
Verfasst Di 13.05.2008 10:20
Titel

Antworten mit Zitat Zum Seitenanfang

danke Lächel
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 40
Geschlecht: Männlich
Verfasst Di 13.05.2008 11:10
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
ein Problem mit Vista.

Das scheint kein Problem des Betriebssystems zu sein, sondern eins des Browsers.

Aber da gibt es eine Menge Probleme...

Der w3c-Validator meldet 108 Fehler alleine auf der index-Seite:
http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.moegglingen.de%2F

Die meisten sind aber ganz schnell behoben, weil es sich immer um den gleichen Fehler handelt.
Das Element img erfordert zwingend das Attribut alt. Man kann es leer lassen, darf es aber nicht weglassen.

Die Attribute topmargin, leftmargin, marginwidth und marginheight gehöten nicht zum HTML-Standard. Das muß über CSS geregelt werden. Setze margin und padding auf 0.

Für Framesets (http://www.moegglingen.de/htdocs_neu/frameset_aktuell.html) muß auch eine Frameset DTD eingesetzt werden.
Im Frameset stecken außerdem auch noch verdammt viele Fehler...
Über den Einsatz von Frames würde ich auch noch mal nachdenken: http://www.subotnik.net/html/frames.html

Ich empfehle, mit Hilfe eines Validators, alle Fehler im Code zu beseitigen.


Und so einen Browsercheck mit JS würde ich in keinem Fall machen. Das ist überhaupt nicht notwendig für so ein Rollover-Script.
Zitat:
Weiss irgend jemand eine Lösung wie ich diesen Rollover-Effekt bekomme mit möglichst niedrigem Aufwand?

Mit CSS: http://aktuell.de.selfhtml.org/artikel/css/mouseover/index.htm oder http://www.drweb.de/csspraxis/css-rollover-menu.shtml
  View user's profile Private Nachricht senden
 
Ähnliche Themen IE6 und IE7 parallel unter Vista möglich?
ie7 problem?
Problem mit IE7
[IE7 Problem] height in %
CSS-Problem im IE7
Problem bei Druckausgabe im IE7
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Software - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.