mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 06.07.2020 09:37 Benutzername: Passwort: Auto-Login

Thema: css probleme vom 13.12.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Prüfungen -> css probleme
Seite: Zurück  1, 2
Autor Nachricht
jenswinni
Threadersteller

Dabei seit: 22.01.2007
Ort: -
Alter: 54
Geschlecht: Männlich
Verfasst Do 13.12.2007 13:46
Titel

Antworten mit Zitat Zum Seitenanfang

ich danke euch für die antworten
hab bischen weiter gebastelt schon mit der css
es geht jetzt etwas besser hir mal der derzeitige stand

/* CSS Document */

a:link{color:#000000;}
a:visited{color:#000000;}
a:hover{color:#999999;}
a:active{color:#999999;}
a:link {text-decoration: none;}
a:visited {text-decoration: none;}
a:hover {text-decoration: none;}
a:active {text-decoration: none;}

.Navi {
color: #000000;
background-color: #a6bbda;
font-family: Verdana, Arial, Helvetica, sans-serif;
margin: 0px;
border: 1px solid #808080;
font-size: 9px;
border-color: #7e807f;
text-align: center;
}

.content {
border: 1px solid #808080;
background-color: #dce4ef;
}

.contenttext {
height: 189px;
width: 552px;
padding-left:180px;
}
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
sousterrainian

Dabei seit: 12.12.2007
Ort: Bremen
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.12.2007 13:47
Titel

Antworten mit Zitat Zum Seitenanfang

@deesi:

A-tens will ich keinen Stress in einem Forum anfangen, dass mir seit langem weiterhilft. B-tens keine Grundsatzdiskussion im Prüfungsforum führen. C-tens klingt das von dir beschriebene Problem nach CSS-magischer Willkür. Ab und an, kommt es vor, dass da was falsch dargestellt wird, wenn ich etwas nicht mache... CSS ist leider logisch aufgebaut(außer in Verbindung mit dem IE).

Der Tip mit dem FireBug war ernst gemeint, er ist mit der Developer-Toolbar und dem RSS-Reader mein häufigst genutztes Plugin und gibt für jedes Element auf der Seite exakt an, woher welche Eigenschaft vererbt wird. Da sieht man schnell mal die lustigsten Strukturfehler im CSS - die ich auch mache, mich auch wundere, warum etwas anders dargestellt wird, als geplant, bis ich den Fehler, der trotz validem Code da war, gefunden habe.

zum Abschluss:
CSS verhält sich nicht willkürlich!
Es folgt einer inneren Logik, wenn man diese nicht befolgt, dann geht etwas schief, dass man sicherlich auch durch Walkarounds "umgehen" kann. Ich war/bin etwas angepisst, weil deine erste Aussage definitiv falsch ist, und du diese vehement verteidigst.
So, jetzt reichts aber, genug gemeckert. Frieden?

Wenn nicht, kannst du mich gerne heute Abend per ICQ anschreiben. Da können wir dann weiterdiskutieren. Auch wenn sich das getippe eigentlich nicht lohnt...


Zuletzt bearbeitet von sousterrainian am Do 13.12.2007 14:12, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden
Anzeige
Anzeige
sousterrainian

Dabei seit: 12.12.2007
Ort: Bremen
Alter: 38
Geschlecht: Männlich
Verfasst Do 13.12.2007 14:00
Titel

Antworten mit Zitat Zum Seitenanfang

@jenswinni:

Zitat:
a:link{color:#000000;}
a:visited{color:#000000;}
a:hover{color:#999999;}
a:active{color:#999999;}
a:link {}
a:visited {text-decoration: none;}
a:hover {text-decoration: none;}
a:active {text-decoration: none;}


polygemoppelt *zwinker*

versuche es mal so:
Code:

a{
  text-decoration: none;
  color:#000; /* Wenn sich die Hexangaben doppeln, musst die "0" nicht 6-mal angeben */
}/*gilt für alle <a> und wird auch an die Pseudo-Klassen :hover etc. vererbt*/

a:hover, a:active{/*Durch Komma getrennt kannste die gleichzeitig deklarieren*/
  color:#999;
}/*Überschreibt, die vererbte Farbe, text-decoration:none; wird dennoch vererbt.*/


Das macht das gleiche, nur weiß ich nicht, wozu das leere a:link{} da ist?

Jetzt muss ich noch ein bissel arbeiten.

* Ich geb auf... * Du definierst die border-color in .Navi immer noch 2x! Warum?!?


Zuletzt bearbeitet von sousterrainian am Do 13.12.2007 14:11, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden
jenswinni
Threadersteller

Dabei seit: 22.01.2007
Ort: -
Alter: 54
Geschlecht: Männlich
Verfasst Do 13.12.2007 14:24
Titel

Antworten mit Zitat Zum Seitenanfang

danke schön ich versuchs mal
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Probleme zur Prüfungszulassung wg. Berufsschule
Probleme mit Anmeldung zur Prüfung
Probleme mit dem berichtsheft im ewrite
Abschlussprüfung W3 Modul: W17 (Verpackung) Probleme
[AP 07] Mediendesign Nonprint - CSS
Praktische Prüfung wie wars gabs probleme mit NEW STYLE
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2
MGi Foren-Übersicht -> Allgemeines - Prüfungen


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.