mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Di 13.04.2021 04:19 Benutzername: Passwort: Auto-Login

Thema: Umlaute in Dreamweaver vom 04.11.2011


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Umlaute in Dreamweaver
Autor Nachricht
lucke
Threadersteller

Dabei seit: 02.08.2005
Ort: Vallés, la costera, ES
Alter: 43
Geschlecht: Weiblich
Verfasst Fr 04.11.2011 18:09
Titel

Umlaute in Dreamweaver

Antworten mit Zitat Zum Seitenanfang

Hallo Zusammen,
ich bin leider kein Dreamweaver-Profi, aber jetzt mache ich endlich mal eine Website und bin auch gleich schon auf ein Problem gestossen:
Ich habe in DW CS5 gelayoutet, alles auf den Server hochgeladen, aber jetzt werden mir die Sonderzeichen (ä,ö,etc) als Fragezeichen, also zerschossen dargestellt. Ich habe auch schon hier im Forum gesucht, aber ich verstehe das alles nicht so richtig... Ich weis nciht an welcher Einstellung es liegt.
Vielleicht kann mir ja jemand mit einer einfachen Antwort helfen...
Herzlichen Dank!!!!

Das steht am Anfang meines QUelltextes:


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><!-- InstanceBegin template="/Templates/Tobys_seite.dwt" codeOutsideHTMLIsLocked="false" -->
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
der_jules

Dabei seit: 20.04.2009
Ort: Stuttgart
Alter: 32
Geschlecht: Männlich
Verfasst Fr 04.11.2011 18:27
Titel

Antworten mit Zitat Zum Seitenanfang

Ersetze
Code:
charset=UTF-8"
durch
Code:
charset=iso-8859-1"
dann sollte es funktionieren.
Ansonsten schreiben sich Umlaute in wie folgt:
ä=&auml;
ü=&uuml;
ö=&ouml;
ß=&szlig;
Eine gute Anlaufstelle ist auch immer SelfHTML.de
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
Smooth-Graphics

Dabei seit: 22.05.2006
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Fr 04.11.2011 20:12
Titel

Antworten mit Zitat Zum Seitenanfang

der_jules hat geschrieben:
Ersetze
Code:
charset=UTF-8"
durch
Code:
charset=iso-8859-1"
dann sollte es funktionieren.

Pfui. UTF-8 sollte verwendet werden, wenn der Server richtig eingestellt ist, sollte das auch klappen.

http://de.wikipedia.org/wiki/Wikipedia:UTF-8-Probleme
http://www.phpwact.org/php/i18n/charsets
http://blog.antikoerperchen.de/beitrag/42/utf-8-und-die-entity.html
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Kash

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 38
Geschlecht: Männlich
Verfasst Mi 09.11.2011 12:39
Titel

Antworten mit Zitat Zum Seitenanfang

Du solltest auch prüfen das die Dokumente im Editor als UTF-8 deklariert sind.
  View user's profile Private Nachricht senden
ExMD

Dabei seit: 27.01.2005
Ort: Saarland
Alter: 42
Geschlecht: Männlich
Verfasst Mi 09.11.2011 18:17
Titel

Antworten mit Zitat Zum Seitenanfang

zusätzlich kannst du noch folgendes checken:

datei -> speichern unter
im darauf folgenden fenster muss ganz unten die checkbox "Unicode-Signatur (BOM) einschließen" deaktiviert sein.
wenn das häkchen jedoch gesetzt ist, unbedingt deaktivieren und bei allen anderen hmtl-seiten, die du bearbeitet hast, genauso vorgehen.

ist, je nach anzahl der html-dateien, entsprechend mehr oder weniger aufwand.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
lucke
Threadersteller

Dabei seit: 02.08.2005
Ort: Vallés, la costera, ES
Alter: 43
Geschlecht: Weiblich
Verfasst Do 10.11.2011 10:37
Titel

Antworten mit Zitat Zum Seitenanfang

Vielen Dank für Eure Hilfe!

Es geht jetzt. Ich habe charset=UTF-8" durch charset=iso-8859-1" ersetzt und schreibe jetzt nur noch in der Entwurfsansicht, dann macht er den code für die Umlaute automatisch. (Ein paar habe ich per Hand geändert)

Wahrscheinlich würde es auch mit charset=UTF-8 funktionieren... aber da ich wie gesagt kein Internet-Profi bin, lass ich es jetzt so und bin froh das alles funktioniert.

Nochmals vielen, vielen Dank!!!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen umlaute im gästebuch
html umlaute
PHP Umlaute
Umlaute werden nicht ausgegeben
Umlaute im Kontakformular
Umlaute umwandeln
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.