mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 24.06.2021 13:23 Benutzername: Passwort: Auto-Login

Thema: Probleme mit Anker vom 25.05.2009


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Probleme mit Anker
Autor Nachricht
gtiler
Threadersteller

Dabei seit: 11.03.2006
Ort: Berlin
Alter: 47
Geschlecht: Weiblich
Verfasst Mo 25.05.2009 09:07
Titel

Probleme mit Anker

Antworten mit Zitat Zum Seitenanfang

Hallo,

ich sitze seit einigen Tagen an einem Ankerproblem. Habe schon sämtliche
Varianten durchprobiert, finde aber den Fehler nicht.

Es geht darum, dass man das ensprechende Event (z. B. Spinnerbrücke 2001) anklickt
und dann automatisch auch zu den entsprechenden Bildern auf genau der selben Seite
gelangt, ohne selbst scrollen zu müssen.

Hoffe, dass ihr mirhelfen könnt. Hier der Link zur entsprechenden Seite:

http://www.gummi-garage.de/events.html

Gruß und Danke im Voraus.

Lächel


Zuletzt bearbeitet von gtiler am Mo 25.05.2009 09:09, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
m
Moderator

Dabei seit: 18.11.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mo 25.05.2009 09:12
Titel

Antworten mit Zitat Zum Seitenanfang

http://de.selfhtml.org/html/verweise/projektintern.htm
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
choise

Dabei seit: 01.02.2007
Ort: Würzburg
Alter: 33
Geschlecht: Männlich
Verfasst Mo 25.05.2009 09:19
Titel

Antworten mit Zitat Zum Seitenanfang

Deine Syntax stimmt hinten und vorne nicht.

Anker setzt man so:
Code:

<a name="ankername" id="ankername"></a>


natürlich musst du beachten ob dein doctype leere tags zulässt.
auf einen anker verlinken kannst du so:

Code:

<a href="#ankername">Zum Anker</a>


ab html 4 kann man anker auch rein mit dem id attribut bezeichnen, gebräuchlich ist dennoch die verwendung des "a" tags in verbindung mit dem name attribut.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtiler
Threadersteller

Dabei seit: 11.03.2006
Ort: Berlin
Alter: 47
Geschlecht: Weiblich
Verfasst Mo 25.05.2009 09:38
Titel

Antworten mit Zitat Zum Seitenanfang

@choise:

So hatte ich es auch schon gemacht. Hat nicht funktioniert. Habe es
trotzdem nochmal so versucht. Jetzt passiert zwar etwas, aber halt
nicht das, was passieren soll. Das Bild "springt" kurz. Aber leider
nicht zum gewünschten Anker.

Habe es erneut hochgeladen. Kannst ja vielleicht nochmal einen
Blick drauf werfen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
choise

Dabei seit: 01.02.2007
Ort: Würzburg
Alter: 33
Geschlecht: Männlich
Verfasst Mo 25.05.2009 09:58
Titel

Antworten mit Zitat Zum Seitenanfang

1. du speicherst dein Dokument falsch ab. deine umlaute werden nicht richtig erkannt, dh du speicherst dein dokument im falschen zeichensatz ab. (nein nur weil du oben das dokument als utf-8 deklariert hast, heisst das noch lange nicht, dass du es auch als utf8 abspeicherst). Verwende in deinen Bezeichnern lieber keine Umlaute (siehe "Spinnerbrücke_2002" ->"spinnerbruecke_2002").

2. da du alles Absolut postitioniert hast, hängen deine "a"-Tags alle links oben in der Ecke, darum springen die funktionierenden Anker (Luckau) nur ein kleines Stück nach unten. Entweder positionierst du deine "a"-Tags an die richtige Stelle, oder du könntest als notlösung die "a"-Tags mit in dein weisses "b"-Tag setzen, die über deinen jeweiligen Bildern sind

insgesamt ist das ganze Dokument sehr unschön geschrieben, les dich doch mal ein bisschen in CSS ein, verwende externe CSS Dateien, dann wird auch alles übersichtlicher.




[edit]
Verschoben von Multimedia nach Allgemeines - Nonprint.


Zuletzt bearbeitet von choise am Mo 25.05.2009 10:00, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
gtiler
Threadersteller

Dabei seit: 11.03.2006
Ort: Berlin
Alter: 47
Geschlecht: Weiblich
Verfasst Mo 25.05.2009 11:06
Titel

Antworten mit Zitat Zum Seitenanfang

Hey vielen Dank! Genau das war das Problem (dein Tipp unter 2.)

Grins
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen dynamischer scroll von anker zu anker
Anker ansprechen, aber wie?
PDF-Anker?
Anker-Markierungen
[HTML] Anker Problem
Anker in HTML-Newsletter
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.