mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Di 21.09.2021 22:44 Benutzername: Passwort: Auto-Login

Thema: Problem mit Internet Explorer vom 26.03.2008


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Problem mit Internet Explorer
Seite: 1, 2  Weiter
Autor Nachricht
stetze
Threadersteller

Dabei seit: 26.03.2008
Ort: Dielkirchen
Alter: 33
Geschlecht: Männlich
Verfasst Mi 26.03.2008 15:02
Titel

Problem mit Internet Explorer

Antworten mit Zitat Zum Seitenanfang

Hallo hab gerade mein erstes CSS Design angepasst...
Leider funzt es nur in Firefox...

Der Internet Explorer fügt die einzelnen Bilder nicht richtig zusammen...
Und bei Kunden zeigt er die Seite falsch an...

klick mich ich bin ein link

Freu mich über jede Hilfe

gruß stetze

EDIT:
Das mit der Kundenseite habe ich gelöst...
Aber wie kann ich dem IE Sagen das er die Bilder also die einzelnen Slices richtig zusammensetzt ohne diese kleinen spalten.


Zuletzt bearbeitet von stetze am Mi 26.03.2008 16:43, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
wipeout

Dabei seit: 20.05.2005
Ort: -
Alter: 37
Geschlecht: Männlich
Verfasst Mi 26.03.2008 23:55
Titel

Antworten mit Zitat Zum Seitenanfang

nun, ich bin im moment leider auch etwas überfragt....versuch mal die bereiche mit margin: 0 und padding: 0 zu setzen...vielleicht klappt es dann im ie


die kunden-seite wird im ie7 übrigens leider nicht richtig dargestellt...
  View user's profile Private Nachricht senden
Anzeige
Anzeige
therapiekind

Dabei seit: 14.03.2006
Ort: In deinem Kopf
Alter: -
Geschlecht: -
Verfasst Do 27.03.2008 01:06
Titel

Antworten mit Zitat Zum Seitenanfang

font-size für das DIV mit der ID "undercontent" auf 0 (Null) setzen. IE reserviert für Blockelemente anscheinend immer so viel Höhe, dass Text noch reinpassen würde (nagel mich nicht drauf fest, ist nur etwas, was ich schon öfters beobachtet habe), unabhängig von der height-Eigenschaft. Bei dir sind das im Moment 12 Pixel, wohl einer zuviel, um deine 13 Pixel Höhe zuzulassen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
stetze
Threadersteller

Dabei seit: 26.03.2008
Ort: Dielkirchen
Alter: 33
Geschlecht: Männlich
Verfasst Do 27.03.2008 02:34
Titel

Antworten mit Zitat Zum Seitenanfang

therapiekind hat geschrieben:
font-size für das DIV mit der ID "undercontent" auf 0 (Null) setzen. IE reserviert für Blockelemente anscheinend immer so viel Höhe, dass Text noch reinpassen würde (nagel mich nicht drauf fest, ist nur etwas, was ich schon öfters beobachtet habe), unabhängig von der height-Eigenschaft. Bei dir sind das im Moment 12 Pixel, wohl einer zuviel, um deine 13 Pixel Höhe zuzulassen.


Das hat funktioniert danke...
Aber jetzt geht an der linken unteren seite der rand noch ein bischen über das design hinaus...
Ich lade es morgen früh neu hoch...

gruß stetze
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
logo-factory
Gesperrt

Dabei seit: 24.11.2007
Ort: Kirchberg
Alter: -
Geschlecht: -
Verfasst Do 27.03.2008 10:26
Titel

Antworten mit Zitat Zum Seitenanfang

Damit du möglichst gleice Voraussetzungen in den verschiedenen Browsern hast, solltest du erstmal ein "Reset"-Stylesheet einbinden.

Ein Besipiel hier aus yaml:

Code:
/* ######################################################################################################
** ### Vorbereitende Maßnahmen | Reset ##################################################################
** ######################################################################################################
*/
   /* Hiermit werden die Randabstände und border aller HTML-Elemente auf Null gesetzt. Damit wird das       
   ** Aussehen der Webseite in unterschiedlichen Browsern vereinheitlicht.
   */
   
   * { margin:0; padding: 0; }

   /* Das zurücksetzen der Innen- und Außenabstände verursacht zu kleine Selectboxen. Dies wird korrigiert */
   option {padding-left: 0.4em}
   
   /*
   ** Die nachfolgenden Angaben entstammen dem Artikel 'Useful Code Snippets' von Mike Foskett
   ** [http://www.websemantics.co.uk/tutorials/useful_css_snippets/]
   */
   
   /* Vertikalen Scrollbalken im Netscape & Firefox erzwingen. Dies verhindert, dass zentrierte Layouts
   ** um 10 Pixel springen wenn der Seiteninhalt kleiner wird als die Höhe des Browserfensters. */
   html { height: 100% }
   body {
      min-height: 101%;   
   /* Beseitigung des Rundungsfehlers bei Schriftgrößen im Opera sowie Standardformatierungen */
      font-size: 100.01%;
   /* FIX: Verhindert, dass positionierte Elemente nicht verschoben werden when die Größe des Browser
         Fensters geändert wird. */
      position: relative;
   
   /* Vorgabe der Standardfarben und Textausrichtung*/     
      color: #000;       
      background: #fff;
      text-align: left;
   }
   
   /* Standardrahmen zurücksetzen */
   fieldset, img { border:0; }
   
   /* Anpassung für Safari Browser. font-size:100% ist für den Safari in Formularen zu groß */
   select, input, textarea { font-size: 99% }
  View user's profile Private Nachricht senden
stetze
Threadersteller

Dabei seit: 26.03.2008
Ort: Dielkirchen
Alter: 33
Geschlecht: Männlich
Verfasst Do 27.03.2008 10:44
Titel

Antworten mit Zitat Zum Seitenanfang

@logo-factory, hab das jetzt einfach mal eingebunden ^^

Das Design wird bei IE nicht zentriert dargestellt...

Hab das Design neu hochgeladen...
Ich bin ein Link

Danke für eure hilfe...
Ihr seid echt top Lächel

gruß stetze


Zuletzt bearbeitet von stetze am Do 27.03.2008 10:48, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 44
Geschlecht: Männlich
Verfasst Do 27.03.2008 11:31
Titel

Antworten mit Zitat Zum Seitenanfang

Der Box-Model-Bug ist dir bekannt?
Dein Code sieht gut aus. Enthält keine Fehler.
Aber wenn du CSS-Layouts anständig umsetzen willst, dann würde ich erst einmal dafür sorgen, daß du die Browser in den standardkonformen Modus schaltest.
Informiere dich über den Doctype-Switch.

Zitat:
Das Design wird bei IE nicht zentriert dargestellt...

margin-left und margin-right auf center setzen, würde ich sagen...
Es gibt einiges an Möglichkeiten, wie du den Krams zentrieren kannst.
Hättest du mal CSS center oder ähnliches in eine Suchmaschine getippt, hättest du bestimmt schon einiges gefunden.
Hier sind ein paar interessante Artikel für dich:
Elemente mit CSS zentrieren
Seiten zentrieren mit CSS
CSS Centering 101
Denke, da wird dein MSIE-Problem auch besprochen.


Dann fällt mir noch auf, daß der Text in deiner header.gif zeimlich schmierig aussieht. Der Zug sieht auch nicht gut aus - zuwenig Farben.
Ich würde die Grafik teilen. Für den Zug würde ich ein JPEG nehmen und für den Text würde ich ein GIF (oder besser ein PNG- *hehe* nehmen. (JPEG ist für Text ungeeignet.)
Außerdem ist der Alternativ-Text völlig daneben. Du hast den Sinn nicht verstanden.
Zitat:
Die Grafik "http://stetze-online.de/fdt/Bilder/header.gif" kann nicht angezeigt werden, weil sie Fehler enthält.

Der Alternativtext kommt zum Einsatz, wenn die Grafik nicht gezeigt wird. Richtig.
Es ist aber sehr unwahscheinlich, daß die Grafikdatei kaputt ist. Dann würde der Browser versuchen, die kaputte Datei anzuzeigen und nicht den alt-Text.
Der Text wird gezeigt, wenn jemand die Darstellung von Bildern deaktiviert hat. Das habe ich beispielsweise in der Berufsschule gemacht. Dort hingen so viele Schüler an einer Leitung, daß man Ewigkeiten warten mußte, bis eine Site geladen war. Also habe ich die Bilddarstellung deaktiviert und dann nur die Bilder laden lassen, die für mich interessant waren.
So. Andere Sache: Der alt-Text kommt zum Einsatz, wenn jemand mit einem Textbrowser surft. Welchen Sinn hätte dann dein Text?
Dann kommt der alt-Text zum Einsatz, wenn jemand mit einem Screenreader surft. Blind und Sehgeschädigte lassen sich Websites von Screenreadern vorlesen. Anstelle der Grafik wird der alt-Text gelesen.
Also solltest du dir das mit deinen alt-Attributen noch mal durch den Kopf gehen lassen und einige Änderungen vornehmen.

Code:
<meta http-equiv="content-type" content="text/html; charset=windows-1250">

Warum arbeitest du mit einer Windows-Codepage?
Ich würde UTF-8 oder ISO-8859-1 bzw. ISO-8859-15 arbeiten, aber nicht mit Windows-Codepages oder Mac-Roman.
Natürlich funktioniert es auch so, aber ich würde offene Standards vorziehen...

Code:
<a href="mailto:info@fischer-datentechnik.de">info@fischer-datentechnik.de</a>

mailto-Links mag ich nicht. Da muß man sich dann darauf verlassen, daß der User einen eigenen Mailaccount besitzt und einen installierten und korrekt konfigurierten Mailclient. Aus einem Internetcafé kann man solche Links also in den meisten Fällen vergessen. Ich würde Mails immer serverseitig verschicken.
Aber das ist nicht so wichtig. Mach das, wie du denkst.
Ich würde nur ganz stark davon abraten, die Mailadresse dort so einfach zu präsentieren. Sobald die Site im Netz steht und die ersten Suchmaschinen-Robots da waren, werden auch die ersten Email-Harvester kommen. Der Mailaccount wird mit Spam vollgeballert werden.
Schütze die Adresse. Wie du das machen könntest, habe ich z.B. hier geschrieben.
  View user's profile Private Nachricht senden
stetze
Threadersteller

Dabei seit: 26.03.2008
Ort: Dielkirchen
Alter: 33
Geschlecht: Männlich
Verfasst Do 27.03.2008 11:59
Titel

Antworten mit Zitat Zum Seitenanfang

So klingt alles ziemlich interessant ^^
Das ist meine erste Webseite die ich mit CSS erstellt habe...
Also ich weiß nicht was Box Model usw sind...
Ich lese mir aber gleich mal die Seiten von dir durch danke.

Zum Header, der Text sollte so aussehn das war absicht, ich fand so sieht es besser aus als normal, zum Zug ich weiß das der nicht gut aussieht, leider habe ich dieses Bild nur in einer schlechen Qualität mehr konnte ich nicht aus ihm rausholen.

Das mit dem Bild teilen versuche ich später mal Lächel

Ja aber es sind doch eh nur Bilder, man könnte eventuell Beim Logo vom FCK zum Beispiel "Logo 1.FCK" hinschreiben? oder wie meinst du das?

der meta code wurde von pspad automatisch generiert, ich kann damit nichts anfangen ^^
aber wenn du sagst das UTF-8 usw, dem standard entspricht ändere ich das.

Mit der Email Adresse muss ich mir noch etwas überlegen ich glaube mein Chef bringt mich um wenn da lauter Spams reinrattern ^^

Danke für deinen Beitrag, werde dann gleich mal loslegen mit den Änderungen ^^

gruß stetze

EDIT:

Wegen den Alt-elementen-> Ich benutz die Bilder ja eigentlich nicht als Inhalt sondern fürs Design, das heist ich mach dann einfach -> alt="" ... Und bei den Logos bei den Kunden kann ich ja alt="Logo 1.FCK" schreiben....

Und mit dem Doctyp hab ichs jetzt so gemacht

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html lang="de">
<head>
<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1">


Zuletzt bearbeitet von stetze am Do 27.03.2008 12:33, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Problem mit dem Internet Explorer
AJAX Problem mit Internet Explorer
Problem Kodierung im Internet Explorer 6
Dickes Problem mit dem Internet Explorer
Problem bei Wiedergabe von .gif im Internet Explorer
Problem mit Schriftart in Firefox und Internet Explorer
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.