mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 22.02.2017 00:41 Benutzername: Passwort: Auto-Login

Thema: mod_rewrite und wordpress vom 12.10.2004


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> mod_rewrite und wordpress
Autor Nachricht
shakadi
Griller Killer
Threadersteller

Dabei seit: 21.12.2003
Ort: SHA
Alter: 36
Geschlecht: Männlich
Verfasst Di 12.10.2004 12:06
Titel

mod_rewrite und wordpress

Antworten mit Zitat Zum Seitenanfang

Hallo,

ich will hier gerade wordpress 1.2 installieren.
soweit so gut. ist auch alles ok.

nun will ich die permalinks mit mod_rewrite so:

Permalink Structure hat geschrieben:
/archives/%year%/%monthnum%/%day%/%postname%/


zudem:

Permalink Result hat geschrieben:
http://www.inmyanus.com/archives/2004/10/12/sample-post/


umschreiben.

Wordpress legt dazu folgende .htaccess an.

.htaccess hat geschrieben:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^feed/?([_0-9a-z-]+)?/?$ /index.php?feed=_$1 [QSA]
RewriteRule ^comments/feed/?([_0-9a-z-]+)?/?$ /index.php?feed=_$1&withcomments=1 [QSA]
RewriteRule ^page/?([0-9]{1,})/?$ /index.php?paged=$1 [QSA]
RewriteRule ^site/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?pagename=$1&feed=$2 [QSA]
RewriteRule ^site/([^/]+)/page/?([0-9]{1,})/?$ /index.php?pagename=$1&paged=$2 [QSA]
RewriteRule ^site/([^/]+)/?$ /index.php?pagename=$1 [QSA]
RewriteRule ^search/(.+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?s=$1&feed=$2 [QSA]
RewriteRule ^search/(.+)/page/?([0-9]{1,})/?$ /index.php?s=$1&paged=$2 [QSA]
RewriteRule ^search/(.+)/?$ /index.php?s=$1 [QSA]
RewriteRule ^archives/category/(.+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?category_name=$1&feed=$2 [QSA]
RewriteRule ^archives/category/(.+)/page/?([0-9]{1,})/?$ /index.php?category_name=$1&paged=$2 [QSA]
RewriteRule ^archives/category/(.+)/?$ /index.php?category_name=$1 [QSA]
RewriteRule ^archives/author/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?author_name=$1&feed=$2 [QSA]
RewriteRule ^archives/author/([^/]+)/page/?([0-9]{1,})/?$ /index.php?author_name=$1&paged=$2 [QSA]
RewriteRule ^archives/author/([^/]+)/?$ /index.php?author_name=$1 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/trackback/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&tb=1 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&feed=$5 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/page/?([0-9]{1,})/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&paged=$5 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/([^/]+)/?([0-9]+)?/?$ /index.php?year=$1&monthnum=$2&day=$3&name=$4&page=$5 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&day=$3&feed=$4 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/page/?([0-9]{1,})/?$ /index.php?year=$1&monthnum=$2&day=$3&paged=$4 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/([0-9]{1,2})/?$ /index.php?year=$1&monthnum=$2&day=$3 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&monthnum=$2&feed=$3 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/page/?([0-9]{1,})/?$ /index.php?year=$1&monthnum=$2&paged=$3 [QSA]
RewriteRule ^archives/([0-9]{4})/([0-9]{1,2})/?$ /index.php?year=$1&monthnum=$2 [QSA]
RewriteRule ^archives/([0-9]{4})/(feed|rdf|rss|rss2|atom)/?$ /index.php?year=$1&feed=$2 [QSA]
RewriteRule ^archives/([0-9]{4})/page/?([0-9]{1,})/?$ /index.php?year=$1&paged=$2 [QSA]
RewriteRule ^archives/([0-9]{4})/?$ /index.php?year=$1 [QSA]
</IfModule>

# END WordPress


Schein ja auch ok. nur nachdem erstellen dieser .htaccess erhalte ich nur noch

403 hat geschrieben:
Forbidden
You don't have permission to access / on this server.


Jemand ne Idee? Kann mir helfen? Woran könnts liegen?
Ich verzweifel gleich.



und ja mod_rewrite ist aktiviert.
phpinfo.php hat geschrieben:
Loaded Modules ..., mod_rewrite, ...




wäre echt Ql. thx im voraus

//: versionsnummer geändert von 3 auf 2


Zuletzt bearbeitet von shakadi am Di 12.10.2004 12:24, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
beeviZ

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Di 12.10.2004 12:19
Titel

Antworten mit Zitat Zum Seitenanfang

seit wann isn 1.3 draußen?
ich werd heut abend mal gucken. mein blog fährt auch wp. allerdings 1.2. aber dürfte sich ja nich soo unterscheiden.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
shakadi
Griller Killer
Threadersteller

Dabei seit: 21.12.2003
Ort: SHA
Alter: 36
Geschlecht: Männlich
Verfasst Di 12.10.2004 12:22
Titel

Antworten mit Zitat Zum Seitenanfang

beeviZ hat geschrieben:
seit wann isn 1.3 draußen?
ich werd heut abend mal gucken. mein blog fährt auch wp. allerdings 1.2. aber dürfte sich ja nich soo unterscheiden.


ooops hab ich 1.3 geschrieben meinte 1.2
habs vorher nur mit der 1.3 nightly build vom 11.10.2004 probiert gehabt.
  View user's profile Private Nachricht senden
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 39
Geschlecht: Männlich
Verfasst Di 12.10.2004 12:35
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
RewriteBase /

und da hast du keinen Zugriff drauf. Fehlermeldung ist recht eindeutig. DocumentRoot richtig gesetzt? Ist das dein eigener Server oder beim Provider?

Das ist aber nicht ungewöhnlich, daß du nicht überall Vollzugriff hast. Erstmal verbietet man alles für alle Verzeichnisse und danach erlaubt man dann gezielt was man braucht, wo man es braucht.
Typischer Unix-Ansatz: Alles verboten, was nicht erlaubt ist. Wohingegen unter Windows meist alles erlaubt ist, was nicht verboten wurde.

Versuch vielleicht mal so in etwa:
<Directory / >
Options Indexes, FollowSymLinks
AllowOverride All
</Directory>

und allow from all


Zuletzt bearbeitet von rob am Di 12.10.2004 12:36, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
shakadi
Griller Killer
Threadersteller

Dabei seit: 21.12.2003
Ort: SHA
Alter: 36
Geschlecht: Männlich
Verfasst Di 12.10.2004 18:19
Titel

Antworten mit Zitat Zum Seitenanfang

rob hat geschrieben:
Zitat:
RewriteBase /

und da hast du keinen Zugriff drauf. Fehlermeldung ist recht eindeutig. DocumentRoot richtig gesetzt? Ist das dein eigener Server oder beim Provider?

Das ist aber nicht ungewöhnlich, daß du nicht überall Vollzugriff hast. Erstmal verbietet man alles für alle Verzeichnisse und danach erlaubt man dann gezielt was man braucht, wo man es braucht.
Typischer Unix-Ansatz: Alles verboten, was nicht erlaubt ist. Wohingegen unter Windows meist alles erlaubt ist, was nicht verboten wurde.

Versuch vielleicht mal so in etwa:
<Directory / >
Options Indexes, FollowSymLinks
AllowOverride All
</Directory>

und allow from all


ach ich bin echt zu blöd für sowas. es geht einfach nicht. ich versteh die .htaccess echt nur soweit, wie z.b. errordokumente, umleitungen, verzeichnisse indexieren... aber sowas echt nee
  View user's profile Private Nachricht senden
 
Ähnliche Themen Mod Rewrite im Unterordner
mod rewrite | Ich checks nicht
Mod Rewrite und SEO
URL / Mod Rewrite
mod rewrite in .htaccess funktioniert nicht
[mod rewrite] url suchmaschinenfreundlich umschreiben
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.