mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 26.05.2017 02:07 Benutzername: Passwort: Auto-Login

Thema: Linksproblem vom 01.01.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Linksproblem
Autor Nachricht
EHST
Gesperrt
Threadersteller

Dabei seit: 08.08.2006
Ort: Orbg.-Sachsenhausen
Alter: -
Geschlecht: -
Verfasst Mo 01.01.2007 14:43
Titel

Linksproblem

Antworten mit Zitat Zum Seitenanfang

Tach!

Habe da ein kleines Problem mit relativen Links. Gehen wir mal davon aus, dass die Startdatei im Stammverzeichnis liegt.
In diese Datei wird eine Liste eingebunden
Code:
<?php include 'liste.php' ?>


Jetzt steht in der Liste ein Link mit folgendem Pfad "ordner1/a/a.php" Wenn ich jetzt auf a klicke (pfad zum einbinden der liste ist auf "../../liste.php" angepasst - ist ja auch nicht sooo relevant), dann befindet sich a.php aber im gleichen Ordner. Der Link würde also nicht mehr funktionieren
Wie bekomme ich es hin, dass die Links sozusagen vom Stammverzeichnis ausgehen? Also immer da starten und dem Pfad folgen.
Problem deutlich?
Wenn möglich keine Javascript-Lösung, wenn es denn eine Lösung gibt. Und bitte nicht "nimm absolute Links" schreiben. *zwinker*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mo 01.01.2007 20:29
Titel

Antworten mit Zitat Zum Seitenanfang

die links sind immer von der einbindenden datei ausgehend ..
deshalb versteh ich deine frage grad nicht?
  View user's profile Private Nachricht senden
Anzeige
Anzeige
 
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.