mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 26.11.2020 04:53 Benutzername: Passwort: Auto-Login

Thema: Joomla Fehlermeldung 404? vom 26.03.2008


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Joomla Fehlermeldung 404?
Seite: 1, 2  Weiter
Autor Nachricht
klsa12
Threadersteller

Dabei seit: 14.11.2007
Ort: Dresden
Alter: 35
Geschlecht: Männlich
Verfasst Mi 26.03.2008 18:28
Titel

Joomla Fehlermeldung 404?

Antworten mit Zitat Zum Seitenanfang

Mal wieder ich...

nun habe ich folgendes Problem. Auf meinem Webspace habe ich in einem unterordner (/var/www/html/web99/html/UNTERORDNER) mein Joomla 1.5 installiert (www.martin-boose.de).
Smartsef für Suchmaschinenfreundliche URLs ist auch im joomla installiert.

Meine Freundin wollte jetzt auf ihre Homepage (www.vincitrice.net) zugreifen die in in einem andren Unterordner des Hauptverzeichnisses meines Webspace liegt. Geht aber nicht mehr. Da kommt ständig die Fehlermeldung 404, die ich eigentlich nur von Joomla her kenne.

Aber da beide Seiten einen eigenen Ordner haben, verstehe ich nicht wie auf der Seite meiner Freundin eine Joomla-Meldung kommen kann, wenn ihre Seite gar nicht auf Joomla basiert.

Ich weiß ja noch nichtmal warum ihre Seite auf einmal nicht mehr geht???!!! Weiß jemand Rat?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
r2d2

Dabei seit: 27.02.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 26.03.2008 19:20
Titel

Antworten mit Zitat Zum Seitenanfang

Es sieht so aus als würde die Domain www.vincitrice.net in ein Verzeichnis auf deinen Webserver zeigen, dass es gar nicht mehr gibt.
Überprüfe mal im Confixx, Plesk oder was auch immer in welchen Ordner die Domain zeigt.
  View user's profile Private Nachricht senden
Anzeige
Anzeige
r2d2

Dabei seit: 27.02.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 26.03.2008 19:21
Titel

Antworten mit Zitat Zum Seitenanfang

Kannst du mir den Unterordner von der Website deiner Freundin mal posten?
  View user's profile Private Nachricht senden
klsa12
Threadersteller

Dabei seit: 14.11.2007
Ort: Dresden
Alter: 35
Geschlecht: Männlich
Verfasst Mi 26.03.2008 20:22
Titel

Antworten mit Zitat Zum Seitenanfang

Also das Verzeichnis existiert. In etwa ab dem Datum, ab dem ich Joomla 1.5 in mein Verzeichnis installiert habe, gingen auch die Besucherzahlen auf der Seite meiner Freundin auf 0/Tag. Deswegen denke ich das Joomla dran Schuld ist, auch wenn ichs komisch find.

Das ist das Verzeichnis von meiner Seite
/var/www/html/web99/html/bichareh

und das von meiner Freundin
/var/www/html/web99/html/line
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
r2d2

Dabei seit: 27.02.2008
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 26.03.2008 20:40
Titel

Antworten mit Zitat Zum Seitenanfang

Hast schon mal im Control Panel nachgesehen ob die Pfade stimmen:

domaindeinerfreundin /line
deinedomain /bichareh ( Das passt ja soweit )

Deine Domain nehme ich mal an ist die Hauptdomain, die deiner Freundin die Nebendomain. Hast du Joomal auch in deinem Ordner installiert bzw. die install.php in diesem ausgeführt?
  View user's profile Private Nachricht senden
Impigra

Dabei seit: 17.05.2006
Ort: Egenhofen
Alter: 42
Geschlecht: Männlich
Verfasst Mi 26.03.2008 21:41
Titel

Antworten mit Zitat Zum Seitenanfang

Hmmmm... scheint lustig zu sein mit Systemen zu schrauben von denen man keine Ahnung hat * Applaus, Applaus *

Ich kenn Joomla jetzt nicht besonders gut... und nehme auch einfach nur an...
Dieses Joomla Modul für "Suchmaschinenfreundliche URLs" verwendet das mod_rewrite Modul für den Apache...

Du könntest mal versuchen das Jooomla Modul restlos zu entfernen....
Oder aber mal nachsehen obs da irgendwo ne .htaccess Datei gibt in der irgendwas von rewrite_base drinnen steht...
diese anpassen... oder Ausschlusskriterien definieren... dann werden die von dem rewritig ausgeschlossen... *zwinker*

Oder einfach mal alle .htaccess Dateien umbenennen... dann kannst Du schon mal ausschliessen dass es an einem mod rewrite über htaccess liegt...

ach ja... falls Dein FTP Programm keine .htaccess Datei findest .. evtl mal versteckte Dateien aktivieren... dann sollten zumindest die angezeigt werden...

Wenns nix davon war erweitere ich meine ganz oben getroffene aussage... die lautet dann *hehe*
scheint lustig zu sein mit Systemen zu schrauben von denen man keine Ahnung hat und sich dann auch noch nen Tipp von jemandem geben lassen der ebenso wenig Ahnung hat *hu hu huu*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 43
Geschlecht: Männlich
Verfasst Mi 26.03.2008 22:10
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
ach ja... falls Dein FTP Programm keine .htaccess Datei findest .. evtl mal versteckte Dateien aktivieren... dann sollten zumindest die angezeigt werden...

Nicht nur eventuell. Dateien, deren Name mit einem Punkt beginnt, sind auf einem Unix(-ähnlichem)-System versteckte Dateien. Aber jeder anständige FTP-Client bietet irgendwo eine Option, um solche Files auch anzuzeigen.

Zitat:
Du könntest mal versuchen das Jooomla Modul restlos zu entfernen....

Aber wenn dieses Modul keine richtige Deinstallationsroutine besitzt, werden die htaccess-Files sicherlich auf dem Server liegen bleiben. Ich kann mir eigentlich nicht vorstellen, daß die automatisch gelöscht werden.
Da bleibt sicherlich nichts anderes, als die manuell zu löschen.
Aber eventuell stehen da auch noch andere wichtige Dinge drin, insofern wäre es wohl besser, wenn man erst einmal einen Blick rein wirft, bevor man die restlos killt.
  View user's profile Private Nachricht senden
klsa12
Threadersteller

Dabei seit: 14.11.2007
Ort: Dresden
Alter: 35
Geschlecht: Männlich
Verfasst Do 27.03.2008 12:15
Titel

Antworten mit Zitat Zum Seitenanfang

Aaaaalso...danke für die zahlreichen Antworten erstmal.

Ich habe jetzt mal die .htaccess datei aus dem ordner meiner joomla-seite gelöscht......und siehe da, die joomla 404-fehlermeldung ist weg bei der website meiner freundin. dafür kommt aber nun eine andere "normale" nicht-joomla meldung.

"Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden."

Die Seite meiner Freundin ist aber immer noch an selber Stelle, haben ja daran nichts geändert. Ich habe lediglich MEINE vorherige Seite auf joomla 1.5.2 umgestellt + smartsef

da ich meine suchmaschinenfreundlichen urls nicht verlieren will, habe ich die datei jetzt wieder in meinen ordner reinkopiert.

gehe ich nun richtig in der annahme das die .htaccess umgeschrieben werden muss irgendwie damit auch ihre Seite endlich wieder geht?

so sieht meine .htaccess aus...

Zitat:
##
# @version $Id: htaccess.txt 4094 2006-06-21 18:35:46Z stingrey $
# @package Joomla
# @copyright Copyright (C) 2005 - 2006 Open Source Matters. All rights reserved.
# @license GNU/GPL
# Joomla! is Free Software
##

#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
# Only use one of the two SEF sections that follow. Lines that can be uncommented
# (and thus used) have only one #. Lines with two #'s should not be uncommented
# In the section that you don't use, all lines should start with #
#
#####################################################

##### SOLVING PROBLEMS WITH COMPONENT URL's that don't work #####
# SPECIAL NOTE FOR SMF USERS WHEN SMF IS INTEGRATED AND BRIDGED
# OR ANY SITUATION WHERE A COMPONENT's URL's AREN't WORKING
#
# In both the 'Standard SEF', and '3rd Party or Core SEF' sections the line:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# May need to be uncommented. If you are running your Joomla from
# a subdirectory the name of the subdirectory will need to be inserted into this
# line. For example, if your Joomla is in a subdirectory called '/test/',
# change this:
# RewriteCond %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
# to this:
# RewriteCond %{REQUEST_URI} ^(/test/component/option,com) [NC,OR] ##optional - see notes##
#
#####################################################


## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On


# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
############# Use this section if you are using a 3rd party (Non Joomla! core) SEF extension - e.g. OpenSEF, 404_SEF, 404SEFx, SEF Advance, etc
#
RewriteCond %{REQUEST_URI} ^(/bichareh/component/option,com) [NC,OR] ##optional - see notes##
RewriteCond %{REQUEST_URI} (/|\.atom|\.rss|\.htm|\.php|\.pdf|\.html|/[^.]*)$ [NC]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule (.*) index.php
#
########## End - Joomla! core SEF Section
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen 404 Error !
error 404
zu viele Hits auf 404
Immer noch 404 bei Schlund
Zuviele Zugriffe auf 404 Errorseite - Zurückverfolgen?
Joomla! Problem ((Joomla) vor CSS-Pfad)
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.