mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 23.11.2017 23:28 Benutzername: Passwort: Auto-Login

Thema: [joomala]css wird nicht geladen vom 27.02.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> [joomala]css wird nicht geladen
Seite: 1, 2  Weiter
Autor Nachricht
Sunlifestyle
Threadersteller

Dabei seit: 20.12.2005
Ort: Hoyerswerda bei Dresden
Alter: -
Geschlecht: Männlich
Verfasst Di 27.02.2007 20:46
Titel

[joomala]css wird nicht geladen

Antworten mit Zitat Zum Seitenanfang

gelöst

Zuletzt bearbeitet von Sunlifestyle am Mi 07.03.2007 11:36, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
sahnemuh

Dabei seit: 19.06.2003
Ort: /dev/null
Alter: 36
Geschlecht: Männlich
Verfasst Di 27.02.2007 20:56
Titel

Antworten mit Zitat Zum Seitenanfang

da fehlt ein leerzeichen vor dem schließenden / beim link tag für die css datei
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Sunlifestyle
Threadersteller

Dabei seit: 20.12.2005
Ort: Hoyerswerda bei Dresden
Alter: -
Geschlecht: Männlich
Verfasst Di 27.02.2007 21:11
Titel

Antworten mit Zitat Zum Seitenanfang

also an dem leerzeichen kann es nicht gelegen haben...es ist jetzt drin..aber der fehler nicht weg
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Sunlifestyle
Threadersteller

Dabei seit: 20.12.2005
Ort: Hoyerswerda bei Dresden
Alter: -
Geschlecht: Männlich
Verfasst Di 27.02.2007 21:13
Titel

Antworten mit Zitat Zum Seitenanfang

kann es sein das der ie den _ nicht mag?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Zeithase

Dabei seit: 09.05.2005
Ort: Erfurt
Alter: 32
Geschlecht: Männlich
Verfasst Di 27.02.2007 21:15
Titel

Antworten mit Zitat Zum Seitenanfang

Da ist ein "ü" im Link. Böse. Ganz böse. Richtig wäre:

Zitat:
/templates/bootstouren-ruhlm%FChle/css/template_css.css
  View user's profile Private Nachricht senden
Sunlifestyle
Threadersteller

Dabei seit: 20.12.2005
Ort: Hoyerswerda bei Dresden
Alter: -
Geschlecht: Männlich
Verfasst Di 27.02.2007 21:50
Titel

Antworten mit Zitat Zum Seitenanfang

ja habe ich auch mitbekommen..habe gestern versehentlich das template umbenant und nicht an den leicht beschränkten ie gedach;)

danke trotzdem!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 40
Geschlecht: Männlich
Verfasst Di 27.02.2007 21:53
Titel

Antworten mit Zitat Zum Seitenanfang

--------------------------------------------------------------------------------
EDIT: wie ich sehe, hat sich das problem wohl jetzt erledigt...
trotzdem sind noch einige fehler im code, die ich berichtigen würde.
--------------------------------------------------------------------------------

also da sind einige fehler im quellcode drin... weiß nicht genau, warum der IE die css-datei nicht mag, aber vielleicht hilft es, wenn du die fehler berichtigst..
es beginnt schon mal damit, daß die xml-deklaration nach der dtd-angabe steht.

statt:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<?xml version="1.0" encoding="iso-8859-1"?><html xmlns="http://www.w3.org/1999/xhtml">

sollte es so aussehen:
Code:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">


dann sind da gleich noch mehr fehler. hier ist eine falsche spitzklammer mit reingerutscht.
Code:
<meta http-equiv="Content-Type" content="text/html;>charset=iso-8859-1" />

sollte wohl eher so aussehen:
Code:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />


sonst fällt mir noch auf, daß du in den links das & nicht codiert hast:
Code:
<a href="index.php?option=com_content&task=view&id=5&Itemid=

es müßte so aussehen:
Code:
<a href="index.php?option=com_content&task=view&amp;id=5&amp;Itemid=


sind noch mehr fehler drin, aber das sind jetzt erstmal die, die mir gleich aufgefallen sind. ich würde in jedem fall mal den w3c-validator nutzen, um alle code-fehler zu finden (und diese dann berichtigen).


vielleicht liegt es aber auch gar nicht am xhtml-code, sondern an der css-datei. eventuell ist die auch fehlerhaft bzw. irgendwas drin, was der IE nicht mag. da hab ich aber jetzt gar nicht reingeschaut.
du kannst den w3c-validator benutzen, um die fehler im html-code zu finden und einen validator für css gibt es da ebenfalls...

BTW: mit welchem mime-type wird die seite eigentlich ausgeliefert und welche dateiendung hat die seite?
davon ist nämlich abhängig, ob der IE den html- oder den xml-parser einsetzt...


Zuletzt bearbeitet von rob am Di 27.02.2007 21:56, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
sahnemuh

Dabei seit: 19.06.2003
Ort: /dev/null
Alter: 36
Geschlecht: Männlich
Verfasst Di 27.02.2007 22:05
Titel

Antworten mit Zitat Zum Seitenanfang

rob hat geschrieben:
--------------------------------------------------------------------------------
EDIT: wie ich sehe, hat sich das problem wohl jetzt erledigt...
trotzdem sind noch einige fehler im code, die ich berichtigen würde.
--------------------------------------------------------------------------------

also da sind einige fehler im quellcode drin... weiß nicht genau, warum der IE die css-datei nicht mag, aber vielleicht hilft es, wenn du die fehler berichtigst..
es beginnt schon mal damit, daß die xml-deklaration nach der dtd-angabe steht.

statt:
Code:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<?xml version="1.0" encoding="iso-8859-1"?><html xmlns="http://www.w3.org/1999/xhtml">

sollte es so aussehen:
Code:
<?xml version="1.0" encoding="iso-8859-1"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">


richtig ist es sicher.. aber machen sollte man es nur, wenn man den IE<7 in den quirksmode katapultieren will (leider) *Schnief*


Zuletzt bearbeitet von sahnemuh am Di 27.02.2007 22:05, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
 
Ähnliche Themen html email-sig warum wird das css nicht geladen
Prüfen ob MC fertig geladen...
Seite wird fehlerhaft geladen
Popup load - Die Seite wird geladen
[solved] Papervision3D - Klassen werden nicht geladen
wordpress - plugin/script wird nicht geladen
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.