mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 06.06.2020 14:51 Benutzername: Passwort: Auto-Login

Thema: Flashplayer Datei mp3 - Autostart in HTML Frames einbinden vom 12.02.2011


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Flashplayer Datei mp3 - Autostart in HTML Frames einbinden
Autor Nachricht
Werbehaus
Threadersteller

Dabei seit: 09.01.2007
Ort: Teublitz
Alter: 43
Geschlecht: Männlich
Verfasst Sa 12.02.2011 11:28
Titel

Flashplayer Datei mp3 - Autostart in HTML Frames einbinden

Antworten mit Zitat Zum Seitenanfang

Hallo @ all hier im Forum.
Ich benötige Hilfe. Ich habe die Webseite in Dreamweaver mit Frames geändert. Es funktioniert auch alles, alle eingebundenen mp3's. Nur war die Idee, beim öffnen der Webseite eine Art Autostartfunktion einfügen.

Dies habe ich im unterem Frame mit Flashplayer eingefügt. Nur ist hier das Problem, er startet nicht von selbst und auch das mp3 File kann ich nicht auswählen. Ich meine ich habe alle Pfade richtig angegeben und diese befinden sich auch so auf dem Server.
Selbst könnt Ihr mal unter www.lenydee.de nachschauen.

Die swf Datei heisst: emff_standard.swf
und das mp3 File: diddy_dirty_money_-_angels__instrumental_.mp

Hier im Anhang ist mal der komplette Code:
Code:


<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
<script src="../Scripts/AC_ActiveX.js" type="text/javascript"></script>
</head>

<body style="BACKGROUND-ATTACHMENT: fixed; BACKGROUND-IMAGE: url(spacer_data/template_unten.png);background-repeat:no-repeat;" link="#EBE1CC" vlink="#EBE1CC" alink="#EBE1CC" text="#EBE1CC" bgcolor="#EBE1CC" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0">

<div align="center">
  <p><font face="Arial, Helvetica, sans-serif" size="2" color="#EBE1CC"><font size="1"><a href="frameset_impressum.htm" target="bottomFrame1"><br>
  Impressum</a></font></font></p>
 
  <div id="Layer1" style="position: absolute; width: 110px; height: 30px; z-index: 1; left: 592px; top: 6px; visibility: visible;">


<script type="text/javascript">
AC_FL_RunContent( 'codebase','http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0','width','110','height','30','src','frame_unten_data/emff_standard','quality','high','pluginspage','http://www.macromedia.com/go/getflashplayer','movie','frame_unten_data/emff_standard' ); //end AC code
AC_FL_RunContent( 'type','application/x-shockwave-flash','data','frame_unten_data/emff_standard.swf','height','30','width','110','movie','emff_standard?src=frame_unten_data/diddy_dirty_money_-_angels__instrumental_.mp3&autostart=yes','quality','high','wmode','transparent' ); //end AC code
</script>

<noscript>
<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=7,0,19,0" width="100" height="30">
  <param name="movie" value="emff_standard.swf?src=frame_unten_data/diddy_dirty_money_-_angels__instrumental_.mp3&amp;autostart=yes">
  <param name="movie" value="frame_unten_data/emff_standard">
  <param name="quality" value="high">
  <param name="wmode" value="transparent">
  <embed src="emff_standard.swf" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="110" height="30"></embed>
</object>
</noscript>

</div>
</div>
</body>
</html>


Ich freue mich, wenn jemand hier den eventuellen Fehler hier im Code mir zeigen kann. Es kann ja nur noch am Code liegen. Denke ich.

lg Steffen


Zuletzt bearbeitet von choise am Mo 14.02.2011 14:28, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
DerM

Dabei seit: 18.01.2009
Ort: -
Alter: 38
Geschlecht: Männlich
Verfasst Sa 12.02.2011 12:02
Titel

Antworten mit Zitat Zum Seitenanfang

Erstens, bitte Codetags verwenden.
Zweitens, dein Code ist so oder so Kraut und Rüben, und überhaupt nicht valide!
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Werbehaus
Threadersteller

Dabei seit: 09.01.2007
Ort: Teublitz
Alter: 43
Geschlecht: Männlich
Verfasst Sa 12.02.2011 18:14
Titel

Flashplayer Datei mp3 - Autostart in HTML Frames einbinden

Antworten mit Zitat Zum Seitenanfang

Oh Danke.

Ich habe mal alles soweit umgestellt und alles wieder hochgeladen - www.lenydee.de

Passt alles super. Jetzt mache ich mich nur noch an css ran. Damit ich alles auf den neusten Stand bringe.

Zur Sicherheit habe ich mal dem gesamten Code hier zum sehen reingestellt. Wenn jemand doch noch was am Code sieht bitte einfach kurz melden.
Code:

<html>
<head>
<title>DJ LenyDee</title>
<style type="text/css">
     <!--
     a{text-decoration:none}
     -->
     </style>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script src="../Scripts/AC_RunActiveContent.js" type="text/javascript"></script>
<script src="../Scripts/AC_ActiveX.js" type="text/javascript"></script>

</head>

<body style="BACKGROUND-ATTACHMENT: fixed; BACKGROUND-IMAGE: url(spacer_data/template_unten.png);background-repeat:no-repeat;" link="#EBE1CC" vlink="#EBE1CC" alink="#EBE1CC" text="#EBE1CC" bgcolor="#EBE1CC" topmargin="0" leftmargin="0" marginwidth="0" marginheight="0">

<div align="center">
  <p><font face="Arial, Helvetica, sans-serif" size="2" color="#EBE1CC"><font size="1"><a href="frameset_impressum.htm" target="bottomFrame1"><br>
  Impressum</a></font></font></p>
 
  <div id="Layer1" style="position: absolute; width: 110px; height: 35px; z-index: 1; left: 592px; top: 11px; visibility: visible;">

<OBJECT ID="MediaPlayer" classid="CLASSID=CLSID:22d6f312-b0f6-11d0-94ab-0080c74c7e95"
CODEBASE="CODEBASE=http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6,4,5,715"
width="150" height="16" standby="Loading Microsoft Windows Media Player components..."
type="application/x-oleobject">
<PARAM NAME="FileName" VALUE="frame_unten_data/diddy_dirty_money_-_angels__instrumental_.mp3">
<PARAM NAME="TransparentAtStart" Value="1">
<PARAM NAME="AutoStart" Value="1">
<PARAM NAME="AnimationatStart" Value="1">
<PARAM NAME="ShowStatusBar" Value="1">
<PARAM NAME="ShowControls" Value="1">
<PARAM NAME="autoSize" Value="0">
<PARAM NAME="displaySize" Value="0">
<PARAM NAME="ShowAudioControls" Value="1">
<PARAM NAME="ShowPositionControls" Value="0">
<Embed type="application/x-mplayer2"
pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/Products/MediaPlayer/"
src="frame_unten_data/diddy_dirty_money_-_angels__instrumental_.mp3" _mce_src="frame_unten_data/diddy_dirty_money_-_angels__instrumental_.mp3" Name="MediaPlayer"
width="150" height="16" transparentAtStart="1" autostart="1"
animationAtStart="0" ShowControls="1" ShowAudioControls="1"
ShowPositionControls="0" autoSize="0" ShowStatusBar="1" displaySize="0">
</embed></OBJECT>


</div>
</div>
</body>
</html>

Danke für die Hilfe.

lg Steffen


Zuletzt bearbeitet von choise am Mo 14.02.2011 14:26, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
immerIch

Dabei seit: 19.10.2010
Ort: #mein{display:block}
Alter: 31
Geschlecht: Männlich
Verfasst Mo 14.02.2011 11:22
Titel

Antworten mit Zitat Zum Seitenanfang

Dir fehlt zudem noch das korrekt Doctype.

Zu der Unübersichtlichkeit deines Codes trägt dein Inline-Css noch ein gutes Stück mit bei, lager dein Css mal in eine extra Datei aus....
Der Übersichtlichkeit halber wäre es auch sinnvoll sich zu entscheiden, ob du nun die Html-Tags grop oder klein schreibst. Im Grunde ist es Wumpe, sieht aber einfach wirrwarr aus....

Ach ja, wie ich HTML5 liebe, da hat der ganze Zirkus mit Object und Param usw. endlich ein Ende....

Bleibt noch die Frage, wer so eine Autostart-Funktion braucht? Mich, und da bin ich mit Sicherheit nicht der Einzige, nervt das schon ziemlich, wenn im Hintergrund plötzlich ungefragt irgendwas umherdüdelt....


Gruß
  View user's profile Private Nachricht senden
stifler_wob

Dabei seit: 28.04.2010
Ort: Wolfsburg
Alter: 28
Geschlecht: Männlich
Verfasst Di 15.02.2011 15:52
Titel

Antworten mit Zitat Zum Seitenanfang

Dito,
dann lieber eine anfrage und dem User selbst enscheiden zu lassen.

Btw: Lieber einen eigenen Flashplayer basteln. Sieht stimmiger aus, und du weist was du hast, bzw. kannst es leicht editieren!
  View user's profile Private Nachricht senden
black.IP

Dabei seit: 23.04.2003
Ort: Hamburg
Alter: 47
Geschlecht: Männlich
Verfasst Do 08.03.2012 18:25
Titel

Antworten mit Zitat Zum Seitenanfang

immerIch hat geschrieben:
Dir fehlt zudem noch das korrekt Doctype.

Zu der Unübersichtlichkeit deines Codes trägt dein Inline-Css noch ein gutes Stück mit bei, lager dein Css mal in eine extra Datei aus....
Der Übersichtlichkeit halber wäre es auch sinnvoll sich zu entscheiden, ob du nun die Html-Tags grop oder klein schreibst. Im Grunde ist es Wumpe, sieht aber einfach wirrwarr aus....

Ach ja, wie ich HTML5 liebe, da hat der ganze Zirkus mit Object und Param usw. endlich ein Ende....

Bleibt noch die Frage, wer so eine Autostart-Funktion braucht? Mich, und da bin ich mit Sicherheit nicht der Einzige, nervt das schon ziemlich, wenn im Hintergrund plötzlich ungefragt irgendwas umherdüdelt....


Gruß


Moin, wie läuft'n das eigentlich in HTML5, wenn man eine SWF einbauen will - mit einer Alternativweiche für Geräte ohne Flashplayer? Finde zu dem Thema irgendwie nix im Netz.

sG, Tobi
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen autostart und html datei
WMV Datei in html einbinden
VOB/IFO Datei in html einbinden?
MP4-Datei in HTML-Seite einbinden
Externe .txt oder .rtf Datei in (X)HTML einbinden
Text aus einer externen Datei in HTML <div> einbinden
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.