mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 26.05.2019 00:08 Benutzername: Passwort: Auto-Login

Thema: Mein Flash-Preloader zickt! vom 17.07.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> Mein Flash-Preloader zickt!
Autor Nachricht
smartybauer
Threadersteller

Dabei seit: 15.01.2007
Ort: Kiel
Alter: 42
Geschlecht: Männlich
Verfasst Di 17.07.2007 17:54
Titel

Mein Flash-Preloader zickt!

Antworten mit Zitat Zum Seitenanfang

Hallo Leute,

ich habe da ein kleines Problem.
Ich möchte für einen Flash-Film einen Preloader scripten.
In einen Tutorial habe ich ein Beispiel gefunden, das auch
sahnemäßig funzt, wenn mann es mit 2 Frames auf der Zeitleiste
umsetzt.(Frame 1 = Preloader; Frame 2 = Inhalt)
Im Download-Profiler wird dann angezeigt, dass die Hauptdaten
im 2.Frame liegen.

Und hier mein Problem:
Bei meinem Flash-Film liegen die Hauptdaten alle im 1.Frame!
Auch, wenn auf der Zeitleiste das 1.Frame völlig frei ist und nur
den Preloader beinhaltet.
So kann ich natürlich lange warten, bis der Preloader gezeigt wird.

Meine Frage an Euch: Hä?
Kann man da was drehen? Bzw. Was habe ich da falsch gemacht?
Please, Heeeeeelp!!!!! * Ich geb auf... *


Vielen Dank im Voraus
SmartyBauer
  View user's profile Private Nachricht senden
phihochzwei
Moderator

Dabei seit: 08.06.2006
Ort: Mülheim an der Ruhr
Alter: 41
Geschlecht: Männlich
Verfasst Di 17.07.2007 18:06
Titel

Antworten mit Zitat Zum Seitenanfang

FLA ?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
woarms

Dabei seit: 03.07.2007
Ort: -
Alter: 37
Geschlecht: Weiblich
Verfasst Mi 18.07.2007 14:28
Titel

Antworten mit Zitat Zum Seitenanfang

Ich würde alles um einen Frame nach rechts schieben und den Preloader auf alle fälle alleine in den ersten Frame.

Warum muss dein Film unbedingt im ersten Frame beginnen?
  View user's profile Private Nachricht senden
ingrimm

Dabei seit: 18.07.2007
Ort: Neulussheim
Alter: -
Geschlecht: Männlich
Verfasst Mi 18.07.2007 15:02
Titel

Antworten mit Zitat Zum Seitenanfang

damit dein preloader richtig läuft musst du ihn ein eine eigenständige swf packen und dann deine haupt swf laden lassen.
auch skripte die sich im ersten frame der hauptzeitleiste befinden greifen immer noch nicht alle ladevorgänge ab. z.b. wird alles was per attachmovie aus der bibliothek geholt wird in das nullte schlüsselbild geladen.

also aufbau wie folgt:

1. loader aufrufen
2. loader lädt main
3. main geniessen.

und versuch dich bitte an der verwendung des moviecliploaders, einer einegebauten flash 8 klasse die bereits verschiedene listener eingebaut hat wie onLoadProgress, onComplete, onLoadInit usw. schau einfach mal in die flash hilfe.
  View user's profile Private Nachricht senden
smartybauer
Threadersteller

Dabei seit: 15.01.2007
Ort: Kiel
Alter: 42
Geschlecht: Männlich
Verfasst Mi 18.07.2007 17:49
Titel

Antworten mit Zitat Zum Seitenanfang

Danke für deinen Tip mit dem Loader.
Habe mich mal mit der Loader Komponente
auseinandergesetzt. Funktioniert prima.
Nochmals besten Dank.
  View user's profile Private Nachricht senden
 
Ähnliche Themen flash zickt
[flash]Ab wann Preloader?
[Flash] Preloader
preloader in flash
Flash Preloader
[HILFE!] Preloader in Flash MX
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.