mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 27.02.2017 14:49 Benutzername: Passwort: Auto-Login

Thema: Flash - Kontakt Formular Probleme vom 08.03.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> Flash - Kontakt Formular Probleme
Seite: Zurück  1, 2, 3, 4, 5  Weiter
Autor Nachricht
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 34
Geschlecht: Männlich
Verfasst Di 08.03.2005 13:17
Titel

Antworten mit Zitat Zum Seitenanfang

auf _level0 liegt meine start.swf!
denn wen ich in formular.swf wieder zur start möchte nutze ich

>>
on(release){
_level0.gotoAndPlay(1);
}
<<
... d.h. meine formular.swf dürfte das level sein welches ich bei der start.swf vergebe.
quasi in meinem fall loadMovieNum("formular.swf", 65);


Zuletzt bearbeitet von Kash am Di 08.03.2005 13:27, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 34
Geschlecht: Männlich
Verfasst Di 08.03.2005 15:36
Titel

Antworten mit Zitat Zum Seitenanfang

kann wirklich keiner weiterhelfen?
  View user's profile Private Nachricht senden
Anzeige
Anzeige
mikesch

Dabei seit: 15.04.2002
Ort: Leverkusen
Alter: 40
Geschlecht: Männlich
Verfasst Mi 09.03.2005 10:10
Titel

Antworten mit Zitat Zum Seitenanfang

akzeptiert der Server den Get oder Post oder beide Arrays.
musst du die variablen vielleichtin der mail noch importieren . Siehe servereinstellungen


für genaueres bräuchte ich mehr code
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 34
Geschlecht: Männlich
Verfasst Mi 09.03.2005 10:41
Titel

Antworten mit Zitat Zum Seitenanfang

den des PhP scriptes oder AS??

AS:
>>

System.useCodePage = true;

plz.restrict = "0-9";

_root.onLoad = function() {
_root.mc_falsch._visible = false;
_root.vorname.text = "Ihr Vorname";
_root.name.text = "Ihr Name";
_root.firma.text = "Ihre Firmenbezeichnung";
_root.land.text = "Ihr Land";
_root.str.text = "Ihre Ihre Strasse";
_root.plz.text = "Ihre Postleitzahl";
_root.ort.text = "Ihr Wohnort";
_root.telefon.text = "Ihre Telefonnummer";
_root.telefax.text = "Ihre Telefaxnummer";
_root.email.text = "Ihre Mail Adresse";
_root.nachricht.text = "Ihre Mitteilung an uns...";
};
// Instanznamen
textfeld = new Array();
textfeld[0] = "vorname";
textfeld[1] = "name";
textfeld[2] = "firma";
textfeld[3] = "land";
textfeld[4] = "str";
textfeld[5] = "plz";
textfeld[6] = "ort";
textfeld[7] = "telefon";
textfeld[8] = "telefax";
textfeld[9] = "email";
textfeld[10] = "nachricht";



for (i=0; i<textfeld.length; i++) {

_root[textfeld[i]].onSetFocus = function() {
this.backgroundColor = 0xFFCC00;

if (_root[this._name]) {
_root[this._name].text = "";
_root[this._name] = false;
}
};

_root[textfeld[i]].onKillFocus = function() {
this.backgroundColor = 0xFFFF9C;
};
}

String.prototype.leer = function() {
for (i=0; i<this.length; i++) {

if (this.charCodeAt(i)>32) {
return true;
}
}
};
// Button
senden_klick.onRelease = function() {

if (txt_email.indexOf("@") == -1 || txt_email.length<6 || _root.name.text.leer() || _root.nachricht.text.leer() ) {

_root.mc_falsch._visible = true;
} else {

_root.mc_falsch._visible = false;
this.loadVariables("senden2.php", "", "GET");
_root.mc_gesendet._visible = true;
}
};
<<

PhP Script:
>>
<?
$suchen = "\r";
$ersetzen = "\n";
// Suche und ersetzte, da Flash Zeilenumbrueche mit \r angibt
// und php aber nur mit \n arbeitet
$nachricht_neu = str_replace($suchen,$ersetzen,$_GET[txt_nachricht]);
$text = $_GET[txt_name].", übermittelt Ihnen folgende Informationen:\n";
$text .= "Vorname: $_GET[txt_vorname]\n";
$text .= "Name: $_GET[txt_name]\n";
$text .= "Firma: $_GET[txt_firma]\n";
$text .= "Land: $_GET[txt_land]\n";
$text .= "Strasse: $_GET[txt_str]\n";
$text .= "PLZ: $_GET[txt_plz]\n";
$text .= "Wohnort: $_GET[txt_ort]\n";
$text .= "Telefon: $_GET[txt_telefon]\n";
$text .= "Telefax: $_GET[txt_telefax]\n";
$text .= "e-Mail: $_GET[txt_email]\n";
$text .= "Nachricht: $nachricht_neu \n";
$empfanger = "******";
mail($empfanger, "*****", $text, "Von: ****** Kontakt-Formular");
$besta = "$_GET[txt_name], danke für Ihre Nachricht!\n";
$besta .= "Ihre Anfrage an die **** haben wir erhalten\n";
mail("$_GET[txt_email]", "Bestätigungsemail", $besta, "From: ******");
?>
<<

das wäre alles an code Lächel
  View user's profile Private Nachricht senden
tuxedo

Dabei seit: 10.10.2002
Ort: ~/
Alter: 44
Geschlecht: -
Verfasst Mi 09.03.2005 11:31
Titel

Antworten mit Zitat Zum Seitenanfang

also ich habe ehrlich gesagt das problem, das ich deine fehlerbeschreibung
nicht so ganz verstehe.
-- geht es darum, das die mails nicht korrekt versandt werden, es also ein problem mit der
externen kommunikation geht...
-- geht es darum, das die überprüfung der einzelnen textfelder innerhalb deines films nicht
funktioniert...
-- oder geht es darum, das die gesamte funktionalität deines formulars nach laden auf eine
andere position nicht funktioniert?


hast du dir mal die verschiedenen werte tracen lassen?
was sagt der gute alte variablenüberblick?
was sagt der debugger?
* Keine Ahnung... *
  View user's profile Private Nachricht senden
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 34
Geschlecht: Männlich
Verfasst Mi 09.03.2005 11:46
Titel

Antworten mit Zitat Zum Seitenanfang

ich dachte ich hätte es ausführlich erklärt.
+das versenden der mail funktioniert.
+wenn ich die formular.swf direkt lade und nicht von meinem hauptfilm heraus dann funktioniert es einwandfrei
+und letzters wird wohl das problem sein, denn sobald ich die formular.swf von meiner start.swf lade, dann funktioniert es nicht.

ich habe die nötigen Dateien online

http://www.rapspetrol.de/problem_zip.ace

und nein, eine ausgabe (trace) habe ich nicht gemacht.
und der debugger sagt alles in ordnung
  View user's profile Private Nachricht senden
JanG

Dabei seit: 13.10.2002
Ort: Köln/Düsseldorf
Alter: -
Geschlecht: Männlich
Verfasst Mi 09.03.2005 15:32
Titel

Antworten mit Zitat Zum Seitenanfang

Nachgeladene filme liegen ja auch nicht mehr direkt auf _root sondern im Level oder im MC, wo die Swf eingeladen wurde. Dein ganzer Code scheint für nen "Startfilm" gemacht zu sein. Ich hab kein Bock wieder alles abzuarbeiten für umme (hie rim Forum hört man selten nen Danke), aber kannst ja mal deine Pfade eingleichen mit _parent. und halt was man da so brauch. Keine Ahnung wie die Dinger bei dier Verschachtelt sind.

Peaze!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 34
Geschlecht: Männlich
Verfasst Mi 09.03.2005 16:00
Titel

Antworten mit Zitat Zum Seitenanfang

zur info.
das ist meine erste frage hier.
und bedankt habe ich mich immer.
ich danke dir auch für den tipp mit parent.

das level wäre ja das ich von dem start film lade.
loadMovieNum("formular.swf", 65); in meinem fall level 65????
  View user's profile Private Nachricht senden
 
Ähnliche Themen kontakt/anmelde-formular
Kontakt-Formular im Dreamweaver - wer hilft?
Kontakt Formular Coden. Help!
[PHP]Problem mit Kontakt Formular
Dreamweaver Kontakt-Formular - wer hilft?
brauche hilfe für php kontakt formular
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2, 3, 4, 5  Weiter
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.