mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 18.07.2024 19:18 Benutzername: Passwort: Auto-Login

Thema: Greybox Fehler? vom 09.04.2008


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Programmierung -> Greybox Fehler?
Autor Nachricht
bsights
Threadersteller

Dabei seit: 21.09.2005
Ort: Hamburg
Alter: -
Geschlecht: Männlich
Verfasst Mi 09.04.2008 01:33
Titel

Greybox Fehler?

Antworten mit Zitat Zum Seitenanfang

Hallo!

Kann mir jemand erklären, was ich hier falsch mache? Auf [url= http://marokko.bsights.de] http://marokko.bsights.de[/url] gibt es folgenden Link "Marokko Bildergalerie", der zu zunächst zwei Bildern führt, die in einer Greybox-Galerie miteinander verbunden sein sollen.

Ich habe die greybox dort installiert, die funktioniert auch, nur werden die Bilder nicht geladen, obwohl die Adressen der Bilder stimmen. Stattdessen wird meine error-page gezeigt. Wie kann das sein?

Über Hilfe wäre ich sehr dankbar.

Viele Grüße
Alexander


Zuletzt bearbeitet von bsights am Mi 09.04.2008 01:34, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Spurlos

Dabei seit: 29.10.2005
Ort: -
Alter: 42
Geschlecht: Männlich
Verfasst Mi 09.04.2008 01:44
Titel

Antworten mit Zitat Zum Seitenanfang

hmmm vllt liegts einfach an der subdomain? oder .htaccsess!?
  View user's profile Private Nachricht senden
Anzeige
Anzeige
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mi 09.04.2008 08:44
Titel

Antworten mit Zitat Zum Seitenanfang

Code:
GET /marokko/greybox/loader_frame.html?s=0 HTTP/1.1
Host: bsights.de

HTTP/1.x 302 Found
Date: Wed, 09 Apr 2008 06:42:50 GMT
Server: Apache/1.3 (Unix) mod_ssl/2.8.28 OpenSSL/0.9.8f AuthPG/1.3 FrontPage/5.0.2.2635
Location: http://www.bsights.de/error.html
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1


Vielleicht mal probieren auch alles hochzuladen? Lächel
  View user's profile Private Nachricht senden
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 47
Geschlecht: Männlich
Verfasst Mi 09.04.2008 08:57
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
Vielleicht mal probieren auch alles hochzuladen?

Das könnte eventuell sein. Klingt aber nicht so ganz wahrscheinlich.
Warum sendet der Server einen 302-Code?
Das bedeutet: "Moved Temporarily". Hätte man vergessen, eine Datei hochzuladen, würde der Server sicherlich einen 404-Code ("Not Found") zurückgeben.
siehe SelfHTML: Webserver Statuscodes

Fordere ich den URL des Bildes, der auf dem Link "Marokko Bildergalerie" liegt, direkt an, wird die Datei gefunden.
Ich würde mir das Script mal genau ansehen. Setze einen JavaScript-Debugger ein (ich empfehle Venkman), wenn du nicht mehr weiter weißt.
Dazu habe ich in einem anderen Posting ein paar Links gepostet.

EDIT:
Nachdem ich gerade gesehen habe, daß du aus Hamburg kommst (wo ich ursprünglich auch herkomme), wollte ich mal einen Blick auf die Adresse werfen.
Dabei mußte ich feststellen, daß im Impressum keine vorhanden ist. Rechtlich bist du zu dieser Angabe im Impressum verpflichtet.
Und mit der Emailadresse gibt es sicherlich auch Probleme. Diese wird nämlich nur dann gezeigt, wenn ein User JavaScript aktiviert hat. Das kannst du nicht als Vorraussetzung geben. Das Impressum würde ich in jedem Fall überarbeiten, um dem Abmahnwahn vorzubeugen.
Und nachdem ich beim Kontaktformular auf das Vorwahl-ändern-Auswahlmenü geklickt habe, mußte ich feststellen, daß die Umlaute dort in meinem Browser nicht korrekt angezeigt werden. Als ich in den Code guckte, um zu schauen, welche Zeichenkodierung in den Metatags angegeben wurde, mußte ich feststellen, daß es keine solche Angabe gibt.
Ich wollte mir die Response-Header des Servers jetzt nicht ansehen... Denke, du hast dein Dokument aus dem Editor mit falscher Kodierung gespeichert.
Außerdem hast du XHTML gewählt und schließt deine Metatags nicht mit /> korrekt ab.
Dann sind dort noch weitere Fehler. <li> muß innerhalb von <ul> oder <ol> stehen. Das gibt es bei dir nicht.
Images haben nicht die vorgeschriebenen alt-Attribute.
Mein Browser meldet mir auf deiner Kontaktseite 22 Fehler im Code.

Und dann schreibst du in den HTML-Kommentaren:
Zitat:
XHTML/CSS-Programmierung:

Bei (X)HTML und CSS handelt es sich nicht um Programmiersprachen. Daher kann man auch nicht von Programmierung sprechen.


Zuletzt bearbeitet von rob am Mi 09.04.2008 09:12, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
bsights
Threadersteller

Dabei seit: 21.09.2005
Ort: Hamburg
Alter: -
Geschlecht: Männlich
Verfasst Do 10.04.2008 10:16
Titel

Antworten mit Zitat Zum Seitenanfang

Vielen Dank für die Hinweise, Rob.

Zurück zum Problem: woran könnte es noch liegen? Die Bildadressen sind korrekt, die Pfade der Scripte sind in Ordnung, das Script selbst enthält doch eigentlich keine Links o.ä.. was bleibt da noch? Orignaladdresse ist http://www.bsights.de/marokko/index.html. Konkurrierende Scripte gibt es auf dieser seite nicht. Sonst arbeite ich auf meiner seite noch mit Lightbox und Thickbox, die alle funktionieren. Ich möchte aber langfristig z.T. auf greybox umstellen, da die Galleriefunktion sehr komfortabel scheint.

Nachwievor über Tipps dankbar: Alexander
Viele Grüße!


Zuletzt bearbeitet von bsights am Do 10.04.2008 10:18, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
bsights
Threadersteller

Dabei seit: 21.09.2005
Ort: Hamburg
Alter: -
Geschlecht: Männlich
Verfasst Do 10.04.2008 10:17
Titel

Antworten mit Zitat Zum Seitenanfang

Ein Script läuft doch im Hintergrund: phpmyvisites. Könnte es daran liegen?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen greybox alternative für .flv video
Greybox / Lightbox - Autostart?
GreyBox ohne Close-Button
[Flash] - Greybox aus Flash starten
W3C Fehler
PHP Fehler
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Programmierung


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.