mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 04.12.2016 15:21 Benutzername: Passwort: Auto-Login

Thema: [XAMPP] [mod_rewrite] [CMS] vom 06.04.2006

Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Software - Nonprint -> [XAMPP] [mod_rewrite] [CMS]
Autor Nachricht
Was will iRoybot eigentlich?
Na is doch klar: er will Lightpress aufm localhost zum laufen bringen
100%
 100%  [ 1 ]
Er will auf Coruscant JediKnight zocken und noobs mitm Jedi-Mind-Trick veräppeln...
0%
 0%  [ 0 ]
Stimmen insgesamt : 1

iRoybot
Threadersteller

Dabei seit: 13.03.2006
Ort: LA, Orange County
Alter: 37
Geschlecht: Männlich
Verfasst Do 06.04.2006 18:23
Titel

[XAMPP] [mod_rewrite] [CMS]

Antworten mit Zitat Zum Seitenanfang

Hallo beisammen.

Vorweg: Ich benutze den Xampp Server (neueste Installer-Version) auf einer Windows-Dose.
Ich möchte mich gern in Lightpress (Frontend für Wordpress) etwas einarbeiten bzw. es verwenden.
Leider ist das dortige Supportforum recht menschenleer - und außerdem liegt mir Deutsch besser.

Deshalb hier nun meine Problembeschreibung:
In meinem htdocs-Ordner liegt der Unterordner "wordpress" in welchem eben jenes installiert ist. ohne plugins, ohne hokus-pokus. soweit so gut.
Wenn ich nun das Lightpress-Plugin aktiviere, dann die Optionen einstelle, die config.php (im Test-Modus zusätzlich auch die .htaccess) wie angegeben speichere, passiert beim aufrufen der URL im brauser folgendes:

1) im Test-mode wird der Verzeichnis-Index des "lightpress"-Ordners angezeigt (/wordpress/lightpress/). Hier sollte eigentlich die .htaccess greifen, die in diesem Verzeichnis liegt und "alles regeln". man bekommt also das frontend nicht zu sehen. *Schnief*
2) im Root-mode fast das selbe: Lightpress überschreibt die htaccess von wordpress (also die permalink-struktur sofern man diese verwendet) mit seinen eigenen Rewrite-Regeln, aber das Lightpress-Frontend kriegt man nicht zu gesicht. Stattdessen: Kubrick (also das Wordpress Frontend). Alle Links weisen zwar die in den Lightpress-optionen angegebene Struktur auf, funktionieren aber im WP-Frontend natürlich nicht. *Schnief*

Das nervige daran: am Webserver klappt es einwandfrei. xampp ist in voreinstellung, also an keiner stelle angepasst oder verändert.
Ne Idee warum die htaccess-Regeln nicht greifen? Kann das an den Windows-Backslashes liegen (C:\xampp\htdocs/wordpress etc.) ? und wie könnte ich das fixen.
Es läßt sich nämlich über den "mit-FTP-auf-Webserver" Umweg nur sehr umständlich damit arbeiten...

1000dank schonmal

Links:
http://www.wordpress.org/ (wp)
http://www.lightpress.org/ (lp)
http://www.apachefriends.org/ (xampp)

[edit]
Verschoben von Allgemeines - Nonprint nach Software - Nonprint


Zuletzt bearbeitet von tacker am Do 06.04.2006 23:05, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Ähnliche Themen Mod Rewrite im Unterordner
mod rewrite | Ich checks nicht
Mod Rewrite und SEO
URL / Mod Rewrite
mod rewrite in .htaccess funktioniert nicht
[mod rewrite] url suchmaschinenfreundlich umschreiben
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Software - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.