mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 04.12.2016 11:21 Benutzername: Passwort: Auto-Login

Thema: Probleme mit HTML Code in der Debian Shell vom 06.06.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Software - Nonprint -> Probleme mit HTML Code in der Debian Shell
Autor Nachricht
momai
Threadersteller

Dabei seit: 08.09.2003
Ort: Augsburg
Alter: 31
Geschlecht: Männlich
Verfasst Mo 06.06.2005 12:20
Titel

Probleme mit HTML Code in der Debian Shell

Antworten mit Zitat Zum Seitenanfang

Hallo Gemeinde,

ich hab schon wieder ein Problem *zwinker* , und zwar hat es diesem mit der Shell von Debian zu tun und zwar wenn ich von DreamweaverMXa meinen Code per SFTP auf den Server verschieb, kommt in der Shell-Datei (vorausgesetzt ich öffne se mit Nano) immer dieses Symbol ^M.

Ich hab mal zwei GIFs geschrieben mit dem Sachverhalt drauf...




hier ist der Code scheinbar in Ordung ohne dieses seltsame Zeichen...





hier hingegen ist die Datei in der Shell nicht mehr in Ordnung bzw das seltsame Zeichen * Ich geb auf... * (Ich habs mal mit einem roten Kreis ummalt) kommt relativ oft vor

des halb ist meine Frage von was kommt dieses Symbol und wie kann ich es unterdrücken oder gar verschwinden lassen?


.momai
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Lazy-GoD
Moderator

Dabei seit: 26.11.2001
Ort: -
Alter: 46
Geschlecht: Männlich
Verfasst Mo 06.06.2005 12:24
Titel

Antworten mit Zitat Zum Seitenanfang

Taucht das im vi auch auf?
  View user's profile Private Nachricht senden
Anzeige
Anzeige
momai
Threadersteller

Dabei seit: 08.09.2003
Ort: Augsburg
Alter: 31
Geschlecht: Männlich
Verfasst Mo 06.06.2005 12:27
Titel

Antworten mit Zitat Zum Seitenanfang

jo, genau das selbe...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
sahnemuh

Dabei seit: 19.06.2003
Ort: /dev/null
Alter: 35
Geschlecht: Männlich
Verfasst Mo 06.06.2005 13:00
Titel

Antworten mit Zitat Zum Seitenanfang

Das sind Windows Zeilenumbrüche.

Speicher deine HTML Dokumente mal im Unix format ab, dann sollte sich das Problem von alleine lösen.


http://www.vs.inf.ethz.ch/edu/SS2004/I2/dosunix.html
  View user's profile Private Nachricht senden
shakadi
Griller Killer

Dabei seit: 21.12.2003
Ort: SHA
Alter: 36
Geschlecht: Männlich
Verfasst Mo 06.06.2005 13:06
Titel

Antworten mit Zitat Zum Seitenanfang

Dreamweaver:

Bearbeiten -> Voreinstellungen -> Reiter: Codeformat -> Zeilenumbruchformat LF (Unix)
  View user's profile Private Nachricht senden
gtz

Dabei seit: 15.04.2002
Ort: -
Alter: 41
Geschlecht: Männlich
Verfasst Mo 06.06.2005 13:16
Titel

Antworten mit Zitat Zum Seitenanfang

das ^m is schlciht und ergreifend der verzweifelte versuch deines terminals, mit dem gerümpel-cr/lf von dos irgendwas anzufangen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
momai
Threadersteller

Dabei seit: 08.09.2003
Ort: Augsburg
Alter: 31
Geschlecht: Männlich
Verfasst Mo 06.06.2005 15:02
Titel

Antworten mit Zitat Zum Seitenanfang

danke, ihr seit der Hit
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
kaputt

Dabei seit: 08.05.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mo 06.06.2005 15:44
Titel

Antworten mit Zitat Zum Seitenanfang

momai hat geschrieben:
danke, ihr seit der Hit

www.seitseid.de
www.seidseit.de
*SCNR*
  View user's profile Private Nachricht senden
 
Ähnliche Themen HTML code in MySQL Daten bank einfügen macht Probleme
HTML-Code
Anführungszeichen im HTML-Code
Fehler im HTML-Code, wo?
Eingeschlichener HTML-Code
HTML Code für die Navigation
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Software - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.