mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 07.12.2016 15:39 Benutzername: Passwort: Auto-Login

Thema: validierendes xhtml 1.0 strict vom 28.04.2004


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> validierendes xhtml 1.0 strict
Seite: Zurück  1, 2, 3  Weiter
Autor Nachricht
Achim M.

Dabei seit: 17.03.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Fr 30.04.2004 18:55
Titel

Antworten mit Zitat Zum Seitenanfang

So schaut's in Safari aus:



Wäre es nicht besser, Du würdest erst mal einen sauberen HTML 4.01-Code schreiben, der in allen Browsern läuft, bevor Du mit XHTML strict beginnst?

Gruß

Achim
  View user's profile Private Nachricht senden
Waschbequen
Account gelöscht


Ort: -

Verfasst Fr 30.04.2004 19:07
Titel

Antworten mit Zitat Zum Seitenanfang

IE:




Fox:


 
Anzeige
Anzeige
karmacoder

Dabei seit: 15.04.2002
Ort: Fürth
Alter: 35
Geschlecht: Männlich
Verfasst Fr 30.04.2004 19:48
Titel

Antworten mit Zitat Zum Seitenanfang

sorry hab nicht gesehen das der zweite links anders ist als der erste. das ist tatsächlich total im sack *zwinker*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
beeviZ
Threadersteller

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Sa 01.05.2004 03:00
Titel

Antworten mit Zitat Zum Seitenanfang

Achim M. hat geschrieben:
So schaut's in Safari aus:
http://www.musall.net/mg/screenshotxhtml.gif

Wäre es nicht besser, Du würdest erst mal einen sauberen HTML 4.01-Code schreiben, der in allen Browsern läuft, bevor Du mit XHTML strict beginnst?

Gruß

Achim


*g* is ja witzig. alles zerschossen hier.
nee. das lustige is ja, html 4.0 beherrsche ich eigentlich aus dem FF, und html seiten sehen bei mir in der regel auch alle auf allen browsern gleich aus... (hab 1998 mit nem quellcode editor angefangen, und nie wirklich wysiwyg editoren benutzt..) sollte also eigentlich fluppen...
ist mir nur unverständlich warum das soooo anders aussieht in den browsern. ich mein, der IE, (auf den ichs optimiert habe Ooops ) zeigts ja auch korrekt an alles.
irgendwie scheint jeder browser die verschachtelten divs, und paddings und margins verschieden zu interpretieren *hu hu huu*

habs nochmal neu hochgeladen............
funktionieren tuts immernoch. allerdings nur im ie..
was mozilla schon wieder macht is für meine begriffe irgendwie unerklärlich...

//edit:
so falsch kann das doch garnicht sein. sonst würd doch weder das xhtml noch das css validieren, oder?????
man ich bin so ratlos *g* *hu hu huu*


Zuletzt bearbeitet von beeviZ am Sa 01.05.2004 03:10, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Achim M.

Dabei seit: 17.03.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Sa 01.05.2004 08:24
Titel

Antworten mit Zitat Zum Seitenanfang

beeviZ hat geschrieben:
so falsch kann das doch garnicht sein. sonst würd doch weder das xhtml noch das css validieren, oder?????
man ich bin so ratlos *g* *hu hu huu*


Der Validator prüft ja nur, ob die Syntax stimmt. Woher soll er wissen, was durch darstellen möchtest?

Dein Problem ist meines Erachtens folgendes: #center hat keine Höhenangabe und soll seine Höhe von den untergeordneten Ebenen #subnavi bzw. #content erben. Diese Vererbung scheitert an float: left. Denn damit weist Du den Browser an, dass die Elemente nicht mehr als untergeordnet zu betrachten sind, sondern sich gegenseitig umfliessen. Damit verliert #center die Bindung an #subnavi bzw. #content. Wenn Du float:left entfernst, funktioniert die Höhenangabe, aber die Position von #subnavi zu #content stimmt nicht mehr.

Die einzige Lösung, die mir im Augenblick einfällt, feste Höhenangabe für #center. Eine elegantere Lösung gibt es bestimmt, fällt mir im Augenblick aber nicht ein.

Gruß

Achim
  View user's profile Private Nachricht senden
beeviZ
Threadersteller

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Sa 01.05.2004 10:43
Titel

Antworten mit Zitat Zum Seitenanfang

Achim M. hat geschrieben:
beeviZ hat geschrieben:
so falsch kann das doch garnicht sein. sonst würd doch weder das xhtml noch das css validieren, oder?????
man ich bin so ratlos *g* *hu hu huu*


Der Validator prüft ja nur, ob die Syntax stimmt. Woher soll er wissen, was durch darstellen möchtest?

Dein Problem ist meines Erachtens folgendes: #center hat keine Höhenangabe und soll seine Höhe von den untergeordneten Ebenen #subnavi bzw. #content erben. Diese Vererbung scheitert an float: left. Denn damit weist Du den Browser an, dass die Elemente nicht mehr als untergeordnet zu betrachten sind, sondern sich gegenseitig umfliessen. Damit verliert #center die Bindung an #subnavi bzw. #content. Wenn Du float:left entfernst, funktioniert die Höhenangabe, aber die Position von #subnavi zu #content stimmt nicht mehr.

Die einzige Lösung, die mir im Augenblick einfällt, feste Höhenangabe für #center. Eine elegantere Lösung gibt es bestimmt, fällt mir im Augenblick aber nicht ein.

Gruß

Achim


achim, du bist genial Lächel

so ähnlich dachte ich mir das schon..
naja, ich werd mal schauen was sich da so machen lässt. danke auf jeden fall.

schade das nicht allen browsern die standards so egal sind wie dem IE *g*
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
beeviZ
Threadersteller

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Mo 03.05.2004 17:20
Titel

Antworten mit Zitat Zum Seitenanfang

HA!

www.manuelbieh.de/dev

ich habs *hehe*

doof is nur, mozilla zeigt jetzt den rahmen nich korrekt an.
aber das is n manko mit dem ich erstmal leben kann so halbwegs. Lächel
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
beeviZ
Threadersteller

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Di 11.05.2004 23:19
Titel

Antworten mit Zitat Zum Seitenanfang

kann irgendwer mit nem exotischen browser nochmal nen blick werfen auf
www.manuelbieh.de/dev/fotos.htm ?

gerade mac user sind willkommen Grins



und dann kann mir evtl mal einer noch erklären was das soll?
ich krieg das css nich mehr validiert.
ich hab, warum auch immer, letztens irgendwann "clear: both" eingebaut. den ausdruck gibts garnich in css.
aber nehm ich das raus, zeigt mir der mozilla die rechte spalte, also die content spalte nich mehr an.
wenn ich stattdessen float: clear mach gehts nich, und wenn ichs ganz weg mach halt auch nich?!
häää?

*ha ha*
naja, immerhin hab ichs so langsam raus mit dem scheiß Lächel

//edit:
laut css4you gibts clear: both doch.
allerdings erklärt der css validator ihn für ungültig *Schnief*

//edit2:
alles klar. geht doch alles... ich doofmann Grins

wär aber trotzdem nett wenn irgendwer mit nem exotischen browser mal drübergucken könnte.
je exotischer desto besser *hehe*
so solltes es aussehen wenn es korrekt angezeigt wird <=
(im mozilla schießt die linke subnavi n stück übern rand raus)


Zuletzt bearbeitet von beeviZ am Di 11.05.2004 23:37, insgesamt 3-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [solved] xhtml 1.0 strict - javascript
[suche] eigenschaften xhtml strict übersicht
Guestbook gesucht (XHTML 1.0 Transitional oder Strict)
[js] jQuery Strict Warnings
target="_blank" erreichen, trotzdem "strict" validieren?
XHTML
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2, 3  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.