mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 14:46 Benutzername: Passwort: Auto-Login

Thema: Problem mit hover effect vom 10.04.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Problem mit hover effect
Seite: 1, 2, 3  Weiter
Autor Nachricht
T0M4T3
Threadersteller

Dabei seit: 27.03.2006
Ort: -
Alter: -
Geschlecht: -
Verfasst Mo 10.04.2006 15:23
Titel

Problem mit hover effect

Antworten mit Zitat Zum Seitenanfang

Moin!
Ich hab das Problem, das der hover Effekt nicht mehr funktioniert, wenn die Links einmal besucht wurden.
Habe ich mit den Farben was falsch gemacht?

Code:

a, a:link, a:active {
   color: #808080;
   background-color: white;
   font-weight: bold;
   text-decoration: none;
}

.block a:link, a:active {
      color: #808080;
      background-color: #f5f5f5;
      font-weight: bold;
      text-decoration: none;
}

.block a:hover  {
   color: #ccc;
   background-color: #f5f5f5;
}

.block a:visited   {
   color: #808080;
   background-color: #f5f5f5;
}


Gruß
Lars
  View user's profile Private Nachricht senden
ZeroFlash

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Mo 10.04.2006 15:43
Titel

Antworten mit Zitat Zum Seitenanfang

gib mal den restlichen quelltext deiner html datei und zu wissen was im einzelnen passieren soll wäre auch nicht schlecht

so was mir auffällt:

#f5f5f5 = keine webfarbe... kannste auch gleich #ffffff nehme
#808080 = keine webfarbe ... #999999
#ccc = unvollständige farbangabe ... was für ne farbe sollte es denn mal werden...

dann versteh ich nicht wieso du noch den block brauchst. die hintergrundfabre macht so auch keinen sinn.

naja sag erstmal was passieren soll und wie es ausschauen soll... bildchen zur veranschaulichung wäre auch nich schlecht


Zuletzt bearbeitet von ZeroFlash am Mo 10.04.2006 16:00, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden
Anzeige
Anzeige
T0M4T3
Threadersteller

Dabei seit: 27.03.2006
Ort: -
Alter: -
Geschlecht: -
Verfasst Mo 10.04.2006 15:54
Titel

Antworten mit Zitat Zum Seitenanfang

ok
also im wesentlichen:

im menü soll sich die schriftfarbe ändern und der hintergund grau bleiben.
bei normalen links soll sich die schriftfarbe ändern und der hintergund weiß bleiben.
bevor ich mit hintergrundfarben wegen css 2.0 gearbeitet hab, hat das auch funktioniert


Code:

<div class="block">
   <h2 class="title">
      <bean:message key="label.menu.about" />
   </h2>
   <div class="content">
      <div class="menu">
         <ul>
            <li>
               <html:link forward="contact">
                  <bean:message key="label.menu.contact" />
               </html:link>
            </li>
            <li>
               <html:link forward="tc">
                  <bean:message key="label.menu.tc" />
               </html:link>
            </li>
            <li>
               <html:link action="stats">
                  <bean:message key="label.menu.statistic" />
               </html:link>
            </li>
            <li>
               <html:link forward="notice">
                  <bean:message key="label.menu.notice" />
               </html:link>
            </li>
         </ul>
      </div>
   </div>
</div>


Zuletzt bearbeitet von T0M4T3 am Mo 10.04.2006 16:01, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden
eikman

Dabei seit: 27.02.2004
Ort: Essen
Alter: 36
Geschlecht: Männlich
Verfasst Mo 10.04.2006 16:09
Titel

Antworten mit Zitat Zum Seitenanfang

ZeroFlash hat geschrieben:

#ccc = unvollständige farbangabe ... was für ne farbe sollte es denn mal werden...


Das ist ok, wenn zwei ziffern identisch sind kann man sie zu einer zusammenfassen.
Wie hier z.B. #CCCCCC. Rot wäre dann #f00 usw.


Zuletzt bearbeitet von eikman am Mo 10.04.2006 16:12, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
m
Moderator

Dabei seit: 18.11.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mo 10.04.2006 16:09
Titel

Antworten mit Zitat Zum Seitenanfang

ZeroFlash hat geschrieben:

#ccc = unvollständige farbangabe ... was für ne farbe sollte es denn mal werden...


Das ist schon in Ordnung so, ist die Abkürzung für #CCCCCC

Edit: eine Sekunde zu spät.


Außerdem solltest du diese Reihenfolge einhalten:

a:link, a:visited, a:hover, a:active


Zuletzt bearbeitet von m am Mo 10.04.2006 16:12, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
ZeroFlash

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Mo 10.04.2006 16:19
Titel

Antworten mit Zitat Zum Seitenanfang

ok is es halt die abkürzung wieder was gelernt

Code:

<html>
<style>
a:link, a:visited, a:hover, a:active {
    font-family:verdana, helvetica, arial;
    font-size:10px;
    text-decoration:none;
    color:#666666;
    }
a:hover {
    color:#333333;
    font-weight:bold;
    }
.block {
    width:100px;
    height:auto;
    padding:10px;
    background:#f4f4f4;
    border:1px solid #000000;
    }
</style>
<body>
    <div class="block">
        <a href="test.html">link 1</a><br/>
        <a href="test.html">link 2</a><br/>
        <a href="test.html">link 3</a><br/>
        <a href="test.html">link 4</a><br/>
    </div>
</body>
</html>


wie wärs damit? is jetzt mit deinem f4f4f4 is dann zwar keine websichere farbe mehr aber n bissi mehr kontrast und nich ganz weiß


Zuletzt bearbeitet von ZeroFlash am Mo 10.04.2006 16:30, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
T0M4T3
Threadersteller

Dabei seit: 27.03.2006
Ort: -
Alter: -
Geschlecht: -
Verfasst Mo 10.04.2006 16:31
Titel

Antworten mit Zitat Zum Seitenanfang

danke, werde ich gleich mal testen

update:

hover effect funktioert damit, muss nur mal gucken ob ich auch wieder alles so hinkriege wie ich es
haben will.


edit:
a:hover {
color:#333333;
font-weight:bold;
}

muss ich bei css 2.0 nicht immer ne vorder und hintergrund farbe angeben?
Das ist ja der Grund, warum ich überhaupt das Problem habe,
Kann mir da noch jemand helfen?


Zuletzt bearbeitet von T0M4T3 am Mo 10.04.2006 16:50, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden
ZeroFlash

Dabei seit: 11.02.2005
Ort: -
Alter: 33
Geschlecht: Männlich
Verfasst Mo 10.04.2006 16:38
Titel

Antworten mit Zitat Zum Seitenanfang

bitte Lächel

ja mach das mal
  View user's profile Private Nachricht senden
 
Ähnliche Themen Hover-Effect bei E-Mail-Banner
After Effect - Problem einen Quicktime.mov auszuspielen!
Problem mit li:hover
HTML a:hover Problem
Problem mit CSS Hover Effekt
Problem mit IE7 und hover-Navigation
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2, 3  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.