mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 05.12.2016 12:01 Benutzername: Passwort: Auto-Login

Thema: problem mit ersten css layout vom 20.10.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> problem mit ersten css layout
Seite: 1, 2  Weiter
Autor Nachricht
O2noob
Threadersteller

Dabei seit: 05.11.2005
Ort: frankfurt
Alter: 26
Geschlecht: Männlich
Verfasst Fr 20.10.2006 19:03
Titel

problem mit ersten css layout

Antworten mit Zitat Zum Seitenanfang

tach,

das ist mein erstes css layout und ich werd verrückt!
ich komm einfach nicht weiter.
kann mir vlt jemand von euch helfen?

So sollte es aussehen (photoshop code)

so sieht es aus

das komische ist auch,
wenn ich die seite vom pc aus lade sehe
ich die navi bilder.
wenn ich sie aber vom server aus angucke sehe ich sie nicht Jo!

wär dankbar für hilfe und vlt auch eine kleine erklärung an was es hängt.

ich hoffe das ist die richtiege katheorie, wenn nicht sorry!

mfg



[edit]
Wichtig: HTML und CSS sind keine Programmiersprachen!
Verschoben von Programmierung nach Allgemeines - Nonprint.


Zuletzt bearbeitet von shakadi am Fr 20.10.2006 19:46, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
snaft

Dabei seit: 21.07.2005
Ort: -
Alter: 45
Geschlecht: Männlich
Verfasst Fr 20.10.2006 19:45
Titel

Antworten mit Zitat Zum Seitenanfang

Hallo!

Ein Lösungsansatz wäre, du überprüfst nochmal die URLs zu deinen Bildern.
Man beachte Groß- und Kleinschreibung bei den Pfadangaben...

.../.../Bilder/...
.../.../bilder/...

Dann solltest du schonmal mehr sehen Lächel

Gruß,
KaY

P.S: Schick sieht´s bis jetzt aus...
  View user's profile Private Nachricht senden
Anzeige
Anzeige
O2noob
Threadersteller

Dabei seit: 05.11.2005
Ort: frankfurt
Alter: 26
Geschlecht: Männlich
Verfasst Fr 20.10.2006 19:51
Titel

Antworten mit Zitat Zum Seitenanfang

ah danke, ok ich dussel *Huch*

aber das ändert noch nix an meinem
eigendlichen problem
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
snaft

Dabei seit: 21.07.2005
Ort: -
Alter: 45
Geschlecht: Männlich
Verfasst Fr 20.10.2006 19:53
Titel

Antworten mit Zitat Zum Seitenanfang

O2noob hat geschrieben:
ah danke, ok ich dussel *Huch*

aber das ändert noch nix an meinem
eigendlichen problem


Ich dachte, dein Problem wäre dieses, dass du die Menübilder nicht sehen kannst. Falls dem so ist
siehst Du sie, wenn Du die Pfadangaben korrigierst.

Falls nicht, was ist dein Problem ?

KaY
  View user's profile Private Nachricht senden
O2noob
Threadersteller

Dabei seit: 05.11.2005
Ort: frankfurt
Alter: 26
Geschlecht: Männlich
Verfasst Fr 20.10.2006 19:55
Titel

Antworten mit Zitat Zum Seitenanfang

ja habs geändert jetzt seh ichs,

aber ne mein eigendliches problem ist das der content nicht angezeigt wird,
vergeich mal das wies sein soll und das wies is, dann siehstes.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
snaft

Dabei seit: 21.07.2005
Ort: -
Alter: 45
Geschlecht: Männlich
Verfasst Fr 20.10.2006 20:07
Titel

Antworten mit Zitat Zum Seitenanfang

Also ganz steig ich da noch nich durch...

wieso hast du die width Angaben im css einmal MIT und einmal OHNE px angegeben ?

Das würd ich als erstes mal korrigieren...

KaY
  View user's profile Private Nachricht senden
O2noob
Threadersteller

Dabei seit: 05.11.2005
Ort: frankfurt
Alter: 26
Geschlecht: Männlich
Verfasst Fr 20.10.2006 20:11
Titel

Antworten mit Zitat Zum Seitenanfang

snaft hat geschrieben:
Also ganz steig ich da noch nich durch...

wieso hast du die width Angaben im css einmal MIT und einmal OHNE px angegeben ?

Das würd ich als erstes mal korrigieren...

KaY


Lächel ok getan und es tut sich was
jetzt sehe ich den linken teile des contents
und die anderen werdeun unten angezeit Au weia!


Zuletzt bearbeitet von O2noob am Fr 20.10.2006 20:12, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
m
Moderator

Dabei seit: 18.11.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Fr 20.10.2006 20:16
Titel

Antworten mit Zitat Zum Seitenanfang

Die positionierungen per margin sind absoluter Schwachsinn. Wofür hast du die clear: both; in den Footern? Bisher hattest du noch kein Element mit einer float Eigenschaft?


Code:
        body
   {
      margin: 0;
      padding: 0;
      font: 85% arial, hevetica, sans-serif;
      text-align: center;
      color: #505367;
      background-color: black;
   }
   
   #container
   {
      margin: 1em auto;
      width: 782px;
      height: 600px;
      text-align: left;
      background-color: black;
      border: 0px
   }
   
   #header
   {
      height: 85px;
      width: 782px;
      background: url('Bilder/index_01.gif');
   }
   
   
   #contentbox
   {
      margin-right: 782px;
      margin-left: 0px;
      height: 353px;
      width: 782px;
                overflow: hidden;
   }

   #contentleft
   {
                float: left;
      height: 353px;
      width: 114px;
      background: url('Bilder/index_02.gif');
   }

   #contentmiddle
   {
                float: left;
      height: 353px;
      width: 540px;
      background: url('Bilder/index_03.gif');
   }

   #contentright
   {
                float: left;
      height: 353px;
      width: 128px;
      background: url('Bilder/index_04.gif');
   }

   
   #footer2   
   {
      height: 103px;
      width: 782px;
      background: url('Bilder/index_05.gif');
   }

   #menu
   {
      width: 782px;
      height: 40px;
   }

   #footer   
   {
      height: 19px;
      width: 782px;
      background: url('Bilder/index_10.gif');
   }




Nun sind die mittleren Teile mit float: left; versehen, die Pixelangaben ergänzt, die margins entfernt, usw..

Allerdings verstehe ich nicht wieso du überhaupt so viele divs da rein haust? Die Seite hat doch eine fixe Größe? Wieso gibst du nicht dem Container einfach die Hintergrund Grafik komplett, positionierst unten deine Navigation als ungeordnete Liste und fertig...


Zuletzt bearbeitet von m am Fr 20.10.2006 20:18, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen css layout problem
Problem bei CSS-Layout
Problem mit mehrspaltigem CSS-Layout
[css] 3 spalten layout problem
[CSS] Problem mit 3-Spalten Layout
problem mit 3 spalten css-layout
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.