mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 10.12.2016 13:57 Benutzername: Passwort: Auto-Login

Thema: Problem mit CSS und Formularen vom 20.12.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Problem mit CSS und Formularen
Seite: 1, 2  Weiter
Autor Nachricht
wehmeier
Threadersteller

Dabei seit: 24.02.2005
Ort: Bad Oeynhausen
Alter: 37
Geschlecht: Männlich
Verfasst Di 20.12.2005 09:57
Titel

Problem mit CSS und Formularen

Antworten mit Zitat Zum Seitenanfang

Ich erstelle gerade eine neue Version von meiner Webseite, die komplett in XHTML und CSS erstellt wird...

Im Hintergrund werkelt dann später natürlich PHP mit MySQL *g*

Allerdings haue ich mir seit knapp 6 Wochen das Layout um die Ohren... ich bekomme es einfach nicht hin, dass das Layout zumindest in den drei wichtigsten Browsern Firefox (+ alle Mozis), Opera und IE möglichst identisch aussieht... es soll nichtmal pixelgenau sein * Ich geb auf... *

Probleme auf der Seite http://test.wehmeier.info/:

Betriebssystem: Windows 2000 und XP

Vorneweg: die roten Rahmen sind mit absicht drin *ggg* und alles unter dem Formular "CSS-Design" ist auch unwichtig.
Die Labels könnten später per CSS
Code:
position: absolute -1000px -1000px
(genaue Bezeichnung müsste ich nun nachsehen) versteckt werden. Nicht zum Einsatz kommt
Code:
display : none


Ich wollte dem Formularfeld auch eine Hintergrundfarbe zuweissen, aber irgendwie wird das dann in jedem Browser anders angezeigt...

Der CSS-Code muss nach W3C gültig sein...

Allgemeine Fehler:
Die Formulare sollen alle ein einheitliches Layout haben und die Grössen sollten -wenn möglich- in em angegeben werden.

1. IE (ab 5.0)
- Im Header werden die Rahmen für die horizontale Navigation nicht angezeigt.
- Die externen Links sind mit einer Grafik markiert. Leider hält der IE den Abstand nicht ein.
- Im Footer wird eine Grafik gefloatet (float:left) aber daher nicht mehr angezeigt

Ich würde mich freuen, wenn jemand ein wenig Zeit opfert und mit bei dem Problemen helfen kann.

An alle anderen die Lust haben mit CSS herumzuspielen dürfen mir auch gerne ein anderes Layout schicken * Applaus, Applaus *
Wenn es mir gefällt (und keine Copyrightrechte verletzt werden), dann würde ich mich mit einer .de-Domain erkenntlich zeigen (bin jetzt Reseller *g*)
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Doppelplusgut

Dabei seit: 06.10.2005
Ort: Zimmer 101
Alter: 47
Geschlecht: Männlich
Verfasst Di 20.12.2005 10:18
Titel

Antworten mit Zitat Zum Seitenanfang

Mach die Seiten erst mal valide:

http://validator.w3.org/check?verbose=1&uri=http%3A//test.wehmeier.info/
http://jigsaw.w3.org/css-validator/validator?profile=css2&warning=2&uri=http%3A//test.wehmeier.info/

Viele Probleme lassen sich damit schon beseitigen, wenn's dann immer noch nicht klappt, sag mal Bescheid.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
wehmeier
Threadersteller

Dabei seit: 24.02.2005
Ort: Bad Oeynhausen
Alter: 37
Geschlecht: Männlich
Verfasst Di 20.12.2005 11:09
Titel

Antworten mit Zitat Zum Seitenanfang

Sorry, da bin ich selber baff... werde ich zu Hause gleich machen.

Habe die Seite durch den Validator gejagt und dann von iso-8859-15 auf UTF-8 umgestellt... und bei meinem Editor das automatische ersetzen der Umlaute ausgestellt. Dann kommt sowas dabei raus *grml*

Komisch ist nur das Ergebnis, wenn man auf "Encoding: iso-8859-15" umstellt. Dann gibt er nur einen Fehler aus und sagt Formulare dürfen kein Name-Attribut beinhalten und das ist mir neu gewesen...

Ansonsten ist die Seite valid <-- Schuld!

Werde aber heute Abend schnell Updaten
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
wehmeier
Threadersteller

Dabei seit: 24.02.2005
Ort: Bad Oeynhausen
Alter: 37
Geschlecht: Männlich
Verfasst Di 20.12.2005 19:50
Titel

Antworten mit Zitat Zum Seitenanfang

Update: fertig *gg*

name im Form-Tag in id geändert und nun ist es valide... ich weiss jetzt auch warum ich den name eingeben wollte, denn im Firefox kann man unter Seiteninformation und Formulare die dazupassenden Namen lesen und das fand ich so nackig nicht sehr schön Mädchen!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
matt

Dabei seit: 06.05.2003
Ort: Köln
Alter: 35
Geschlecht: Männlich
Verfasst Di 20.12.2005 20:17
Titel

Re: Problem mit CSS und Formularen

Antworten mit Zitat Zum Seitenanfang

wehmeier hat geschrieben:
Allgemeine Fehler:
Die Formulare sollen alle ein einheitliches Layout haben und die Grössen sollten -wenn möglich- in em angegeben werden.


Daran kann man leicht verzweifeln. Bei mir war es schließlich der Fall als ich ein input type="file" stylen wollte. Das macht der Firefox einfach mal gar nicht.

Ansonsten ist da so einiges fragwürdig. Mittlerweile sag ich mir, dass ich dass CSS für Formulare auf das nötigste reduziere, da die Elemente vom Browser und/oder Betriebssystem abhänggig sind und somit von vornherein sehr verschieden sind (Mac OSX, Skins, ...).

Aber gute Sache mit den Größenangaben in em ...

Matt
  View user's profile Private Nachricht senden
Doppelplusgut

Dabei seit: 06.10.2005
Ort: Zimmer 101
Alter: 47
Geschlecht: Männlich
Verfasst Di 20.12.2005 20:27
Titel

Antworten mit Zitat Zum Seitenanfang

Schon mal hier geguckt?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
wehmeier
Threadersteller

Dabei seit: 24.02.2005
Ort: Bad Oeynhausen
Alter: 37
Geschlecht: Männlich
Verfasst Mi 21.12.2005 00:17
Titel

Antworten mit Zitat Zum Seitenanfang

Ja, ich kenne viele CSS Seiten, aber die haben alle nicht das erwünschte gebracht.

Viele barrierefreie Webseiten verstecken einfach den Border oder setzen Grafiken ein. Da ich aber ein kleines CMS (wiWMS) erstellen möchte, kann ich nicht davon ausgehen, dass jeder Benutzer die auch einsetzen möchte.

Ich hatte eigentlich gehofft, dass hier ein guter CSS-Layouter an Bo(a)rd ist, der einmal drüberguckt und sagt: "Du Dumpfbacke... du musst doch nur..." Ich würde auch durch die Informationen, die ich mit PHP erhalte CSS-Dateien nachladen, wenn es überhaupt nicht anders geht.

Mir ist bezüglich der Navigation nur wichtig, dass diese genauso breit sind wie die Formulare und da ich überall die gleichen Breitenangaben mache, verstehe ich einfach nicht, warum das nicht auch von jedem Browser umgesetzt wird (kommt mir jetzt nicht mit dem Border-Hack wegen dem IE, denn alle Angaben [width, padding, margin, border] sind gleich!)

Und ich verstehe die Fehler des IE nicht: Wobei die Version 6.0 zumindest die horizontale Navi so anzeigt wie ich will... aber warum keine float-Bilder?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Doppelplusgut

Dabei seit: 06.10.2005
Ort: Zimmer 101
Alter: 47
Geschlecht: Männlich
Verfasst Mi 21.12.2005 13:41
Titel

Antworten mit Zitat Zum Seitenanfang

wehmeier hat geschrieben:
(kommt mir jetzt nicht mit dem Border-Hack wegen dem IE, denn alle Angaben [width, padding, margin, border] sind gleich!)


Das mag stimmen, aber der IE rechnet anders als richtige Browser: http://css4you.de/wsboxmodell/index.html#browser
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Umlaut-Problem bei Formularen
Problem mit Acrobat Formularen, Verlinkung z. Mail-Client
[CSS] Kleines CSS-Problem
variablenübergabe in formularen
Absende-Button bei Formularen
Frage zu PDF Formularen
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.