mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 03.12.2016 14:58 Benutzername: Passwort: Auto-Login

Thema: @import Problem vom 23.02.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> @import Problem
Seite: 1, 2, 3  Weiter
Autor Nachricht
Braininsider
Threadersteller

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Mi 23.02.2005 09:52
Titel

@import Problem

Antworten mit Zitat Zum Seitenanfang

Hi Forum

ich habe folgendes Problem mit dem css @import beim IE.
Im Mozilla, Safari, Netscape funtzt das "@import url ("sw/layout.css") screen;" aber im IE kommt nix.
Dann hab ich mal gegoogelt der spukte mir das

CCS4You hat geschrieben:
CSS4YOU
sagt das es ab IE 5.0 gehen sollte


perun.net hat geschrieben:
meinte das es da einen Bug giebt den FOUC (Flash of Unstyled Content) hier zum nachlesen.


Aber dies löst mein Problem nicht!!!
Der IE Zeigt mir einfach keine css an.

Hier der code
Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
     "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de">

<HEAD>

<TITLE>{PAGE_TITEL}</TITLE>

<META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=iso-8859-1">

<link rel="stylesheet" href="layout/styles/layout.css" type="text/css">


Inhalt der Layut.css
Code:

@import url ("sw/layout.css") screen;
@import url ("sw/layout_navi.css") screen;
@import url ("sw/layout_suche_standard.css") screen;
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
waiu

Dabei seit: 16.04.2002
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mi 23.02.2005 09:58
Titel

Antworten mit Zitat Zum Seitenanfang

ich dachte das
@import url schreibt man immer in den HTML Header rein (um z.B. 2 CSS Dateien für jeweils IE bzw. Netscape zu haben).
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Braininsider
Threadersteller

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Mi 23.02.2005 10:03
Titel

Antworten mit Zitat Zum Seitenanfang

Also ich ha es in die css geschrieben und es funtzt ja auch nur im IE nicht "kotz"
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
mcbethy

Dabei seit: 02.12.2002
Ort: Hamburg
Alter: 33
Geschlecht: Weiblich
Verfasst Mi 23.02.2005 10:07
Titel

Antworten mit Zitat Zum Seitenanfang

Ich benutze auch @import in meinem CSS und es geht im IE.
Vielleicht kommt der IE mit dem screen am Ende nicht klar? Lass das doch mal spaßeshalber weg.

//Edit:

Ich meine mal gelesen zu haben, dass du Stilen keine Namen mit diesem Zeichen "_" geben darfst.


Zuletzt bearbeitet von mcbethy am Mi 23.02.2005 10:09, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
beeviZ

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst Mi 23.02.2005 10:12
Titel

Antworten mit Zitat Zum Seitenanfang

manchmal liegt das an totalen banalitäten. probier mal das leerzeichen zwischen url und der klammer weg zu nehmen. importiert der denn garnix, oder nur nich alles?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Braininsider
Threadersteller

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Mi 23.02.2005 10:31
Titel

Antworten mit Zitat Zum Seitenanfang

Hm Menno!

hab beides mal ausprobiert

einmal so
Code:

@import url("/layout/styles/sw/layout.css") screen;
@import url("/layout/styles/sw/layout_navi.css") screen;
@import url("/layout/styles/sw/layout_suche_standard.css") screen;

Hier habe ich das leezeichen zwischen url und der klammer enfernt


und so
Code:

@import url("/layout/styles/sw/layout.css");
@import url("/layout/styles/sw/layout_navi.css");
@import url("/layout/styles/sw/layout_suche_standard.css");

Hier habe ich den Medientype enfernt


Aber nix hat was gebracht.


Zuletzt bearbeitet von Braininsider am Mi 23.02.2005 10:33, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
mcbethy

Dabei seit: 02.12.2002
Ort: Hamburg
Alter: 33
Geschlecht: Weiblich
Verfasst Mi 23.02.2005 10:35
Titel

Antworten mit Zitat Zum Seitenanfang

Und wenn du es mal damit probierst?


Keine Unterstriche
Code:

@import url("/layout/styles/sw/navi.css") screen;

oder kompletten Pfad
Code:

@import url("http://www.deineseite.de/layout/styles/sw/layout.css");

oder alle Dokumente in einem Ordner
Code:

@import url("layout.css") screen;
  View user's profile Private Nachricht senden
Braininsider
Threadersteller

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Mi 23.02.2005 10:42
Titel

Antworten mit Zitat Zum Seitenanfang

Ich kann mir nicht vortellen das es an den unterstrichen liegt.
Die komplette url kann ich nicht nehem da es in einem Template sytem eingebunden ist.
wenn ich die CSS-Dateien alle in einen Ordner packe mach das Import Prinzip keinen sinn mehr.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen Excel, Import-Problem
[mysql] problem beim import
Problem mit Import einer AI Datei in Flash
Neues Problem: Preloader-Import in Director
Problem mit 3D Molekül import aus z.G. JMol, Avogadro und Co
Problem beim Import von AI, SWF, EPS Dateien
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2, 3  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.