mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 08.12.2016 13:37 Benutzername: Passwort: Auto-Login

Thema: IE Problem mit CSS Navigation vom 07.10.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> IE Problem mit CSS Navigation
Autor Nachricht
aight
Threadersteller

Dabei seit: 26.09.2003
Ort: Berlin
Alter: 30
Geschlecht: Männlich
Verfasst Fr 07.10.2005 10:06
Titel

IE Problem mit CSS Navigation

Antworten mit Zitat Zum Seitenanfang

Hallo!

Bei einer mit CSS realisierten Navigation habe ich pro Navigationspunkt eine Grafik, d.h. der Hover Effekt ist direkt mit in der Grafik drin. Der Hover Effekt wird im CSS durch "background-position" erzeugt.
Das Problem ist nur das es im IE bei manchen Leuten beim hover flackert, bei manchen nicht.

Code so ungefähr:
Code:

#kontakt a {
   width:41px;
   height:15px;
   background:url("images/navigation/kontakt.gif") no-repeat 0px 0px;
   display:block;
}
#kontakt a:hover {
   background-position: 0px -12px;
}


Hier der Link

Das ist die Grafik:



Wie gesagt das Problem ist das flackern im IE


Zuletzt bearbeitet von aight am Fr 07.10.2005 11:10, insgesamt 2-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Braininsider

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Fr 07.10.2005 10:41
Titel

Re: IE Problem mit CSS Navigation

Antworten mit Zitat Zum Seitenanfang

Panell hat geschrieben:

Code so ungefähr:
Code:

.kontakt {
   width:41px;
   height:15px;
   background:url("images/navigation/kontakt.gif") no-repeat 0px 0px;
   display:block;
}
.kontakt {
   background-position: 0px -12px;
}



was heißt so ungefähr
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
aight
Threadersteller

Dabei seit: 26.09.2003
Ort: Berlin
Alter: 30
Geschlecht: Männlich
Verfasst Fr 07.10.2005 10:46
Titel

Antworten mit Zitat Zum Seitenanfang

Code:
.kontakt {
   background-position: 0px -12px;
}


das entspricht nicht der genauen angabe aus dem code! aber unwichtig. ist nur die angabe um wieviel pixel es verschoben wird und da gibt es keine probleme!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
mcbethy

Dabei seit: 02.12.2002
Ort: Hamburg
Alter: 33
Geschlecht: Weiblich
Verfasst Fr 07.10.2005 11:00
Titel

Antworten mit Zitat Zum Seitenanfang

Vielleicht wird die Grafik einfach nur mit Verspätung geladen? Bei mir funktioniert es im IE einwandfrei.
  View user's profile Private Nachricht senden
Braininsider

Dabei seit: 18.11.2003
Ort: Halle
Alter: 35
Geschlecht: Männlich
Verfasst Fr 07.10.2005 11:02
Titel

Antworten mit Zitat Zum Seitenanfang

Ok ich wollte nur den bezug von class zu html sehen.

Weil ich nirgend dein a und kein a:hover sehe.

Deswegen war die Frage mehr Ironisch und sollte heißen Bitte zeig mir alles um einen fehler nach voll ziehen zu können.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
aight
Threadersteller

Dabei seit: 26.09.2003
Ort: Berlin
Alter: 30
Geschlecht: Männlich
Verfasst Fr 07.10.2005 11:10
Titel

Antworten mit Zitat Zum Seitenanfang

oh deine frage war berechtigt, hab da was falsch eingetippt. natürlich gibt es ein a, sowie a:hover. pardon

mcbethy hat geschrieben:
Vielleicht wird die Grafik einfach nur mit Verspätung geladen? Bei mir funktioniert es im IE einwandfrei.


damit kann es nicht zusammenhängen da die grafik ja schon geladen ist und sich nur verschiebt


Zuletzt bearbeitet von aight am Fr 07.10.2005 11:22, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
taste of ink

Dabei seit: 14.06.2005
Ort: Hamburg
Alter: 32
Geschlecht: Männlich
Verfasst Fr 07.10.2005 11:41
Titel

Antworten mit Zitat Zum Seitenanfang

Also bei mir flackerts
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
aight
Threadersteller

Dabei seit: 26.09.2003
Ort: Berlin
Alter: 30
Geschlecht: Männlich
Verfasst Fr 07.10.2005 12:02
Titel

Antworten mit Zitat Zum Seitenanfang

was hast du für nen Computer? Leistungsstark, sagen wir über 2,5 GHz oder weniger?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [CSS] Problem mit Navigation
[css] Problem mit Navigation (solved)
mein Problem: CSS/JavaScript-DropDown-Navigation
CSS Problem: Waagerechte Navigation mit Hintergrund
[CSS] Probleme mit CSS-Navigation und Rolloverbildern
CSS Navigation
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.