mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 05.12.2016 03:58 Benutzername: Passwort: Auto-Login

Thema: Hintergrund Problem mit CSS vom 10.01.2007


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Hintergrund Problem mit CSS
Autor Nachricht
Luvshining
Threadersteller

Dabei seit: 04.08.2005
Ort: Bayern
Alter: 37
Geschlecht: Weiblich
Verfasst Mi 10.01.2007 15:05
Titel

Hintergrund Problem mit CSS

Antworten mit Zitat Zum Seitenanfang

Hallo,
ich habe folgendes Problem und hoffe jemand von euch kann mir hier auf die Sprünge helfen.

Innerhalb einer Tabelle möchte ich die erste Zeile mit einem Hintergrund belegen. Damit das erste Symbol dort anklickbar ist, habe ich die Zeile unterteilt. In der vorderen Spalte ist das Bild, dass auch verlinkt ist und in der daneben dann die Überschrift, die aber mit einem Hintergrund belegt sein sollte. Für gewöhnlich gar kein Problem. Aber diese Tabelle ziert sich ... Obwohl ich feste Breiten angegeben habe, ist zwischen der ersten und zweiten Zeile ein 10px breites "Loch". Kann sich das jemand erklären?

Hier der verantwortliche PHP-Code für die Ausgabe der Tabelle
Code:

print "<table width='470px' cellpadding='0' cellspacing='0'>";
print "<tr><td width='65px'><a href='".trim($url)."'><img src='cam.jpg' border='0'></a></td><td background='bg_mov.jpg'><a href='".trim($url)."'>".trim($title)."</a></td></tr>";   
print "<tr><td colspan='2' width='405px'><IMG SRC='$imageurl'></a>".trim($description)."";
print "<br><a href='".trim($url)."'>"."weiter</a></td></tr></table>";


Hier ein Ausschnitt der Ausgabe in Bildform:



Über eure Hilfe und Ideen würd ich mich echt freuen.

Grüße
Nadine[/code]
  View user's profile Private Nachricht senden
Kraat

Dabei seit: 05.10.2006
Ort: Köln
Alter: 35
Geschlecht: Männlich
Verfasst Mi 10.01.2007 15:10
Titel

Antworten mit Zitat Zum Seitenanfang

meistens sind das Padding bzw. Margin Probleme *zwinker* vllt. könntest du ja das zugehörige CSS mal posten *zwinker*
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Luvshining
Threadersteller

Dabei seit: 04.08.2005
Ort: Bayern
Alter: 37
Geschlecht: Weiblich
Verfasst Mi 10.01.2007 15:28
Titel

Antworten mit Zitat Zum Seitenanfang

Die Tabelle kommt ohne CSS aus. Das seltsame ist auch, dass die Seite im FF korrekt ist und nur der IE 6.0 die angezeigte Darstellung bringt... *Schnief*
  View user's profile Private Nachricht senden
Kraat

Dabei seit: 05.10.2006
Ort: Köln
Alter: 35
Geschlecht: Männlich
Verfasst Mi 10.01.2007 15:39
Titel

Antworten mit Zitat Zum Seitenanfang

hmm ja IE 6 *Schnief* ich denke mal das es wohl an dem Bild liegen wird.
ich würde dir empfehlen die ausrichtungen nach links und und oben des Bildes auf 0 zu stellen:

sprich <img src="deinBild.jpg" vspace=0 hspace=0 border=0 />
  View user's profile Private Nachricht senden
Raumwurm

Dabei seit: 21.12.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst Mi 10.01.2007 15:41
Titel

Antworten mit Zitat Zum Seitenanfang

Probiers doch mal so:
Code:
print "<table width='470' cellpadding='0' cellspacing='0'>";
print "<tr><td width='65'><a href='".trim($url)."'><img src='cam.jpg' border='0'></a></td><td background='bg_mov.jpg'  width='405'><a href='".trim($url)."'>".trim($title)."</a></td></tr>";   
print "<tr><td colspan='2' width='470'><IMG SRC='$imageurl'></a>".trim($description)."";
print "<br><a href='".trim($url)."'>"."weiter</a></td></tr></table>";
  View user's profile Private Nachricht senden
seal

Dabei seit: 31.07.2005
Ort: Pfalz
Alter: 33
Geschlecht: Männlich
Verfasst Mi 10.01.2007 17:49
Titel

Antworten mit Zitat Zum Seitenanfang

In die hoffentlich vorhandene CSS-Datei (auch wenn die Tabelle ohne auskommt) mal folgendes eintragen:

Code:
td { margin: 0; padding: 0; }


Mit etwas Glück behebt das schon den Fehler. Abstände kann man natürlich nach belieben ändern...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Luvshining
Threadersteller

Dabei seit: 04.08.2005
Ort: Bayern
Alter: 37
Geschlecht: Weiblich
Verfasst Mi 10.01.2007 17:55
Titel

Antworten mit Zitat Zum Seitenanfang

Hallo,

vielen lieben Dank für eure Hilfe und Ratschläge.

@Raumwurm: Dein Vorschlag hat mir schon geholfen!

Viele Grüße
Nadine
  View user's profile Private Nachricht senden
 
Ähnliche Themen [CSS/HTML] Problem mit Hintergrund und I-Frame
CSS Problem: Waagerechte Navigation mit Hintergrund
CSS Hintergrund Problem (etwas komplexer)
FF zeigt css hintergrund nicht an ..
CSS Hintergrund Positionierung
CSS Schrift und Hintergrund
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.