mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 05:24 Benutzername: Passwort: Auto-Login

Thema: Fehler?: XHTML 1.1 erzeugt Abstand nach Bild in Tabelle vom 06.11.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> Fehler?: XHTML 1.1 erzeugt Abstand nach Bild in Tabelle
Autor Nachricht
[fränK]
Moderator
Threadersteller

Dabei seit: 27.04.2002
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 06.11.2005 11:44
Titel

Fehler?: XHTML 1.1 erzeugt Abstand nach Bild in Tabelle

Antworten mit Zitat Zum Seitenanfang

Hallo,

schaut euch mal bitte folgendes Dokument an:
http://www.frank-spangenberg.de/testing/arnold/arnold.xxhtml

Nach dem Bild (blau mit Arnold) zeigen die meisten Browsern einen größeren
Abstand als oben, links, rechts (grün) an, der eigentlich nicht gewollt ist.

Das Dokument ist gemäß XHTML 1.1 aufgebaut und wird auch vom Server als
„application/xhtml+xml“ geliefert.

Getestet wurde mit Firefox (0.7, 1.5 RC1), Opera 8.5, Netscape 8.04, der größere
Abstand wird immer angezeigt. Amaya zeigt allerdings einen gleichmäßigen
grünen Rahmen, so wie gewünscht.

Hab ich irgendwo einen (Denk-)Fehler drin oder scheint es ein Browser-Fehler
zu sein? Au weia!

p.s. Über das „Bild in Tabelle“ bitte nicht streiten, ist mir beim Konvertieren einer
auf Tabellen basierten Seite nach XHTML aufgefallen...
  View user's profile Private Nachricht senden
mcbethy

Dabei seit: 02.12.2002
Ort: Hamburg
Alter: 33
Geschlecht: Weiblich
Verfasst So 06.11.2005 12:12
Titel

Antworten mit Zitat Zum Seitenanfang

Moin.

Mach aus dem Inlineelement ein Blocklevelelement:
Code:
td img {display: block;}

Dann müsste es eigentlich funktionieren.
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Raumwurm

Dabei seit: 21.12.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 06.11.2005 12:24
Titel

Antworten mit Zitat Zum Seitenanfang

*Huch*
Da ist wohl noch ein blank nach dem
Bild in der td mit drin. Und gib der table
vielleicht besser noch einen border: none;
padding: 0px; und margin: 0px; mit.
  View user's profile Private Nachricht senden
[fränK]
Moderator
Threadersteller

Dabei seit: 27.04.2002
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 06.11.2005 12:34
Titel

Antworten mit Zitat Zum Seitenanfang

mcbethy hat geschrieben:
Mach aus dem Inlineelement ein Blocklevelelement:
Code:
td img {display: block;}

Dann müsste es eigentlich funktionieren.

Hey, danke, es funktioniert, habe auch gleich ein paar Seiten dazu gefunden.
http://www.frank-spangenberg.de/testing/arnold/arnold_block.xxhtml

Ursache ist, dass das Bild auf die Schriftlinie gesetzt wird, daher der Abstand
nach unten (= Unterlänge). * Wo bin ich? *
http://www.dodabo.de/html+css/img-table/

Raumwurm hat geschrieben:
Da ist wohl noch ein blank nach dem
Bild in der td mit drin.

Neee.
  View user's profile Private Nachricht senden
beeviZ

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst So 06.11.2005 12:39
Titel

Antworten mit Zitat Zum Seitenanfang

eine kurze frage so in den raum gestellt: warum xhtml 1.1, und nicht 1.0 ?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
[fränK]
Moderator
Threadersteller

Dabei seit: 27.04.2002
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 06.11.2005 12:49
Titel

Antworten mit Zitat Zum Seitenanfang

Nur zum Spaß/Testen. *zwinker*
  View user's profile Private Nachricht senden
beeviZ

Dabei seit: 30.09.2002
Ort: Dortmund
Alter: 23
Geschlecht: Männlich
Verfasst So 06.11.2005 13:48
Titel

Antworten mit Zitat Zum Seitenanfang

ok *zwinker*
frag nur, weil eigentlich wird ja davon abgeraten das schon zu benutzen und so, …
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [XHTML] Tabelle 100%
xhtml u. noch 1. tabelle
[JavaScript] Erzeugt Fehler im Firefox
Umlautdomain und Flash erzeugt Fehler
PDFs erzeugt mit Distiller haben Fehler
Tabelle - kein Abstand zwischen Zeilen bei Opera
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.