mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 01:37 Benutzername: Passwort: Auto-Login

Thema: css-problemchen mit InternetExplorer und Firefox vom 28.10.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> css-problemchen mit InternetExplorer und Firefox
Seite: 1, 2  Weiter
Autor Nachricht
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 33
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:16
Titel

css-problemchen mit InternetExplorer und Firefox

Antworten mit Zitat Zum Seitenanfang

Hallo Leute,
habe ein problem und weiß nicht mehr weiter.

Möchte ein Layout via css realisieren, nur machen mir die 2 Browser einen Strich durch die Rechnung.

Habe folgende CSS Angaben

Code:

#container {
   position: absolute;
   top: 50%;
   left: 50%;
   width: 795px;
   height: 474px;
   margin: -240px 0 0 -400px;
   background-color: #DADAD7;
}

#third_nav {
   margin-left: 479px;
   width: 316px;
   height: 22px;
   /*background-color:#FF780B;*/
   background-image: url(img/third_nav_hint.gif);
   z-index: 1;
}

#sec_nav_container {
   margin-top: 0px;
   height:369;
   width:110px;
   background-image: url(img/sec_nav_hint.gif);
   border-left: 1px;
   border-left-style: solid;
   border-left-color: #7d7d7d;
   border-top: 1px;
   border-top-style: solid;
   border-top-color: #7d7d7d;
   border-bottom: 1px;
   border-bottom-style: solid;
   border-bottom-color: #7d7d7d;*/
   z-index:2;
}

#content {
   margin-top:-369px;
   margin-left:110px;
   width: 489px;
   height: 369px;
   border-top: 1px;
   border-top-color:#7d7d7d;
   border-top-style:solid;
   border-bottom: 1px;
   border-bottom-color:#7d7d7d;
   border-bottom-style:solid;
   /*border-left: 1px;
   border-left-style: solid;
   border-left-color: #7d7d7d;*/
   z-index: 3;
   background-color:#FFFFFF;
}


im HTML binde ich sie wie folgt ein:
Code:

<link rel="stylesheet" href="stylesheet2.css">
<body>

<div id="container">
   <div id="third_nav"></div>
   <div id="sec_nav_container"></div>
   <div id="content"></div>

</div>
</body>


die ausgabe ist zum verrückt werden.
denn sie stimmt in den beiden Browsern einfach nicht überein.
Brauche dringend Hilfe, denn meine Kenntnisse sind nicht so ausgereift.

Dank euch.
  View user's profile Private Nachricht senden
Zeithase

Dabei seit: 09.05.2005
Ort: Erfurt
Alter: 32
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:21
Titel

Antworten mit Zitat Zum Seitenanfang

...Sehr unübersichtlich. Erstmal grobe Fehler:

Code:
border-bottom-color: #7d7d7d;*/


Bei "#sec_nav_container". Der Comment wird geschlossen, aber nie zuvor geöffnet.

Code:
 height:369;


Ebenfalls "#sec_nav_container". Da fehlt ein "px".

HTH,
der Zeithase.


Zuletzt bearbeitet von Zeithase am Fr 28.10.2005 08:22, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 33
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:26
Titel

Antworten mit Zitat Zum Seitenanfang

danke, diese Fehler habe ich korrigiert.
Nur besteht das Problem weiterhin.
mir kommt es sovor als ob Firefox immer einen Pixel mehr berechnet als der IExplorer.

woran kannn das liegen?
und mit welchen kniffen bekomme ich es hin damit es 1:1 gleich ist?
  View user's profile Private Nachricht senden
sahnemuh

Dabei seit: 19.06.2003
Ort: /dev/null
Alter: 35
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:27
Titel

Antworten mit Zitat Zum Seitenanfang

zusätzlich zu dem, was mein vorredner schon sagte:

Code:
   border-left: 1px;
   border-left-style: solid;
   border-left-color: #7d7d7d;
   border-top: 1px;
   border-top-style: solid;
   border-top-color: #7d7d7d;
   border-bottom: 1px;
   border-bottom-style: solid;
   border-bottom-color: #7d7d7d;


ist doch totaler overkill..
Code:

border-left: 1px solid #7d7d7d;
border-top: 1px solid #7d7d7d;
border-bottom: 1px solid #7d7d7d;


tut das gleiche und is wesentlich weniger code und übersichtlicher.
  View user's profile Private Nachricht senden
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 33
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:35
Titel

Antworten mit Zitat Zum Seitenanfang

gut damit hast du sicherlich recht, doch ich nehme nicht an das das mein Problem lösen wird.
Probieren werde ich es jetzt dennoch.

hattet ihr auch schon solche Positionierungsschwierigkeiten mit untersch. Browsern??


Zuletzt bearbeitet von Kash am Fr 28.10.2005 08:35, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Nimroy
Community Manager

Dabei seit: 26.05.2004
Ort: zwischen Köln und D'dorf
Alter: 38
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:36
Titel

Antworten mit Zitat Zum Seitenanfang

Das liegt am unterschiedlichen Box-System der Browser.

Füg deinem CSS mal das hinzu:
Code:
html, body   {
   height: 100%;
   margin: 0;
   padding: 0;
}


Zuletzt bearbeitet von Nimroy am Fr 28.10.2005 08:39, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Kash
Threadersteller

Dabei seit: 07.11.2002
Ort: Schopfheim
Alter: 33
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:38
Titel

Antworten mit Zitat Zum Seitenanfang

ha ich glaub das liegt wirklich an den Rahmen.
wenn ich die auskommentiere schaut es so aus als stimmt es.
und IExplorer und Firefox geben das selbe aus.

kann doch nicht war sein.
ich brauche die rahmen doch.
  View user's profile Private Nachricht senden
Zeithase

Dabei seit: 09.05.2005
Ort: Erfurt
Alter: 32
Geschlecht: Männlich
Verfasst Fr 28.10.2005 08:39
Titel

Antworten mit Zitat Zum Seitenanfang

Nur mal so zur Info: Beim Doctype XHTML 1.0 Transitional ist's im Internet Explorer auch nicht richtig. Ich verstehe immernoch nicht, warum Du da jedesmal extra einen Rahmen drumherum basteln willst.
  View user's profile Private Nachricht senden
 
Ähnliche Themen css problemchen
CSS, InternetExplorer und oxytoca :-(
CSS / HTML Problemchen
CSS Menue wird im Internetexplorer nicht angezeigt!
CSS + Internetexplorer + overflow: auto + höhenangabe
CSS Probleme im Internetexplorer - brauche mal eure Hilfe :)
Neues Thema eröffnen   Neue Antwort erstellen Seite: 1, 2  Weiter
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.