mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Do 08.12.2016 05:35 Benutzername: Passwort: Auto-Login

Thema: [CSS] Auslagern in externe Datei funktioniert nicht vom 14.08.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Allgemeines - Nonprint -> [CSS] Auslagern in externe Datei funktioniert nicht
Autor Nachricht
TeisT
Threadersteller

Dabei seit: 18.03.2003
Ort: -
Alter: 35
Geschlecht: Männlich
Verfasst So 14.08.2005 15:54
Titel

[CSS] Auslagern in externe Datei funktioniert nicht

Antworten mit Zitat Zum Seitenanfang

Tachchen!

Ich bin gerade dabei einem bekannten etwas mit seiner Seite zu helfen... Die Seite soll möglichst mit CSS erstellt werden. Ich habe mal angefangen die Dateien in DIVs zu werfen und wollte diese später mit einer externen CSS-Datei verlinken. Aber irgendwie will er das nicht...

Code:
<html>

   <head>
      <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
      <meta name="generator" content="Adobe GoLive">
      <title>Unbenannte Seite</title>
      <link href="(EmptyReference!)" rel="stylesheet" type="text/css" media="all">
      <style type="text/css" media="screen"><!--
#HG   { background-color: #fabc00; visibility: visible; position: absolute; top: 40%; left: 0; width: 100%; height: 91px }
#swf  { background-color: #747376; visibility: visible; position: absolute; top: 0; left: 150px; width: 440px; height: 75px }
#Logo  { background-image: url("Bilder/logo_va.gif"); visibility: visible; position: absolute; top: -85px; left: 5px; width: 150px; height: 75px }
#TAB      { background: #fabc00 url("Bilder/TAB_91px.gif"); visibility: visible; position: absolute; top: 0; left: 700px; width: 118px; height: 91px }
#poliert   { background-image: url("Bilder/poliert.gif"); visibility: visible; position: absolute; top: 130px; left: 215px; width: 340px; height: 40px }
#claim  { background-image: url("Bilder/claim.gif"); background-repeat: no-repeat; visibility: visible; position: absolute; top: -70px; left: 215px; width: 290px; height: 45px }
--></style>

   </head>

   <body bgcolor="#ffffff">
      <div id="HG">
         <div id="swf">
            <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" height="91" width="520">
               <param name="movie" value="flash/startseite.swf">
               <param name="quality" value="best">
               <param name="play" value="true">

               <embed height="91" pluginspage="http://www.macromedia.com/go/getflashplayer" src="flash/startseite.swf" type="application/x-shockwave-flash" width="520" quality="best" play="true">
            </object></div>
         <div id="Logo"></div>
         <div id="claim"></div>
         <div id="TAB"></div>
         <div id="poliert"></div>
      </div>
      <p></p>
   </body>

</html>


Wieso bekomme ich da Zeug nicht ausgelagert? *Whaazzzz uppp?*


Zuletzt bearbeitet von shakadi am Mo 15.08.2005 10:09, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
m
Moderator

Dabei seit: 18.11.2004
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.08.2005 16:43
Titel

Antworten mit Zitat Zum Seitenanfang

Code:
<html>

   <head>
      <meta http-equiv="content-type" content="text/html;charset=iso-8859-1">
      <meta name="generator" content="Adobe GoLive">
      <title>Unbenannte Seite</title>
      <link href="style.css" rel="stylesheet" type="text/css" media="all">


   </head>

   <body bgcolor="#ffffff">
      <div id="HG">
         <div id="swf">
            <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" height="91" width="520">
               <param name="movie" value="flash/startseite.swf">
               <param name="quality" value="best">
               <param name="play" value="true">

               <embed height="91" pluginspage="http://www.macromedia.com/go/getflashplayer" src="flash/startseite.swf" type="application/x-shockwave-flash" width="520" quality="best" play="true">
            </object></div>
         <div id="Logo"></div>
         <div id="claim"></div>
         <div id="TAB"></div>
         <div id="poliert"></div>
      </div>
      <p></p>
   </body>

</html>



style.css

Code:
#HG   { background-color: #fabc00; visibility: visible; position: absolute; top: 40%; left: 0; width: 100%; height: 91px }
#swf  { background-color: #747376; visibility: visible; position: absolute; top: 0; left: 150px; width: 440px; height: 75px }
#Logo  { background-image: url("Bilder/logo_va.gif"); visibility: visible; position: absolute; top: -85px; left: 5px; width: 150px; height: 75px }
#TAB      { background: #fabc00 url("Bilder/TAB_91px.gif"); visibility: visible; position: absolute; top: 0; left: 700px; width: 118px; height: 91px }
#poliert   { background-image: url("Bilder/poliert.gif"); visibility: visible; position: absolute; top: 130px; left: 215px; width: 340px; height: 40px }
#claim  { background-image: url("Bilder/claim.gif"); background-repeat: no-repeat; visibility: visible; position: absolute; top: -70px; left: 215px; width: 290px; height: 45px }


Gruß
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
TeisT
Threadersteller

Dabei seit: 18.03.2003
Ort: -
Alter: 35
Geschlecht: Männlich
Verfasst So 14.08.2005 18:02
Titel

Antworten mit Zitat Zum Seitenanfang

* Keine Ahnung... *

So hatte ich das auch probiert. Aber es wird nicht angezeigt! * Mmmh, lecker... *
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.08.2005 18:27
Titel

Antworten mit Zitat Zum Seitenanfang

Datt is eine ganz klasse Ansage mit der man super helfen kann ..
watt genau .. funktioniert nur die striktur trennung nicht ... oder
oder oder ...
  View user's profile Private Nachricht senden
TeisT
Threadersteller

Dabei seit: 18.03.2003
Ort: -
Alter: 35
Geschlecht: Männlich
Verfasst So 14.08.2005 18:46
Titel

Antworten mit Zitat Zum Seitenanfang

Menno! was soll ich den noch sagen wenn ich nicht weiß woran es liegt.

Hab's aber herausgefunden. Klappt nun alles wunderbar!

Trotzdem danke!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
dastef

Dabei seit: 03.11.2003
Ort: -
Alter: -
Geschlecht: Männlich
Verfasst So 14.08.2005 20:14
Titel

Antworten mit Zitat Zum Seitenanfang

Ganz einfach .. was nach der umstellung von deinem aktuellen
source auf die umstellung des vorgeschlagenen nicht mehr
funktioniert. funktioniert's komplett oder komplett nicht, oder
nur teilweise .. oder oder oder.

irgendwas musste ja jetzt auch geändert haben - sonst würd's
ja jetzt auch nicht funktionieren wa?
  View user's profile Private Nachricht senden
TeisT
Threadersteller

Dabei seit: 18.03.2003
Ort: -
Alter: 35
Geschlecht: Männlich
Verfasst So 14.08.2005 20:26
Titel

Antworten mit Zitat Zum Seitenanfang

Die CSS Anweisungen die bei mir oben im Header stehen ließen sich am Amfang zwar exportieren aber die internen css Anweisungen später nicht (über den GoLive CSS Editor – Ebenen können nicht gelöscht werden) löschen.

Wenn ich es aber per Hand aus dem Quellcode lösche geht's...
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen EBAY - CSS / JS -> auslagern?
CSS - Tabellenformate auslagern & Frameersatz
[CSS] Kann man ein komplettes Menü auslagern?
externe swf funktioniert nicht richtig
Preloader für externe Datei
Externe .txt oder .rtf Datei in (X)HTML einbinden
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Allgemeines - Nonprint


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.