mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 04.12.2016 17:44 Benutzername: Passwort: Auto-Login

Thema: FLASH und XML mit HTML-TAGS PROBLEM vom 28.10.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> FLASH und XML mit HTML-TAGS PROBLEM
Autor Nachricht
mikesch
Threadersteller

Dabei seit: 15.04.2002
Ort: Leverkusen
Alter: 40
Geschlecht: Männlich
Verfasst Sa 28.10.2006 15:07
Titel

FLASH und XML mit HTML-TAGS PROBLEM

Antworten mit Zitat Zum Seitenanfang

Hallo ihr lieben, habe ein denke ich mal kleineres Problem
Folgendes hat sich bei mir egeben. Ich lade einen Text(inklusive <br/> und <img />) aus eiener XML in ein FLASH - TEXTFELD. Es wird auch alles richtig dargestellt aber ich bekomme nach jedem tag ein Komma angezeigt im FLASH-TEXTFELD.

Das XML wird mit ignorWhite=true geladen und das Textfeld steht auf html=true und multiline=true und der text wird

über
Code:
mytextfield.htmlText=XML.childnodes
eingefügt.

also eingentlich st alles richtig es werde halt nur da wo ein <br/> oder ein <img/> steht zusätlich zm bild oder zeilenumbruch ein komma eingefügt. finde in den referenen keine passenden fehlerproblemlösunen und auch hier im Forum leider nicht..


Danke für die hilfe..

LG Mike


Zuletzt bearbeitet von mikesch am Sa 28.10.2006 16:18, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
public

Dabei seit: 29.11.2004
Ort: Dessau
Alter: 35
Geschlecht: -
Verfasst Sa 28.10.2006 16:00
Titel

Antworten mit Zitat Zum Seitenanfang

so ganz richtig ist dat net....probier ma so
Code:
mytextfield.htmlText=XML.childnodes
  View user's profile Private Nachricht senden
Anzeige
Anzeige
mikesch
Threadersteller

Dabei seit: 15.04.2002
Ort: Leverkusen
Alter: 40
Geschlecht: Männlich
Verfasst Sa 28.10.2006 16:17
Titel

Antworten mit Zitat Zum Seitenanfang

hab ich auch schon... steht auch so nun drin. löst allerdings nicht das problem.. wenn ich mir dir XML ausgeben lasse als Trace, dann sind doch auch schon zusätzlich die komma drin.

hier mal der XML knoten als bsp:
Code:

echo'<VITA NAME="'.utf8_encode("sdfsdsdf").'">
<de>'.utf8_encode("<img src='image.gif' />BLABKABKA<br />BLABLA Str. NN<br />bhjfgsd<br />sdfsdfsdf<br />8678/890809<br /><a href='mailto:sdfsdf@sdfsdf.de'>sdfsdf@sdfsdf.de</a>").'</de>
</VITA>';


der wird durchs PHP erzeugt und im Browser in der vorschau ist auch nicht von den komma zu sehen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
mikesch
Threadersteller

Dabei seit: 15.04.2002
Ort: Leverkusen
Alter: 40
Geschlecht: Männlich
Verfasst Sa 28.10.2006 16:27
Titel

gelöst

Antworten mit Zitat Zum Seitenanfang

musste nur hinter den childNodes ein .join(""); anhängen.

is klar.. childNodes beschreibt ja auch nen Array ... * Ich geb auf... * * Ich geb auf... * * Ich geb auf... * * Ich geb auf... *


also die zuordnung dann über

Code:
mytextfield.htmlText=XML.childnodes.join("")
* Applaus, Applaus * * Applaus, Applaus * * Applaus, Applaus * * Applaus, Applaus *

danke an alle, die sich damit auseinandergesetzt haben...

LG Mike
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
quicksilver79

Dabei seit: 15.11.2006
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 15.11.2006 08:40
Titel

Antworten mit Zitat Zum Seitenanfang

Wahnsinn! Du hast mir riesig geholfen!
  View user's profile Private Nachricht senden
 
Ähnliche Themen XML mit HTML-Tags will nicht in Flash-Textfeld bzw. Variable
Brauche Hilfe bei flash/xml/html problem
Text aus XML wird in Flash nicht als Html gerendert
Flash + Xml Problem
Flash + XML Encoding Problem (Umlaute)
Flash-XML Problem mit Text auslesen!
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.