mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mi 07.12.2016 12:06 Benutzername: Passwort: Auto-Login

Thema: [Flash] Problem mit loadmovie /Bilder reinladen vom 13.08.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [Flash] Problem mit loadmovie /Bilder reinladen
Seite: Zurück  1, 2
Autor Nachricht
buff-daddy
Threadersteller

Dabei seit: 12.03.2003
Ort: Hamburg
Alter: 35
Geschlecht: Männlich
Verfasst Mo 14.08.2006 08:16
Titel

Antworten mit Zitat Zum Seitenanfang

Danke, ein paar Sachen sind mir fremd aber die werde ich in der Flash Hilfe nachschlagen.

Zuletzt bearbeitet von buff-daddy am Mo 14.08.2006 08:16, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Mo 14.08.2006 10:47
Titel

Antworten mit Zitat Zum Seitenanfang

Also, wenn sonst das Script ausgeführt wird, gibt es die Instanz "bild1_btn" noch nicht. Deswegen hab ich alles in ne Schleife gepakt, welche proportial zur Framerate durchlaufen wird, auch dann, wenn der externe Film mit der Instanz "bild1_btn" geladen ist.
Die Schleife ist in einer Initialisierungsfunktion verpackt, welche nach dem Aufruf der restlichen Buttons aufgerufen wird. Soweit klar?

Wie Flaming Art schon gesagt hat. Man kann per MovieClip-Loader-Klasse viel komfortabler arbeiten. Schaus dir mal an!
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Anzeige
Anzeige
buff-daddy
Threadersteller

Dabei seit: 12.03.2003
Ort: Hamburg
Alter: 35
Geschlecht: Männlich
Verfasst Mo 14.08.2006 11:57
Titel

Antworten mit Zitat Zum Seitenanfang

Code:
this.set1_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set1.swf", container);
   initBtn();
};
this.set2_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set2.swf", container);
   initBtn();
};
this.set3_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set3.swf", container);
   initBtn();
};
function initBtn() {
   this.onEnterFrame = function() {
      this.container.bild1_btn.onPress = function() {
         _root.createEmptyMovieClip("bilder", 2);
         bilder._x = 509;
         bilder._y = 270;
         loadMovie("image1.jpg", bilder);
      };
      delete this.onEnterFrame;
   };
}
stop();


Damit klappt es leider auch nicht. Trotzdem danke für die Hilfe und ich werde mir die MovieClip-Loader-Klasse mal anschauen.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Mo 14.08.2006 11:58
Titel

Antworten mit Zitat Zum Seitenanfang

buff-daddy hat geschrieben:
Code:
this.set1_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set1.swf", container);
   initBtn();
};
this.set2_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set2.swf", container);
   initBtn();
};
this.set3_btn.onPress = function() {
   _root.createEmptyMovieClip("container", 1);
   container._x = 463;
   container._y = 300;
   loadMovie("set3.swf", container);
   initBtn();
};
function initBtn() {
   this.onEnterFrame = function() {
      this.container.bild1_btn.onPress = function() {
         _root.createEmptyMovieClip("bilder", 2);
         bilder._x = 509;
         bilder._y = 270;
         loadMovie("image1.jpg", bilder);
      };
      delete this.onEnterFrame;
   };
}
stop();


Damit klappt es leider auch nicht. Trotzdem danke für die Hilfe und ich werde mir die MovieClip-Loader-Klasse mal anschauen.


Bei mir klappts.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
buff-daddy
Threadersteller

Dabei seit: 12.03.2003
Ort: Hamburg
Alter: 35
Geschlecht: Männlich
Verfasst Mo 14.08.2006 13:39
Titel

Antworten mit Zitat Zum Seitenanfang

Ahh, jetzt gehts auch bei mir. Supi * Ich bin unwürdig *
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [Flash MX] Problem mit Preloader für LoadMovie
[Flash AS2] loadmovie problem
Externen Text in Flash reinladen
[flash mx] hilfe bei .txt-file per actionscript reinladen
[flash] LoadMovie mit Variablen
flash loadmovie und print
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.