mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Mo 05.12.2016 05:55 Benutzername: Passwort: Auto-Login

Thema: [Flash MX] Problem mit LoadVariableNum vom 09.11.2004


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [Flash MX] Problem mit LoadVariableNum
Autor Nachricht
BlankPromise
Threadersteller

Dabei seit: 29.09.2004
Ort: München
Alter: 30
Geschlecht: Männlich
Verfasst Di 09.11.2004 14:51
Titel

[Flash MX] Problem mit LoadVariableNum

Antworten mit Zitat Zum Seitenanfang

Hallo Flashworker,

jetzt bin ichs schon wieder. ich habe mal wieder ein Problem. Es geht um folgendes:

Eine Flashhomepage. Die Navigation befindet sich im Flashfilm "index.swf" in den die einzelnen Content-Filme via LoadMovie eingeladen werden. Diese Filme beinhalten je einen Scrolltext, der mit der besagten Aktion (LoadVariableNum) in das Textfeld eingeladen wird. Wenn man den Film "aktuelles.swf" (besagter Content-Film) im Browser öffnet, fuktioniert alles einwandfrei. Der Text läßt sich scrollen und die Formatierungen sind auch vorhanden. Nur wenn dieser Film in "index.swf" (Film mit der Navigation) geladen wird, wird der Text des Content-Films nicht mehr geladen *Schnief* warum?

Hab mal was hochgeladen:
Homepage (index.swf)
Es geht um den Navigationspunkt "Aktuelles"

Content-Film "aktuelles.swf"

Ich bin für jede Antwort und Hilfe dankbar.

Ben from Blank Promise
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
Terrabyte

Dabei seit: 20.10.2003
Ort: -
Alter: 45
Geschlecht: Männlich
Verfasst Di 09.11.2004 15:06
Titel

Antworten mit Zitat Zum Seitenanfang

zeig mal dein AS bitte damit man sich hier ein besseres bild machen kann
  View user's profile Private Nachricht senden
Anzeige
Anzeige
BlankPromise
Threadersteller

Dabei seit: 29.09.2004
Ort: München
Alter: 30
Geschlecht: Männlich
Verfasst Di 09.11.2004 15:10
Titel

Antworten mit Zitat Zum Seitenanfang

As zum laden des Contentfilms:
Code:

ladeziel.loadMovie("001_aktuelles/aktuelles.swf");
ladestatus();
loader._visible = false;
ladestatus = function () { loader.onEnterFrame = function() {geladen = _root.ladeziel.getBytesLoaded();zuladen = _root.ladeziel.getBytesTotal();if (geladen>=10) {loader._visible = true;prozent = Math.round(geladen/zuladen*100);this.prozentanzeige.text = prozent+" Prozent geladen";this.balken._xscale = prozent;if (prozent>=100) {delete this.onEnterFrame;this._visible = false;}}};};
v;


As zum laden des ScrollTextes:
Code:

loadVariablesNum("aktuelles.txt", 0);
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
l'Audiophile

Dabei seit: 16.09.2004
Ort: Berlin
Alter: 35
Geschlecht: Männlich
Verfasst Do 18.11.2004 15:41
Titel

Antworten mit Zitat Zum Seitenanfang

BlankPromise hat geschrieben:

As zum laden des ScrollTextes:
Code:

loadVariablesNum("aktuelles.txt", 0);


Bin gerade schnell über dein Sript geflogen und mir ist aufgefallen, dass du noch eine alte Syntax benutzt.

"loadVariables" und "loadVariablesNum" sind sehr alte Scriptelemente und werden daher i.d.R. nicht, oder selten benutzt. Häufig entstehen dort die Fehler.
Versuch das Ganze mal mit "LoadVars" zu bewältigen.

Gruß PeJot
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [Flash 8] - Problem: Popup aus Flash mit Übergabe einer Var
[Flash] - Dickes Problem mit Flash Player 9
Problem mit flash player 10 und flash video
Flash-Problem.
flash-problem -
Flash Problem mit IE
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.