mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 11.12.2016 07:07 Benutzername: Passwort: Auto-Login

Thema: [Flash 8] 1 Problem und 2 Fragen vom 07.03.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Multimedia -> [Flash 8] 1 Problem und 2 Fragen
Seite: Zurück  1, 2
Autor Nachricht
fickerei

Dabei seit: 06.03.2006
Ort: -
Alter: -
Geschlecht: -
Verfasst Mi 08.03.2006 18:01
Titel

Antworten mit Zitat Zum Seitenanfang

Frag bei www.flashforum.de, die haben es drauf!
  View user's profile Private Nachricht senden
213db

Dabei seit: 20.09.2005
Ort: Nuremberg +/- 30km
Alter: 30
Geschlecht: Weiblich
Verfasst Mi 08.03.2006 18:38
Titel

Antworten mit Zitat Zum Seitenanfang

oh,sorry pocko,das hab ich total vergessen:

benutz mal diese variante:

Code:
this.onData = function() {
     /*
       Deinen Code hier einfügen;
       Der Unterschied zu der onEnterFrame-Methode ist,
       das hier jedesmal wenn eine Datenportion geladen wird,
       dieser Eventtrigger ausgeführt wird. Das Resultat ist ein absolut
       smoother preloader. Wenn du Beispielsweise das 6000er dsl hast und
       die seite lädst,dann kann es sein,dass während der onEnterFrame-Event
       das erste mal ausgeführt wird,die komplette datenmenge bereits transferiert wurde
       und du den ladebalken theoretisch nur den bruchteil einer sekunde siehst
       ehe er wieder verschwindet.
    */
}


diese variante hatte moock in asdg beschrieben.
cheers...
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Pocko
Threadersteller

Dabei seit: 01.09.2004
Ort: Zürich
Alter: 31
Geschlecht: Männlich
Verfasst Do 09.03.2006 00:36
Titel

Antworten mit Zitat Zum Seitenanfang

213db hat geschrieben:
oh,sorry pocko,das hab ich total vergessen:

benutz mal diese variante:

Code:
this.onData = function() {
     /*
       Deinen Code hier einfügen;
       Der Unterschied zu der onEnterFrame-Methode ist,
       das hier jedesmal wenn eine Datenportion geladen wird,
       dieser Eventtrigger ausgeführt wird. Das Resultat ist ein absolut
       smoother preloader. Wenn du Beispielsweise das 6000er dsl hast und
       die seite lädst,dann kann es sein,dass während der onEnterFrame-Event
       das erste mal ausgeführt wird,die komplette datenmenge bereits transferiert wurde
       und du den ladebalken theoretisch nur den bruchteil einer sekunde siehst
       ehe er wieder verschwindet.
    */
}


diese variante hatte moock in asdg beschrieben.
cheers...


Hi

Habs mal ausprobiert, funktioniert leider immernoch nicht :/
Hab herausgefunden, dass wenn ich onData verwende er erst nachdem die Daten fertig geladen wurden in diese Funktion springt


Gruss
Pocko
  View user's profile Private Nachricht senden
213db

Dabei seit: 20.09.2005
Ort: Nuremberg +/- 30km
Alter: 30
Geschlecht: Weiblich
Verfasst Do 09.03.2006 00:48
Titel

Antworten mit Zitat Zum Seitenanfang

so,ich habe gerade nochmal nachgeschlagen.
in der tat ändert onData nichts an der situation,
aber dass onData getriggert wird nachdem alle
daten geladen wurden stimmt auch nicht.
das is bei onLoad so - das wird getriggert nachdem
die daten geladen wurden und der mc beginnt
abzuspielen.

dann lass es bei der getBytesLoaded/-Total variante.
dass der ladebalken erst bei 30prozent anfängt is
dann korrekt so. erstens testest du den film ja auf
der lokalen festplatte und hast somit einen unrealistisch
hohes transfervolumen. wenn du den film aus flash testest,
dann kann du oben ium menü eine testbandbreite (56k modem,dsl,etc...)
auswählen und die simulieren. dann siehste auch,dass der
balken bei 56k beispielsweise bei null beginnt.

dass is dann korrekt so. sorry für die verwirrung...
  View user's profile Private Nachricht senden
Pocko
Threadersteller

Dabei seit: 01.09.2004
Ort: Zürich
Alter: 31
Geschlecht: Männlich
Verfasst Do 09.03.2006 00:57
Titel

Antworten mit Zitat Zum Seitenanfang

Hallo


Kein Problem, bin dankbar für jede Hlfe Lächel
Hab den Film bisher immer aus Flash getestet, jedoch habe ich es jetzt so gelöst dass ich einfach das Logo rausgenommen habe -> Preloader wird schon bei 0% angezeigt Lächel


MfG
Pocko


Zuletzt bearbeitet von Pocko am Do 09.03.2006 00:57, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
213db

Dabei seit: 20.09.2005
Ort: Nuremberg +/- 30km
Alter: 30
Geschlecht: Weiblich
Verfasst Do 09.03.2006 01:00
Titel

Antworten mit Zitat Zum Seitenanfang

nun gut...is dann zwar net so die elegante lösung,aber okay.


peter
  View user's profile Private Nachricht senden
 
Ähnliche Themen Fragen zu Flash MX
weitere Fragen zu einer Flash-Weiche
Grundlegende Flash Animations Fragen!
Fragen rund um XML, Flash und Dynamische Container
[Flash 8] - Problem: Popup aus Flash mit Übergabe einer Var
[Flash] - Dickes Problem mit Flash Player 9
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2
MGi Foren-Übersicht -> Multimedia


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.