mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Sa 10.12.2016 12:22 Benutzername: Passwort: Auto-Login

Thema: [Excel] Richtig runden vom 27.03.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Hard- und Software -> [Excel] Richtig runden
Seite: Zurück  1, 2
Autor Nachricht
spass-digga

Dabei seit: 29.04.2006
Ort: Ballenstedt
Alter: 36
Geschlecht: Männlich
Verfasst Mo 28.08.2006 09:19
Titel

Antworten mit Zitat Zum Seitenanfang

Das geht zum Beispiel so:

=WENN(AUFRUNDEN(A1;0)-A1<0,5;AUFRUNDEN(A1;0);AUFRUNDEN(A1;0)-0,5)

in A1 steht wieder der Wert, der gerundet werden soll.

Gruß
Rudi
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
worshipper
Threadersteller

Dabei seit: 01.10.2004
Ort: worshipper fear satan
Alter: -
Geschlecht: Männlich
Verfasst Mo 28.08.2006 11:03
Titel

Antworten mit Zitat Zum Seitenanfang

hallo,

möchte gern aufrunden bzw. abrunden und war z. B. 1,43 zu 1,45 und 1,46 zu 1,5, also immer auf 0,05 bzw. auf zehner

hab dazu folgende formel:

Code:
=(RUNDEN((A1*100/5);0)*5)/100


bei 6,46 macht er mir aber 6,45 ... das kann doch so nicht stimmen.

was ist falsch?


Zuletzt bearbeitet von worshipper am Mo 28.08.2006 11:36, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Anzeige
Anzeige
spass-digga

Dabei seit: 29.04.2006
Ort: Ballenstedt
Alter: 36
Geschlecht: Männlich
Verfasst Mo 28.08.2006 12:29
Titel

Antworten mit Zitat Zum Seitenanfang

Die Formel, die ich dir oben für dein anderes Problem genannt habe, kannst du für diese Aufgabe entsprechend anpassen:

=WENN(AUFRUNDEN(A1;1)-A1<0,05;AUFRUNDEN(A1;1);AUFRUNDEN(A1;1)-0,05)

Damit wird 6,43 z.B. auf 6,45 gerundet und 6,46 auf 6,5 ....

Teste es einfach mal.

Gruß
Rudi

//EDIT: Deine Formel kommt auch auf das Ergebnis, wenn du sie wie folgt änderst:

(AUFRUNDEN((A1*100/5);0)*5)/100

Die widersprichst dir: einerseits sagst du, du willst auf bzw. abrunden auf volle 0,05 andererseits
passt dir die Rundung von 6,46 auf 6,45 nicht ... was aber einer korrekten Abrundung auf volle 0,05
bedeutet. Was du willst ist generell Aufrunden auf volle 0,05 und das geht mit den beiden Formeln die ich dir hier gepostet habe.

Viel Erfolg.


Zuletzt bearbeitet von spass-digga am Mo 28.08.2006 13:13, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [excel] WTF?
Maßangaben in Excel
Excel-Frage
Excel-Tabellen
Excel Frage
[Excel] Formelprobleme?
Neues Thema eröffnen   Neue Antwort erstellen Seite: Zurück  1, 2
MGi Foren-Übersicht -> Hard- und Software


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.