mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: So 04.12.2016 03:25 Benutzername: Passwort: Auto-Login

Thema: Was mache ich hier falsch? vom 06.12.2006


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Programmierung -> Was mache ich hier falsch?
Autor Nachricht
Gisa88
Threadersteller

Dabei seit: 06.12.2006
Ort: Altenstadt
Alter: -
Geschlecht: Weiblich
Verfasst Mi 06.12.2006 20:20
Titel

Was mache ich hier falsch?

Antworten mit Zitat Zum Seitenanfang

*Schnief* Hallo Ihr Profis,

ich möchte eine weihnachts.html per Email versenden. Ich habe diese in php eingebaut (bin, was php anbetrifft, absoluter Laie), diese auf meinen Server geladen und versandt. Leider wird die Dynamik, wie sie in der html-Ausführung einwandfrei ausgeführt wird, nicht ausgeführt..Wo liegt der Fehler?? Für Eure Hilfe wäre ich dankbar.



Code:
<?php

$Empfaenger = "mein.name@t-online.de";
$Betreff = "Frohe Weihnachten";

$Nachricht = "
<html>
<head>
<title>Weihnachsgrüße</title>

<style type=text/css>
body { background-image:url('http://www.meine-seite.de/sterne.jpg') }#tx { color:black;
font-size:80;
text-align:center }
#vorne { position:absolute;
background-image:url('http://www.meine-seite.de/h1.jpg') ; top:0;
left:0;
z-index:1;
filter:progid:DXImageTransform.Microsoft.Chroma(color=#000000) }
#s1 { position:absolute;
left:0;
top:0 }
#s2 { position:absolute;
right:0;
bottom:0 }
#s3 { position:absolute;
left:20;
top:20 }
</style>

</head>
<body scroll=no>
<div id=vorne>
<p id=tx> Frohe Weihnachten</p>
<img id=s1 src=http://www.mein-name.de/weihnachten/stern1.gif></img>
<img id=s2 src=http://www.mein-name.de/weihnachten/stern1.gif></img>
<img id=s3 src=http://www.mein-name.de/weihnachten/stern1.gif></img>
<br><br><br>
<p id=tx> wünschen von Herzen</p><br><br><br>
<br><br><br><br><br><br><br><br><br><br><br><br><br><br><br>
<p id=tx> Gisa und Hans-Jürgen</p>
</div>
</body>
<script language=vbscript>
x=0
";

$Header = "MIME-Version: 1.0\n";
$Header .= "Content-type: text/html; charset=iso-8859-1\n";
$Header .= "From: Gisa und Hans-Jürgen <mein.name@t-online.de>\n";

mail($Empfaenger, $Betreff, $Nachricht, $Header);

?>


Gruß Gisa


Zuletzt bearbeitet von Mischpult am Mi 06.12.2006 21:30, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden
Backware

Dabei seit: 09.12.2004
Ort: bei Köln
Alter: 31
Geschlecht: Männlich
Verfasst Mi 06.12.2006 20:23
Titel

DAS machst du hier falsch.

Antworten mit Zitat Zum Seitenanfang

Gisa88 hat geschrieben:
*Schnief* Hallo Ihr Profis,

ich möchte eine weihnachts.html per Email versenden. Ich habe diese in php eingebaut (bin, was php anbetrifft, absoluter Laie), diese auf meinen Server geladen und versandt. Leider wird die Dynamik, wie sie in der html-Ausführung einwandfrei ausgeführt wird, nicht ausgeführt..Wo liegt der Fehler?? Für Eure Hilfe wäre ich dankbar.
  View user's profile Private Nachricht senden
Anzeige
Anzeige
Gisa88
Threadersteller

Dabei seit: 06.12.2006
Ort: Altenstadt
Alter: -
Geschlecht: Weiblich
Verfasst Mi 06.12.2006 20:41
Titel

Antworten mit Zitat Zum Seitenanfang

Sorry, habe ich nicht verstanden. Geht es mit ein paar Worten mehr????

Gisa
  View user's profile Private Nachricht senden
bluespoon

Dabei seit: 10.11.2006
Ort: Hannover
Alter: 33
Geschlecht: Männlich
Verfasst Do 07.12.2006 10:40
Titel

..?

Antworten mit Zitat Zum Seitenanfang

Kann's sein, dass Du tatsächlich ein t-online Formular
genommen hast, welchses bereits vorgefertigt war?
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
pRiMUS

Dabei seit: 09.09.2003
Ort: Vienna
Alter: 41
Geschlecht: Männlich
Verfasst Do 07.12.2006 10:58
Titel

Antworten mit Zitat Zum Seitenanfang

du kannst kein html kram in php einbetten so ohne weiteres. am besten du befasst dich erstmal mit den grundlegenden funktionen von php oder beauftragst jemanden der dir das macht was du möchtest.

weil so wie du das da vor hast gehts nicht.

falsch
Code:

<?php
$foo = "bar";
<html>
...
</html>
?>


richtig
Code:

<?php
$foo = "bar";
?>
<html>
...
</html>
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
tacker

Dabei seit: 22.03.2002
Ort: Offenbach am Main
Alter: 36
Geschlecht: Männlich
Verfasst Do 07.12.2006 12:30
Titel

Antworten mit Zitat Zum Seitenanfang

Dein Nachrichten-Quelltext ist auch invalide.
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
 
Ähnliche Themen [Flash] Was mache ich falsch?
Preloader...was mache ich falsch?
Was mache ich falsch mit meiner Div-Verlinkung?
Was mache ich beim speichern als png. file falsch?
Wie mache ich so ein script?
Wie mache ich so einen 3D-Style bei Fonts?
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Programmierung


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.