mediengestalter.info
FAQ :: Mitgliederliste :: MGi Team

Willkommen auf dem Portal für Mediengestalter

Aktuelles Datum und Uhrzeit: Fr 09.12.2016 01:28 Benutzername: Passwort: Auto-Login

Thema: problem mit rollover und target vom 29.09.2005


Neues Thema eröffnen   Neue Antwort erstellen MGi Foren-Übersicht -> Programmierung -> problem mit rollover und target
Autor Nachricht
liane
Threadersteller

Dabei seit: 10.05.2002
Ort: köln
Alter: 36
Geschlecht: Weiblich
Verfasst Do 29.09.2005 10:30
Titel

problem mit rollover und target

Antworten mit Zitat Zum Seitenanfang

hallo.

ich habe folgendes problem.

ich habe einen rollover button, der auf einen iframe verweist. target ist also der iframe.

sobald ich aber als target den namen des frames eingebe, funktioniert der rollover effekt nicht mehr!

kann mir jemand helfen?

hier der code:

Code:
<a href="../frames/schwiegermutter/alzheimer_on.html" target="alzheimer" onMouseOver="MM_swapImage('alzheimer','','../func/kreuz_pink_on.gif',1)" onMouseOut="MM_swapImgRestore()"><img src="../func/kreuz_pink_off.gif" alt="alzheimer" name="alzheimer" width="14" height="14" border="0"></a>


danke

[/code]
  View user's profile Private Nachricht senden
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 39
Geschlecht: Männlich
Verfasst Do 29.09.2005 11:15
Titel

Antworten mit Zitat Zum Seitenanfang

das ist nicht der code. das sind nur die funktionsaufrufe...
der wichtige code, das wären die eigentlichen funktionen. aber die brauchst du eigentlich gar nicht zu posten, weil man an den Funktionsnamen schon sehen kann, daß es sich um Macromedia-Funktionen handelt. Die wurden vom Dreamweaver, von Fireworks oder sowas erzeugt.
Da steigt kein Mensch mehr durch. Insofern braucht man die erst gar nicht posten.

Ich geb dir den Tipp: Schreib die Funktionen selbst. Ein Rollover ist gar kein Problem. Ich meine, daß ich da sogar schon mal ein Script gepostet hab, wie's geht. Sind nur ganz wenige Zeilen Code. Mußt mal die Suchfunktion benutzen, wenn du das nicht selber coden kannst...
  View user's profile Private Nachricht senden
Anzeige
Anzeige
powdaer

Dabei seit: 20.11.2002
Ort: Regensburg
Alter: 32
Geschlecht: Weiblich
Verfasst Do 29.09.2005 12:04
Titel

Re: problem mit rollover und target

Antworten mit Zitat Zum Seitenanfang

liane hat geschrieben:


Code:
<a href="../frames/schwiegermutter/alzheimer_on.html" target="alzheimer" onMouseOver="MM_swapImage('[b]alzheimer[/b]','','../func/kreuz_pink_on.gif',1)" onMouseOut="MM_swapImgRestore()"><img src="../func/kreuz_pink_off.gif" alt="alzheimer" name="alzheimer" width="14" height="14" border="0"></a>



[/code]


kann es sein, dass du den target zweimal angibst ?
oder was hat das "alzheimer", dass ich fett gekennzeichnet hab, zu bedeuten?


poste mal code von den mouseover anweisungen.


pow
  View user's profile Private Nachricht senden
liane
Threadersteller

Dabei seit: 10.05.2002
Ort: köln
Alter: 36
Geschlecht: Weiblich
Verfasst Do 29.09.2005 12:45
Titel

Antworten mit Zitat Zum Seitenanfang

also: ich hab das jetzt anders gelöst! habe deswegen aber auch direkt ein anderes problem *zwinker*

benutze jetzt diese js-funktion:

Normal1 = new Image();
Normal1.src = "../func/kreuz_pink_off.gif";
Highlight1 = new Image();
Highlight1.src = "../func/kreuz_pink_on.gif";

function Bildwechsel (Bildnr, Bildobjekt) {
window.document.images[Bildnr].src = Bildobjekt.src;
}

im body sieht das dann so aus:

<a href="../frames/schwiegermutter/lippenherpes.html" target="lippenherpes"
onMouseOver="Bildwechsel(136, Highlight1)"
onMouseOut="Bildwechsel(136, Normal1)"><img src="../func/kreuz_pink_off.gif"
width="14" height="14" border="0" class="kreuz"></a>

jetzt hab ich aber nach dem klicken nen blauen rand der bleibt und nicht schön ist! border ist gleich 0.
weiss jemand rat?

danke
  View user's profile Private Nachricht senden
dante

Dabei seit: 14.02.2004
Ort: NIC
Alter: 31
Geschlecht: Männlich
Verfasst Do 29.09.2005 12:57
Titel

Antworten mit Zitat Zum Seitenanfang

benutze lieber das DOM wenn du bilder mit javascript austauschen willst:

setz klassen in diverse tags, geh in ner schleife durch alle tags filter die raus die du markiert hast und änder dort die bildadresse bei nem onmouseover event.

oder google wenigstens mal danach.


Zuletzt bearbeitet von dante am Do 29.09.2005 12:58, insgesamt 1-mal bearbeitet
  View user's profile Private Nachricht senden Website dieses Benutzers besuchen
rob

Dabei seit: 11.12.2003
Ort: ~/
Alter: 39
Geschlecht: Männlich
Verfasst Do 29.09.2005 15:39
Titel

Antworten mit Zitat Zum Seitenanfang

Zitat:
jetzt hab ich aber nach dem klicken nen blauen rand der bleibt und nicht schön ist! border ist gleich 0.

Stylesheet? Border für visited-Links vergeben..?

Steht noch was in deiner class "kreuz" drin? Ansonsten dürfte es hier keinen Border geben.
  View user's profile Private Nachricht senden
 
Ähnliche Themen Problem mit: Neuem Fenster per target oder JS
[Problem IE6] Link in Popup-Fenster zu Seite mit target
Problem mit JS Rollover
Problem mit Rollover
Problem mit Rollover
Rollover Problem
Neues Thema eröffnen   Neue Antwort erstellen
MGi Foren-Übersicht -> Programmierung


Du kannst keine Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum nicht antworten.
Du kannst an Umfragen in diesem Forum nicht mitmachen.